summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-24 07:02:40 +0100
committerRemi Collet <remi@remirepo.net>2018-01-24 07:02:40 +0100
commitbe64ba3baaf00d3f370f873f1989908badb85218 (patch)
tree6100555513f5cb5312cac3105c83dc32657b589d
parent4ae2e5bccbffd3d3dc73f6d0a2e35ff6d5e195db (diff)
Update to 1.4.0RC1
with libbson and libmongoc 1.9.2
-rw-r--r--REFLECTION7
-rw-r--r--php-pecl-mongodb.spec16
2 files changed, 14 insertions, 9 deletions
diff --git a/REFLECTION b/REFLECTION
index 779c100..910c9c1 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #182 mongodb version 1.4.0beta1 ] {
+Extension [ <persistent> extension #182 mongodb version 1.4.0RC1 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #182 mongodb version 1.4.0beta1 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.4.0beta1 }
+ Constant [ string MONGODB_VERSION ] { 1.4.0RC1 }
Constant [ string MONGODB_STABILITY ] { beta }
}
@@ -1449,10 +1449,11 @@ Extension [ <persistent> extension #182 mongodb version 1.4.0beta1 ] {
Class [ <internal:mongodb> final class MongoDB\Driver\ReadConcern implements MongoDB\BSON\Serializable, MongoDB\BSON\Type ] {
- - Constants [3] {
+ - Constants [4] {
Constant [ public string LOCAL ] { local }
Constant [ public string MAJORITY ] { majority }
Constant [ public string LINEARIZABLE ] { linearizable }
+ Constant [ public string AVAILABLE ] { available }
}
- Static properties [0] {
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 64289e1..1f07436 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-mongodb
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -36,14 +36,14 @@
%global libver 1.9
%else
%global with_syslib 0
-%global libver 1.9.0
+%global libver 1.9.2
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
%global upstream_version 1.4.0
-%global upstream_prever beta1
-%global upstream_lower ~beta1
+%global upstream_prever RC1
+%global upstream_lower ~rc1
Version: %{upstream_version}%{?upstream_lower}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
@@ -133,7 +133,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_MONGODB_VERSION/{s/.* "//;s/".*$//;p}' php_phongo.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -174,11 +173,12 @@ peclbuild() {
--with-libbson \
--with-libmongoc \
--enable-mongodb
-
%else
%configure \
--with-php-config=%{_bindir}/${1}-config \
+ --enable-mongodb-crypto-system-profile \
+ --with-mongodb-sasl \
--enable-mongodb
%endif
@@ -322,6 +322,10 @@ exit $ret
%changelog
+* Fri Dec 22 2017 Remi Collet <remi@remirepo.net> - 1.4.0~rc1-1
+- Update to 1.4.0RC1
+- with libbson and libmongoc 1.9.2
+
* Fri Dec 22 2017 Remi Collet <remi@remirepo.net> - 1.4.0~beta1-1
- Update to 1.4.0beta1
- with libbson and libmongoc 1.9.0