summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-04 08:44:20 +0200
committerRemi Collet <remi@remirepo.net>2019-06-04 08:44:20 +0200
commit383f46afe55fc034a2073181c84395a1a2b1ef0f (patch)
tree6a9211133ac8ef40fe805f56be9875d910c27822
parent558944aa2eb0e39588bf65e0e9e5530c023a62f2 (diff)
- update to 1.6.0alpha2
- with libbson and libmongoc 1.14.0
-rw-r--r--PHPINFO10
-rw-r--r--REFLECTION31
-rw-r--r--php-pecl-mongodb.spec21
3 files changed, 47 insertions, 15 deletions
diff --git a/PHPINFO b/PHPINFO
index 3435773..b03bf70 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.6.0alpha1
+MongoDB extension version => 1.6.0alpha2
MongoDB extension stability => alpha
-libbson headers version => 1.13.0
-libbson library version => 1.13.0
-libmongoc headers version => 1.13.0
-libmongoc library version => 1.13.0
+libbson headers version => 1.14.0
+libbson library version => 1.14.0
+libmongoc headers version => 1.14.0
+libmongoc library version => 1.14.0
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
diff --git a/REFLECTION b/REFLECTION
index a54808f..3389786 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #191 mongodb version 1.6.0alpha1 ] {
+Extension [ <persistent> extension #197 mongodb version 1.6.0alpha2 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #191 mongodb version 1.6.0alpha1 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.6.0alpha1 }
+ Constant [ string MONGODB_VERSION ] { 1.6.0alpha2 }
Constant [ string MONGODB_STABILITY ] { alpha }
}
@@ -2160,7 +2160,7 @@ Extension [ <persistent> extension #191 mongodb version 1.6.0alpha1 ] {
}
}
- Interface [ <internal:mongodb> interface MongoDB\Driver\Exception\Exception ] {
+ Interface [ <internal:mongodb> interface MongoDB\Driver\Exception\Exception extends Throwable ] {
- Constants [0] {
}
@@ -2174,7 +2174,30 @@ Extension [ <persistent> extension #191 mongodb version 1.6.0alpha1 ] {
- Properties [0] {
}
- - Methods [0] {
+ - Methods [8] {
+ Method [ <internal:Core, inherits Throwable> abstract public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Throwable> abstract public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Throwable> abstract public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Throwable> abstract public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Throwable> abstract public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Throwable> abstract public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Throwable> abstract public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Throwable> abstract public method __toString ] {
+ }
}
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 2994aca..107d84c 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -29,21 +29,22 @@
# test suite requires a MongoDB server
%global with_tests 0%{?_with_tests:1}
+# F30 for fedora repo, F27 for remi
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 9
%global with_syslib 1
-%global libver 1.13
+%global libver 1.14
%else
%global with_syslib 0
-%global libver 1.13.0
+%global libver 1.14.0
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
%global upstream_version 1.6.0
-%global upstream_prever alpha1
-%global upstream_lower ~alpha1
+%global upstream_prever alpha2
+%global upstream_lower ~alpha2
Version: %{upstream_version}%{?upstream_lower}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -101,9 +102,13 @@ Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -321,6 +326,10 @@ exit $ret
%changelog
+* Tue Jun 4 2019 Remi Collet <remi@remirepo.net> - 1.6.0~alpha2-1
+- update to 1.6.0alpha2
+- with libbson and libmongoc 1.14.0
+
* Thu Mar 7 2019 Remi Collet <remi@remirepo.net> - 1.6.0~alpha1-2
- rebuild with libicu62