summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-06-26 17:43:25 +0200
committerRemi Collet <remi@remirepo.net>2018-06-26 17:43:25 +0200
commit33fde6a2ab89dfc619179d6d746670fb850f946d (patch)
tree35af0a4a5f927f79b008fd6d7cabaf3c4dbdd99c
parent8db2180f76827584af4275dffa01fa2682fa3868 (diff)
update to 1.5.0
with libbson and libmongoc 1.11.0 add dependency on icu
-rw-r--r--PHPINFO23
-rw-r--r--REFLECTION216
-rw-r--r--php-pecl-mongodb.spec24
3 files changed, 248 insertions, 15 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..46d4735
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,23 @@
+
+mongodb
+
+MongoDB support => enabled
+MongoDB extension version => 1.5.0
+MongoDB extension stability => stable
+libbson headers version => 1.11.0
+libbson library version => 1.11.0
+libmongoc headers version => 1.11.0
+libmongoc library version => 1.11.0
+libmongoc SSL => enabled
+libmongoc SSL library => OpenSSL
+libmongoc crypto => enabled
+libmongoc crypto library => libcrypto
+libmongoc crypto system profile => enabled
+libmongoc SASL => enabled
+libmongoc ICU => enabled
+libmongoc compression => enabled
+libmongoc compression snappy => enabled
+libmongoc compression zlib => enabled
+
+Directive => Local Value => Master Value
+mongodb.debug => no value => no value
diff --git a/REFLECTION b/REFLECTION
index b76a9cf..9075748 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #189 mongodb version 1.4.4 ] {
+Extension [ <persistent> extension #189 mongodb version 1.5.0 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #189 mongodb version 1.4.4 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.4.4 }
+ Constant [ string MONGODB_VERSION ] { 1.5.0 }
Constant [ string MONGODB_STABILITY ] { stable }
}
@@ -70,7 +70,7 @@ Extension [ <persistent> extension #189 mongodb version 1.4.4 ] {
}
}
- - Classes [56] {
+ - Classes [59] {
Interface [ <internal:mongodb> interface MongoDB\BSON\Type ] {
- Constants [0] {
@@ -571,6 +571,54 @@ Extension [ <persistent> extension #189 mongodb version 1.4.4 ] {
}
}
+ Class [ <internal:mongodb> final class MongoDB\BSON\Int64 implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:mongodb> final public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype JsonSerializable> final public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ }
+
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
Class [ <internal:mongodb> final class MongoDB\BSON\Javascript implements MongoDB\BSON\JavascriptInterface, JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
@@ -1722,7 +1770,7 @@ Extension [ <persistent> extension #189 mongodb version 1.4.4 ] {
- Properties [0] {
}
- - Methods [7] {
+ - Methods [11] {
Method [ <internal:mongodb> final public method advanceClusterTime ] {
- Parameters [1] {
@@ -1755,6 +1803,31 @@ Extension [ <persistent> extension #189 mongodb version 1.4.4 ] {
}
}
+ Method [ <internal:mongodb> final public method startTransaction ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $options ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method commitTransaction ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method abortTransaction ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method endSession ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -2090,6 +2163,63 @@ Extension [ <persistent> extension #189 mongodb version 1.4.4 ] {
}
}
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\ServerException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception, Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:mongodb> class MongoDB\Driver\Exception\ConnectionException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception, Throwable ] {
- Constants [0] {
@@ -2147,7 +2277,7 @@ Extension [ <persistent> extension #189 mongodb version 1.4.4 ] {
}
}
- Class [ <internal:mongodb> abstract class MongoDB\Driver\Exception\WriteException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception, Throwable ] {
+ Class [ <internal:mongodb> abstract class MongoDB\Driver\Exception\WriteException extends MongoDB\Driver\Exception\ServerException implements Throwable, MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -2268,7 +2398,7 @@ Extension [ <persistent> extension #189 mongodb version 1.4.4 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\BulkWriteException extends MongoDB\Driver\Exception\WriteException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\BulkWriteException extends MongoDB\Driver\Exception\WriteException implements MongoDB\Driver\Exception\Exception, Throwable ] {
- Constants [0] {
}
@@ -2332,6 +2462,70 @@ Extension [ <persistent> extension #189 mongodb version 1.4.4 ] {
}
}
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\CommandException extends MongoDB\Driver\Exception\ServerException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [5] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> protected $resultDocument ]
+ }
+
+ - Methods [11] {
+ Method [ <internal:mongodb> final public method getResultDocument ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ConnectionTimeoutException extends MongoDB\Driver\Exception\ConnectionException implements Throwable, MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
@@ -2389,7 +2583,7 @@ Extension [ <persistent> extension #189 mongodb version 1.4.4 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ExecutionTimeoutException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception, Throwable ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ExecutionTimeoutException extends MongoDB\Driver\Exception\ServerException implements Throwable, MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -2744,7 +2938,7 @@ Extension [ <persistent> extension #189 mongodb version 1.4.4 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -2775,6 +2969,12 @@ Extension [ <persistent> extension #189 mongodb version 1.4.4 ] {
}
}
+ Method [ <internal:mongodb> final public method getReply ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method getRequestId ] {
- Parameters [0] {
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index cccb077..5c6d314 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -38,15 +38,15 @@
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
%global with_syslib 1
-%global libver 1.9
+%global libver 1.11
%else
%global with_syslib 0
-%global libver 1.9.4
+%global libver 1.11.0
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.4.4
+%global upstream_version 1.5.0
#global upstream_prever RC2
#global upstream_lower ~rc2
Version: %{upstream_version}%{?upstream_lower}
@@ -70,6 +70,8 @@ Provides: bundled(mongo-c-driver) = %{libver}
%endif
BuildRequires: snappy-devel
BuildRequires: zlib-devel
+# We require 50 to ensure use of libicu-last (same version than PHP)
+BuildRequires: libicu-devel >= 50
%if %{with_tests}
BuildRequires: mongodb-server
%endif
@@ -133,7 +135,7 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_MONGODB_VERSION/{s/.* "//;s/".*$//;p}' php_phongo.h)
+extver=$(sed -n '/#define PHP_MONGODB_VERSION /{s/.* "//;s/".*$//;p}' phongo_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
exit 1
@@ -164,21 +166,24 @@ peclbuild() {
%if %{with_syslib}
# Ensure we use system library
# Need to be removed only after phpize because of m4_include
- rm -r src/libbson
rm -r src/libmongoc
%configure \
--with-php-config=%{_bindir}/${1}-config \
--with-libbson \
--with-libmongoc \
- --with-mongodb-sasl \
+ --with-mongodb-sasl=cyrus \
+ --with-mongodb-icu=yes \
+ --with-mongodb-ssl=openssl \
--enable-mongodb
%else
%configure \
--with-php-config=%{_bindir}/${1}-config \
--enable-mongodb-crypto-system-profile \
- --with-mongodb-sasl \
+ --with-mongodb-sasl=cyrus \
+ --with-mongodb-icu=yes \
+ --with-mongodb-ssl=openssl \
--enable-mongodb
%endif
@@ -322,6 +327,11 @@ exit $ret
%changelog
+* Tue Jun 26 2018 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+- with libbson and libmongoc 1.11.0
+- add dependency on icu
+
* Thu Jun 7 2018 Remi Collet <remi@remirepo.net> - 1.4.4-1
- update to 1.4.4