summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-11 07:20:58 +0200
committerRemi Collet <remi@remirepo.net>2017-08-11 07:20:58 +0200
commitf87ed4f50004b4f6c261aeb62284204f990a25ab (patch)
tree725b59c961910008d976334a8905c5fcb2b72fd9
parent1ba344800fb8ce4fcec8fe8434144eb4e23cf203 (diff)
v1.3.0beta1
-rw-r--r--REFLECTION910
-rw-r--r--php-pecl-mongodb.spec44
2 files changed, 767 insertions, 187 deletions
diff --git a/REFLECTION b/REFLECTION
index aa9f834..98a72d5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
+Extension [ <persistent> extension #175 mongodb version 1.3.0beta1 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,8 +14,8 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.2.9 }
- Constant [ string MONGODB_STABILITY ] { stable }
+ Constant [ string MONGODB_VERSION ] { 1.3.0beta1 }
+ Constant [ string MONGODB_STABILITY ] { beta }
}
- Functions {
@@ -27,8 +27,9 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
Function [ <internal:mongodb> function MongoDB\BSON\toPHP ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $bson ]
+ Parameter #1 [ <optional> array $typemap ]
}
}
Function [ <internal:mongodb> function MongoDB\BSON\toJSON ] {
@@ -37,15 +38,39 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
Parameter #0 [ <required> $bson ]
}
}
+ Function [ <internal:mongodb> function MongoDB\BSON\toCanonicalExtendedJSON ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $bson ]
+ }
+ }
+ Function [ <internal:mongodb> function MongoDB\BSON\toRelaxedExtendedJSON ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $bson ]
+ }
+ }
Function [ <internal:mongodb> function MongoDB\BSON\fromJSON ] {
- Parameters [1] {
Parameter #0 [ <required> $json ]
}
}
+ Function [ <internal:mongodb> function MongoDB\Driver\Monitoring\addSubscriber ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\Subscriber $subscriber ]
+ }
+ }
+ Function [ <internal:mongodb> function MongoDB\Driver\Monitoring\removeSubscriber ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\Subscriber $subscriber ]
+ }
+ }
}
- - Classes [38] {
+ - Classes [53] {
Interface [ <internal:mongodb> interface MongoDB\BSON\Type ] {
- Constants [0] {
@@ -111,7 +136,136 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Interface [ <internal:mongodb> interface MongoDB\BSON\Persistable extends MongoDB\BSON\Unserializable, MongoDB\BSON\Serializable, MongoDB\BSON\Type ] {
+ Interface [ <internal:mongodb> interface MongoDB\BSON\BinaryInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:mongodb> abstract public method getData ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method getType ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Interface [ <internal:mongodb> interface MongoDB\BSON\Decimal128Interface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:mongodb> abstract public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Interface [ <internal:mongodb> interface MongoDB\BSON\JavascriptInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:mongodb> abstract public method getCode ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method getScope ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Interface [ <internal:mongodb> interface MongoDB\BSON\MaxKeyInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Interface [ <internal:mongodb> interface MongoDB\BSON\MinKeyInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Interface [ <internal:mongodb> interface MongoDB\BSON\ObjectIDInterface ] {
- Constants [0] {
}
@@ -126,14 +280,112 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
- Methods [2] {
- Method [ <internal:mongodb, inherits MongoDB\BSON\Unserializable> abstract public method bsonUnserialize ] {
+ Method [ <internal:mongodb> abstract public method getTimestamp ] {
- - Parameters [1] {
- Parameter #0 [ <required> array $data ]
+ - Parameters [0] {
}
}
- Method [ <internal:mongodb, inherits MongoDB\BSON\Serializable> abstract public method bsonSerialize ] {
+ Method [ <internal:mongodb> abstract public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Interface [ <internal:mongodb> interface MongoDB\BSON\RegexInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:mongodb> abstract public method getFlags ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method getPattern ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Interface [ <internal:mongodb> interface MongoDB\BSON\TimestampInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:mongodb> abstract public method getIncrement ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method getTimestamp ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Interface [ <internal:mongodb> interface MongoDB\BSON\UTCDateTimeInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:mongodb> abstract public method toDateTime ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method __toString ] {
- Parameters [0] {
}
@@ -141,7 +393,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\Binary implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\Binary implements MongoDB\BSON\BinaryInterface, JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [7] {
Constant [ integer TYPE_GENERIC ] { 0 }
@@ -177,7 +429,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> final public method __toString ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\BinaryInterface> final public method __toString ] {
- Parameters [0] {
}
@@ -202,13 +454,13 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> final public method getData ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\BinaryInterface> final public method getData ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method getType ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\BinaryInterface> final public method getType ] {
- Parameters [0] {
}
@@ -216,7 +468,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\Decimal128 implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\Decimal128 implements MongoDB\BSON\Decimal128Interface, JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
}
@@ -244,7 +496,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> final public method __toString ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\Decimal128Interface> final public method __toString ] {
- Parameters [0] {
}
@@ -271,7 +523,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\Javascript implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\Javascript implements MongoDB\BSON\JavascriptInterface, JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
}
@@ -300,7 +552,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> final public method __toString ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\JavascriptInterface> final public method __toString ] {
- Parameters [0] {
}
@@ -325,13 +577,13 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> final public method getCode ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\JavascriptInterface> final public method getCode ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method getScope ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\JavascriptInterface> final public method getScope ] {
- Parameters [0] {
}
@@ -339,7 +591,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\MaxKey implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\MaxKey implements MongoDB\BSON\MaxKeyInterface, JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
}
@@ -381,7 +633,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\MinKey implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\MinKey implements MongoDB\BSON\MinKeyInterface, JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
}
@@ -423,7 +675,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\ObjectID implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\ObjectID implements MongoDB\BSON\ObjectIDInterface, JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
}
@@ -451,13 +703,13 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> final public method getTimestamp ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\ObjectIDInterface> final public method getTimestamp ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method __toString ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\ObjectIDInterface> final public method __toString ] {
- Parameters [0] {
}
@@ -484,7 +736,37 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\Regex implements MongoDB\BSON\Type, Serializable, JsonSerializable ] {
+ Interface [ <internal:mongodb> interface MongoDB\BSON\Persistable extends MongoDB\BSON\Unserializable, MongoDB\BSON\Serializable, MongoDB\BSON\Type ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:mongodb, inherits MongoDB\BSON\Unserializable> abstract public method bsonUnserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
+ Method [ <internal:mongodb, inherits MongoDB\BSON\Serializable> abstract public method bsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\BSON\Regex implements MongoDB\BSON\RegexInterface, MongoDB\BSON\Type, Serializable, JsonSerializable ] {
- Constants [0] {
}
@@ -513,7 +795,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> final public method __toString ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\RegexInterface> final public method __toString ] {
- Parameters [0] {
}
@@ -538,13 +820,13 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> final public method getPattern ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\RegexInterface> final public method getPattern ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method getFlags ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\RegexInterface> final public method getFlags ] {
- Parameters [0] {
}
@@ -552,7 +834,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\Timestamp implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\Timestamp implements MongoDB\BSON\TimestampInterface, JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
}
@@ -572,7 +854,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [7] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [2] {
@@ -581,7 +863,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> final public method __toString ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\TimestampInterface> final public method __toString ] {
- Parameters [0] {
}
@@ -605,10 +887,51 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
Parameter #0 [ <required> $serialized ]
}
}
+
+ Method [ <internal:mongodb, prototype MongoDB\BSON\TimestampInterface> final public method getIncrement ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype MongoDB\BSON\TimestampInterface> final public method getTimestamp ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Interface [ <internal:mongodb> interface MongoDB\BSON\TypeWrapper ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:mongodb> abstract static public method createFromBSONType ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\BSON\Type $type ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:mongodb> abstract public method toBSONType ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\UTCDateTime implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\UTCDateTime implements MongoDB\BSON\UTCDateTimeInterface, JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
}
@@ -636,7 +959,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> final public method __toString ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\UTCDateTimeInterface> final public method __toString ] {
- Parameters [0] {
}
@@ -661,7 +984,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> final public method toDateTime ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\UTCDateTimeInterface> final public method toDateTime ] {
- Parameters [0] {
}
@@ -669,7 +992,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\Command ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\BulkWrite implements Countable ] {
- Constants [0] {
}
@@ -683,15 +1006,45 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
- Properties [0] {
}
- - Methods [2] {
+ - Methods [6] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [1] {
+ Parameter #0 [ <optional> array or NULL $options ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method insert ] {
+
+ - Parameters [1] {
Parameter #0 [ <required> $document ]
}
}
- Method [ <internal:mongodb> public method __wakeup ] {
+ Method [ <internal:mongodb> final public method update ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $query ]
+ Parameter #1 [ <required> $newObj ]
+ Parameter #2 [ <optional> array or NULL $updateOptions ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method delete ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $query ]
+ Parameter #1 [ <optional> array or NULL $deleteOptions ]
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Countable> final public method count ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
}
@@ -699,7 +1052,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> <iterateable> final class MongoDB\Driver\Cursor implements Traversable ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\Command ] {
- Constants [0] {
}
@@ -713,13 +1066,37 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
- Properties [0] {
}
- - Methods [7] {
- Method [ <internal:mongodb, ctor> final private method __construct ] {
+ - Methods [2] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $document ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
}
}
+ }
+ }
+
+ Class [ <internal:mongodb> <iterateable> final class MongoDB\Driver\Cursor implements Traversable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+ - Methods [7] {
Method [ <internal:mongodb> final public method setTypeMap ] {
- Parameters [1] {
@@ -751,7 +1128,13 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> public method __wakeup ] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
}
@@ -774,19 +1157,19 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
- Methods [3] {
- Method [ <internal:mongodb, ctor> final private method __construct ] {
+ Method [ <internal:mongodb> final public method __toString ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method __toString ] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> public method __wakeup ] {
+ Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
}
@@ -876,7 +1259,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> public method __wakeup ] {
+ Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
}
@@ -907,7 +1290,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> public method __wakeup ] {
+ Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
}
@@ -932,7 +1315,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
- Properties [0] {
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [1] {
@@ -946,6 +1329,12 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
+ Method [ <internal:mongodb> final public method isDefault ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb, prototype MongoDB\BSON\Serializable> final public method bsonSerialize ] {
- Parameters [0] {
@@ -1035,12 +1424,6 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
- Methods [16] {
- Method [ <internal:mongodb, ctor> final private method __construct ] {
-
- - Parameters [0] {
- }
- }
-
Method [ <internal:mongodb> final public method executeCommand ] {
- Parameters [3] {
@@ -1134,67 +1517,13 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> public method __wakeup ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:mongodb> final class MongoDB\Driver\BulkWrite implements Countable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [6] {
- Method [ <internal:mongodb, ctor> final public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> array or NULL $options ]
- }
- }
-
- Method [ <internal:mongodb> final public method insert ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $document ]
- }
- }
-
- Method [ <internal:mongodb> final public method update ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $query ]
- Parameter #1 [ <required> $newObj ]
- Parameter #2 [ <optional> array or NULL $updateOptions ]
- }
- }
-
- Method [ <internal:mongodb> final public method delete ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $query ]
- Parameter #1 [ <optional> array or NULL $deleteOptions ]
- }
- }
-
- Method [ <internal:mongodb, prototype Countable> final public method count ] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> public method __wakeup ] {
+ Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
}
@@ -1217,7 +1546,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [6] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [3] {
@@ -1245,6 +1574,12 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
+ Method [ <internal:mongodb> final public method isDefault ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb, prototype MongoDB\BSON\Serializable> final public method bsonSerialize ] {
- Parameters [0] {
@@ -1268,31 +1603,31 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
- Methods [5] {
- Method [ <internal:mongodb, ctor> final private method __construct ] {
+ Method [ <internal:mongodb> final public method getCode ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method getCode ] {
+ Method [ <internal:mongodb> final public method getInfo ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method getInfo ] {
+ Method [ <internal:mongodb> final public method getMessage ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method getMessage ] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> public method __wakeup ] {
+ Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
}
@@ -1315,37 +1650,37 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
- Methods [6] {
- Method [ <internal:mongodb, ctor> final private method __construct ] {
+ Method [ <internal:mongodb> final public method getCode ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method getCode ] {
+ Method [ <internal:mongodb> final public method getIndex ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method getIndex ] {
+ Method [ <internal:mongodb> final public method getMessage ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method getMessage ] {
+ Method [ <internal:mongodb> final public method getInfo ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method getInfo ] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> public method __wakeup ] {
+ Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
}
@@ -1368,12 +1703,6 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
- Methods [12] {
- Method [ <internal:mongodb, ctor> final private method __construct ] {
-
- - Parameters [0] {
- }
- }
-
Method [ <internal:mongodb> final public method getInsertedCount ] {
- Parameters [0] {
@@ -1434,7 +1763,13 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Method [ <internal:mongodb> public method __wakeup ] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
}
@@ -1460,7 +1795,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\LogicException extends LogicException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\RuntimeException extends RuntimeException implements Throwable, MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1517,7 +1852,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\RuntimeException extends RuntimeException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\ConnectionException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception, Throwable ] {
- Constants [0] {
}
@@ -1574,7 +1909,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\UnexpectedValueException extends UnexpectedValueException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> abstract class MongoDB\Driver\Exception\WriteException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception, Throwable ] {
- Constants [0] {
}
@@ -1585,14 +1920,21 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> protected $message ]
Property [ <default> protected $code ]
Property [ <default> protected $file ]
Property [ <default> protected $line ]
+ Property [ <default> protected $writeResult ]
}
- - Methods [10] {
+ - Methods [11] {
+ Method [ <internal:mongodb> final public method getWriteResult ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -1631,7 +1973,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\InvalidArgumentException extends InvalidArgumentException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\AuthenticationException extends MongoDB\Driver\Exception\ConnectionException implements Throwable, MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1688,7 +2030,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\ConnectionException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception, Throwable ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\BulkWriteException extends MongoDB\Driver\Exception\WriteException implements Throwable, MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1699,14 +2041,21 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> protected $message ]
Property [ <default> protected $code ]
Property [ <default> protected $file ]
Property [ <default> protected $line ]
+ Property [ <default> protected $writeResult ]
}
- - Methods [10] {
+ - Methods [11] {
+ Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\WriteException> final public method getWriteResult ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -1745,7 +2094,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\AuthenticationException extends MongoDB\Driver\Exception\ConnectionException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ConnectionTimeoutException extends MongoDB\Driver\Exception\ConnectionException implements Throwable, MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1802,7 +2151,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\Exception\SSLConnectionException extends MongoDB\Driver\Exception\ConnectionException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ExecutionTimeoutException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception, Throwable ] {
- Constants [0] {
}
@@ -1859,7 +2208,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> abstract class MongoDB\Driver\Exception\WriteException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception, Throwable ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\InvalidArgumentException extends InvalidArgumentException implements Throwable, MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1870,21 +2219,14 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
- Static methods [0] {
}
- - Properties [5] {
+ - Properties [4] {
Property [ <default> protected $message ]
Property [ <default> protected $code ]
Property [ <default> protected $file ]
Property [ <default> protected $line ]
- Property [ <default> protected $writeResult ]
}
- - Methods [11] {
- Method [ <internal:mongodb> final public method getWriteResult ] {
-
- - Parameters [0] {
- }
- }
-
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -1923,7 +2265,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\BulkWriteException extends MongoDB\Driver\Exception\WriteException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\LogicException extends LogicException implements Throwable, MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1934,21 +2276,14 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
- Static methods [0] {
}
- - Properties [5] {
+ - Properties [4] {
Property [ <default> protected $message ]
Property [ <default> protected $code ]
Property [ <default> protected $file ]
Property [ <default> protected $line ]
- Property [ <default> protected $writeResult ]
}
- - Methods [11] {
- Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\WriteException> final public method getWriteResult ] {
-
- - Parameters [0] {
- }
- }
-
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -1987,7 +2322,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ExecutionTimeoutException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception, Throwable ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\Exception\SSLConnectionException extends MongoDB\Driver\Exception\ConnectionException implements Throwable, MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -2044,7 +2379,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ConnectionTimeoutException extends MongoDB\Driver\Exception\ConnectionException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\UnexpectedValueException extends UnexpectedValueException implements Throwable, MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -2100,6 +2435,257 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
}
+
+ Interface [ <internal:mongodb> interface MongoDB\Driver\Monitoring\Subscriber ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Interface [ <internal:mongodb> interface MongoDB\Driver\Monitoring\CommandSubscriber extends MongoDB\Driver\Monitoring\Subscriber ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:mongodb> abstract public method commandStarted ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\CommandStartedEvent $event ]
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method commandSucceeded ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\CommandSucceededEvent $event ]
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method commandFailed ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\CommandFailedEvent $event ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\Driver\Monitoring\CommandFailedEvent ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [8] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getCommandName ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getError ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getDurationMicros ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getOperationId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getRequestId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getServer ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\Driver\Monitoring\CommandStartedEvent ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [8] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getCommand ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getCommandName ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getDatabaseName ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getOperationId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getRequestId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getServer ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\Driver\Monitoring\CommandSucceededEvent ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [8] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getCommandName ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getDurationMicros ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getOperationId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getReply ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getRequestId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getServer ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
}
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 2ff8a5d..2b3f7d9 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -21,7 +21,6 @@
# After 40-smbclient.ini, see https://jira.mongodb.org/browse/PHPC-658
%global ini_name 50-%{pecl_name}.ini
%endif
-#global prever alpha3
%ifarch x86_64
%global with_tests 0%{?_with_tests:1}
@@ -32,7 +31,7 @@
%global with_tests 0%{?_with_tests:1}
%endif
-%if 0%{?fedora} >= 26
+%if 0%{?fedora} >= 27
%global with_syslib 1
%else
%global with_syslib 0
@@ -40,12 +39,14 @@
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.2.9
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%global upstream_version 1.3.0
+%global upstream_prever beta1
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
BuildRequires: %{?scl_prefix}php-devel > 5.4
BuildRequires: %{?scl_prefix}php-pear
@@ -53,12 +54,14 @@ BuildRequires: %{?scl_prefix}php-json
BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
%if %{with_syslib}
-BuildRequires: pkgconfig(libbson-1.0) >= 1.6
-BuildRequires: pkgconfig(libmongoc-1.0) >= 1.6
+BuildRequires: pkgconfig(libbson-1.0) >= 1.7
+BuildRequires: pkgconfig(libmongoc-1.0) >= 1.7
%else
-Provides: bundled(libbson) = 1.6.1
-Provides: bundled(mongo-c-driver) = 1.6.1
+Provides: bundled(libbson) = 1.7.0
+Provides: bundled(mongo-c-driver) = 1.7.0
%endif
+BuildRequires: snappy-devel
+BuildRequires: zlib-devel
%if %{with_tests}
BuildRequires: mongodb-server
%endif
@@ -121,7 +124,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-mv %{pecl_name}-%{version}%{?prever} NTS
+mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
@@ -132,8 +135,8 @@ cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_MONGODB_VERSION/{s/.* "//;s/".*$//;p}' php_phongo.h)
-if test "x${extver}" != "x%{version}%{?prever:%{prever}}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:%{prever}}.
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
exit 1
fi
cd ..
@@ -270,19 +273,6 @@ if [ -s server.pid ] ; then
: Drop known to fail tests
%if "%{mongo_version}" < "3.4"
### With mongodb 3.2
- rm ?TS/tests/standalone/bug0231.phpt
-%endif
-%if "%{mongo_version}" < "3.2"
- ### With mongodb 3.0
- rm ?TS/tests/manager/manager-executeBulkWrite-011.phpt
- rm ?TS/tests/manager/manager-executeQuery-002.phpt
- rm ?TS/tests/readPreference/bug0146-002.phpt
-%endif
-%if "%{mongo_version}" < "3.0"
- ### Older mongodb
- rm ?TS/tests/bulk/write-0003.phpt
- rm ?TS/tests/manager/manager-executeBulkWrite_error-001.phpt
- rm ?TS/tests/manager/manager-executeBulkWrite_error-002.phpt
%endif
: Run the test suite
@@ -331,6 +321,10 @@ exit $ret
%changelog
+* Fri Aug 11 2017 Remi Collet <remi@remirepo.net> - 1.3.0~beta1-1
+- update to 1.3.0beta1
+- raise dependency on libbson and mongo-c-driver 1.7.0
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.2.9-4
- rebuild for PHP 7.2.0beta1 new API