summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-08-31 19:54:34 +0200
committerRemi Collet <fedora@famillecollet.com>2015-08-31 19:54:34 +0200
commitcbbc8d1bb59c61a8641ce8b1765ea4f22393d43d (patch)
tree38393a65affada1f7cf0f7b68336fe82a97d61a9
parenta9de69e492b1ba0fc50dc2de7c768e4e7cb02a94 (diff)
php-pecl-mongodb: 1.0.0alpha2
-rw-r--r--REFLECTION139
-rw-r--r--php-pecl-mongodb.spec25
2 files changed, 116 insertions, 48 deletions
diff --git a/REFLECTION b/REFLECTION
index 20f1a19..e19f381 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
+Extension [ <persistent> extension #124 mongodb version 1.0.0alpha2 ] {
- INI {
Entry [ mongodb.debug <ALL> ]
@@ -6,31 +6,32 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
- - Constants [2] {
- Constant [ string MONGODB_VERSION ] { 0.6.3 }
+ - Constants [3] {
+ Constant [ string MONGODB_VERSION ] { 1.0.0alpha2 }
Constant [ string MONGODB_STABILITY ] { alpha }
+ Constant [ string BSON_NAMESPACE ] { MongoDB\BSON }
}
- Functions {
- Function [ <internal:mongodb> function BSON\fromArray ] {
+ Function [ <internal:mongodb> function MongoDB\BSON\fromPHP ] {
- Parameters [1] {
- Parameter #0 [ <required> $array ]
+ Parameter #0 [ <required> $value ]
}
}
- Function [ <internal:mongodb> function BSON\toArray ] {
+ Function [ <internal:mongodb> function MongoDB\BSON\toPHP ] {
- Parameters [1] {
Parameter #0 [ <required> $bson ]
}
}
- Function [ <internal:mongodb> function BSON\toJSON ] {
+ Function [ <internal:mongodb> function MongoDB\BSON\toJSON ] {
- Parameters [1] {
Parameter #0 [ <required> $bson ]
}
}
- Function [ <internal:mongodb> function BSON\fromJSON ] {
+ Function [ <internal:mongodb> function MongoDB\BSON\fromJSON ] {
- Parameters [1] {
Parameter #0 [ <required> $json ]
@@ -163,7 +164,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
- Properties [0] {
}
- - Methods [10] {
+ - Methods [12] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [3] {
@@ -230,12 +231,24 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
+ Method [ <internal:mongodb> final public method getReadPreference ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method getServers ] {
- Parameters [0] {
}
}
+ Method [ <internal:mongodb> final public method getWriteConcern ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method selectServer ] {
- Parameters [1] {
@@ -351,9 +364,10 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
Method [ <internal:mongodb> final public method executeBulkWrite ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $namespace ]
Parameter #1 [ <required> MongoDB\Driver\BulkWrite $zbulk ]
+ Parameter #2 [ <optional> MongoDB\Driver\WriteConcern or NULL $writeConcern ]
}
}
@@ -726,7 +740,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -736,6 +750,9 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -780,7 +797,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -790,6 +807,9 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -834,7 +854,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -844,6 +864,9 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -888,7 +911,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -898,6 +921,9 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -942,7 +968,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -952,6 +978,9 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -996,7 +1025,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -1006,6 +1035,9 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -1050,7 +1082,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -1060,6 +1092,9 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -1105,7 +1140,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
Property [ <default> protected $writeResult ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:mongodb> final public method getWriteResult ] {
- Parameters [0] {
@@ -1121,6 +1156,9 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -1166,7 +1204,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
Property [ <default> protected $writeResult ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\WriteException> final public method getWriteResult ] {
- Parameters [0] {
@@ -1182,6 +1220,9 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -1227,7 +1268,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
Property [ <default> protected $writeResult ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\WriteException> final public method getWriteResult ] {
- Parameters [0] {
@@ -1243,6 +1284,9 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -1288,7 +1332,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
Property [ <default> protected $writeResult ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\WriteException> final public method getWriteResult ] {
- Parameters [0] {
@@ -1304,6 +1348,9 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -1348,7 +1395,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -1358,6 +1405,9 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -1402,7 +1452,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -1412,6 +1462,9 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -1438,7 +1491,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
- Interface [ <internal:mongodb> interface BSON\Type ] {
+ Interface [ <internal:mongodb> interface MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1456,7 +1509,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
- Interface [ <internal:mongodb> interface BSON\Serializable extends BSON\Type ] {
+ Interface [ <internal:mongodb> interface MongoDB\BSON\Serializable extends MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1479,7 +1532,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
- Interface [ <internal:mongodb> interface BSON\Unserializable ] {
+ Interface [ <internal:mongodb> interface MongoDB\BSON\Unserializable ] {
- Constants [0] {
}
@@ -1503,7 +1556,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
- Interface [ <internal:mongodb> interface BSON\Persistable extends BSON\Unserializable, BSON\Serializable, BSON\Type ] {
+ Interface [ <internal:mongodb> interface MongoDB\BSON\Persistable extends MongoDB\BSON\Unserializable, MongoDB\BSON\Serializable, MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1518,14 +1571,14 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
- Methods [2] {
- Method [ <internal:mongodb, inherits BSON\Unserializable> abstract public method bsonUnserialize ] {
+ Method [ <internal:mongodb, inherits MongoDB\BSON\Unserializable> abstract public method bsonUnserialize ] {
- Parameters [1] {
Parameter #0 [ <required> array $data ]
}
}
- Method [ <internal:mongodb, inherits BSON\Serializable> abstract public method bsonSerialize ] {
+ Method [ <internal:mongodb, inherits MongoDB\BSON\Serializable> abstract public method bsonSerialize ] {
- Parameters [0] {
}
@@ -1533,7 +1586,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
- Class [ <internal:mongodb> class BSON\Binary implements BSON\Type ] {
+ Class [ <internal:mongodb> class MongoDB\BSON\Binary implements MongoDB\BSON\Type ] {
- Constants [7] {
Constant [ integer TYPE_GENERIC ] { 0 }
@@ -1554,16 +1607,22 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
- Properties [0] {
}
- - Methods [2] {
+ - Methods [3] {
Method [ <internal:mongodb, ctor> public method __construct ] {
- Parameters [2] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <required> $subtype ]
+ Parameter #1 [ <required> $type ]
+ }
+ }
+
+ Method [ <internal:mongodb> public method getData ] {
+
+ - Parameters [0] {
}
}
- Method [ <internal:mongodb> public method getSubType ] {
+ Method [ <internal:mongodb> public method getType ] {
- Parameters [0] {
}
@@ -1571,7 +1630,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
- Class [ <internal:mongodb> class BSON\Javascript implements BSON\Type ] {
+ Class [ <internal:mongodb> class MongoDB\BSON\Javascript implements MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1596,7 +1655,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
- Class [ <internal:mongodb> class BSON\MaxKey implements BSON\Type ] {
+ Class [ <internal:mongodb> class MongoDB\BSON\MaxKey implements MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1614,7 +1673,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
- Class [ <internal:mongodb> class BSON\MinKey implements BSON\Type ] {
+ Class [ <internal:mongodb> class MongoDB\BSON\MinKey implements MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1632,7 +1691,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
- Class [ <internal:mongodb> class BSON\ObjectID implements BSON\Type ] {
+ Class [ <internal:mongodb> class MongoDB\BSON\ObjectID implements MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1662,7 +1721,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
- Class [ <internal:mongodb> class BSON\Regex implements BSON\Type ] {
+ Class [ <internal:mongodb> class MongoDB\BSON\Regex implements MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1705,7 +1764,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
- Class [ <internal:mongodb> class BSON\Timestamp implements BSON\Type ] {
+ Class [ <internal:mongodb> class MongoDB\BSON\Timestamp implements MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1736,7 +1795,7 @@ Extension [ <persistent> extension #122 mongodb version 0.6.3 ] {
}
}
- Class [ <internal:mongodb> class BSON\UTCDatetime implements BSON\Type ] {
+ Class [ <internal:mongodb> class MongoDB\BSON\UTCDateTime implements MongoDB\BSON\Type ] {
- Constants [0] {
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 7af8914..b7e79dd 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -14,19 +14,20 @@
%global with_zts 0%{?__ztsphp:1}
%global pecl_name mongodb
%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
+%global ini_name %{pecl_name}.ini
%else
-%global ini_name 40-%{pecl_name}.ini
+%global ini_name 40-%{pecl_name}.ini
%endif
+%global prever alpha2
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.6.3
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 1.0.0
+Release: 0.1.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
@@ -34,6 +35,8 @@ BuildRequires: %{?scl_prefix}php-pear
BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
BuildRequires: pkgconfig(libbson-1.0)
+BuildRequires: pkgconfig(libmongoc-1.0)
+BuildRequires: pkgconfig(libmongoc-priv)
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -81,7 +84,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-mv %{pecl_name}-%{version} NTS
+mv %{pecl_name}-%{version}%{?prever} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' -i package.xml
@@ -90,8 +93,8 @@ cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define MONGODB_VERSION_S/{s/.* "//;s/".*$//;p}' php_phongo.h)
-if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+if test "x${extver}" != "x%{version}%{?prever:%{prever}}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:%{prever}}.
exit 1
fi
cd ..
@@ -118,10 +121,12 @@ peclbuild() {
# Ensure we use system library
# Need to be removed only after phpize because of m4_include
rm -r src/libbson
+ rm -r src/libmongoc
%configure \
--with-php-config=%{_bindir}/${1}-config \
--with-libbson \
+ --with-libmongoc \
--enable-mongodb
make %{?_smp_mflags}
@@ -215,6 +220,10 @@ rm -rf %{buildroot}
%changelog
+* Mon Aug 31 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.1.alpha2
+- Update to 1.0.0alpha2 (alpha)
+- buid with system libmongoc
+
* Thu May 07 2015 Remi Collet <remi@fedoraproject.org> - 0.6.3-1
- Update to 0.6.3 (alpha)