summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-05-06 07:45:28 +0200
committerRemi Collet <fedora@famillecollet.com>2015-05-06 07:45:28 +0200
commitb268d86fcc3dfe063b585fa8f8e3d9bbed873503 (patch)
tree2c1a8d8386a6c0d2ff3b1e14b3dbe84c55f42b1b
parent159b128b029e15d893c36f126402991afb6fbf58 (diff)
php-pecl-mongodb: 0.6.0 (alpha)
-rw-r--r--REFLECTION92
-rw-r--r--php-pecl-mongodb.spec5
2 files changed, 77 insertions, 20 deletions
diff --git a/REFLECTION b/REFLECTION
index 21f9866..650739a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
+Extension [ <persistent> extension #122 mongodb version 0.6.0 ] {
- INI {
Entry [ mongodb.debug <ALL> ]
@@ -7,7 +7,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 0.5.1 }
+ Constant [ string MONGODB_VERSION ] { 0.6.0 }
Constant [ string MONGODB_STABILITY ] { alpha }
}
@@ -38,7 +38,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
}
- - Classes [37] {
+ - Classes [38] {
Class [ <internal:mongodb> final class MongoDB\Driver\Command ] {
- Constants [0] {
@@ -690,7 +690,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
}
- Interface [ <internal:mongodb> interface MongoDB\Driver\Exception ] {
+ Interface [ <internal:mongodb> interface MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -708,7 +708,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\RuntimeException extends RuntimeException implements MongoDB\Driver\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\LogicException extends LogicException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -762,7 +762,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\UnexpectedValueException extends UnexpectedValueException implements MongoDB\Driver\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\RuntimeException extends RuntimeException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -816,7 +816,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\InvalidArgumentException extends InvalidArgumentException implements MongoDB\Driver\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\UnexpectedValueException extends UnexpectedValueException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -870,7 +870,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\ConnectionException extends MongoDB\Driver\RuntimeException implements MongoDB\Driver\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\InvalidArgumentException extends InvalidArgumentException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -924,7 +924,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\AuthenticationException extends MongoDB\Driver\ConnectionException implements MongoDB\Driver\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\ConnectionException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -978,7 +978,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\SSLConnectionException extends MongoDB\Driver\ConnectionException implements MongoDB\Driver\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\AuthenticationException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1032,7 +1032,61 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\WriteException extends MongoDB\Driver\RuntimeException implements MongoDB\Driver\Exception ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\Exception\SSLConnectionException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [9] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\WriteException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1093,7 +1147,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\WriteConcernException extends MongoDB\Driver\WriteException implements MongoDB\Driver\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\WriteConcernException extends MongoDB\Driver\Exception\WriteException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1113,7 +1167,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
- Methods [10] {
- Method [ <internal:mongodb, inherits MongoDB\Driver\WriteException> final public method getWriteResult ] {
+ Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\WriteException> final public method getWriteResult ] {
- Parameters [0] {
}
@@ -1154,7 +1208,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\BulkWriteException extends MongoDB\Driver\WriteException implements MongoDB\Driver\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\BulkWriteException extends MongoDB\Driver\Exception\WriteException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1174,7 +1228,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
- Methods [10] {
- Method [ <internal:mongodb, inherits MongoDB\Driver\WriteException> final public method getWriteResult ] {
+ Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\WriteException> final public method getWriteResult ] {
- Parameters [0] {
}
@@ -1215,7 +1269,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\DuplicateKeyException extends MongoDB\Driver\WriteException implements MongoDB\Driver\Exception ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\Exception\DuplicateKeyException extends MongoDB\Driver\Exception\WriteException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1235,7 +1289,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
- Methods [10] {
- Method [ <internal:mongodb, inherits MongoDB\Driver\WriteException> final public method getWriteResult ] {
+ Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\WriteException> final public method getWriteResult ] {
- Parameters [0] {
}
@@ -1276,7 +1330,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\ExecutionTimeoutException extends MongoDB\Driver\RuntimeException implements MongoDB\Driver\Exception ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ExecutionTimeoutException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1330,7 +1384,7 @@ Extension [ <persistent> extension #122 mongodb version 0.5.1 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\ConnectionTimeoutException extends MongoDB\Driver\ConnectionException implements MongoDB\Driver\Exception ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ConnectionTimeoutException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index ef71136..ce46261 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -21,7 +21,7 @@
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.5.1
+Version: 0.6.0
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
@@ -215,6 +215,9 @@ rm -rf %{buildroot}
%changelog
+* Wed May 06 2015 Remi Collet <remi@fedoraproject.org> - 0.6.0-1
+- Update to 0.6.0 (alpha)
+
* Sat Apr 25 2015 Remi Collet <remi@fedoraproject.org> - 0.5.1-1
- Update to 0.5.1 (alpha)