summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-10-06 09:23:34 +0200
committerRemi Collet <fedora@famillecollet.com>2015-10-06 09:23:34 +0200
commit9c283b369ac8620863b5bf67f58137795be3adc2 (patch)
treeaf83af0e0abe2a01ea4a45ac5419d3e70464c40c
parent526976513471273c3758151f5213844712a6b5f9 (diff)
php-pecl-mongodb: dupliacte our spec
-rw-r--r--REFLECTION45
-rw-r--r--php-pecl-mongodb-dev.spec250
-rw-r--r--php-pecl-mongodb.spec11
3 files changed, 294 insertions, 12 deletions
diff --git a/REFLECTION b/REFLECTION
index 1e56450..e5b56d4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #125 mongodb version 1.0.0beta1 ] {
+Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- INI {
Entry [ mongodb.debug <ALL> ]
@@ -7,7 +7,7 @@ Extension [ <persistent> extension #125 mongodb version 1.0.0beta1 ] {
}
- Constants [3] {
- Constant [ string MONGODB_VERSION ] { 1.0.0beta1 }
+ Constant [ string MONGODB_VERSION ] { 1.0.0beta2 }
Constant [ string MONGODB_STABILITY ] { beta }
Constant [ string BSON_NAMESPACE ] { MongoDB\BSON }
}
@@ -308,14 +308,26 @@ Extension [ <persistent> extension #125 mongodb version 1.0.0beta1 ] {
- Properties [0] {
}
- - Methods [1] {
+ - Methods [3] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [2] {
- Parameter #0 [ <required> $readPreference ]
+ Parameter #0 [ <required> $mode ]
Parameter #1 [ <optional> array or NULL $tagSets ]
}
}
+
+ Method [ <internal:mongodb> final public method getMode ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getTagSets ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -516,14 +528,31 @@ Extension [ <persistent> extension #125 mongodb version 1.0.0beta1 ] {
- Properties [0] {
}
- - Methods [1] {
+ - Methods [4] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- - Parameters [4] {
- Parameter #0 [ <required> $wstring ]
+ - Parameters [3] {
+ Parameter #0 [ <required> $w ]
Parameter #1 [ <optional> $wtimeout ]
Parameter #2 [ <optional> $journal ]
- Parameter #3 [ <optional> $fsync ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getW ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getWtimeout ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getJournal ] {
+
+ - Parameters [0] {
}
}
}
diff --git a/php-pecl-mongodb-dev.spec b/php-pecl-mongodb-dev.spec
new file mode 100644
index 0000000..398f3e1
--- /dev/null
+++ b/php-pecl-mongodb-dev.spec
@@ -0,0 +1,250 @@
+# spec file for php-pecl-mongodb
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-pecl-mongodb}
+%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
+%{!?__pecl: %global __pecl %{_bindir}/pecl}
+%{!?__php: %global __php %{_bindir}/php}
+
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name mongodb
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+%global prever beta2
+
+Summary: MongoDB driver for PHP
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 1.0.0
+Release: 0.3.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: BSD
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: cyrus-sasl-devel
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig(libbson-1.0)
+BuildRequires: pkgconfig(libmongoc-1.0)
+BuildRequires: pkgconfig(libmongoc-priv)
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+The purpose of this driver is to provide exceptionally thin glue between
+MongoDB and PHP, implementing only fundemental and performance-critical
+components necessary to build a fully-functional MongoDB driver.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version}%{?prever} NTS
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' -i package.xml
+
+cd NTS
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define MONGODB_VERSION_S/{s/.* "//;s/".*$//;p}' php_phongo.h)
+if test "x${extver}" != "x%{version}%{?prever:%{prever}}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:%{prever}}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable %{summary} extension module
+extension=%{pecl_name}.so
+
+; Configuration
+;mongodb.debug=''
+EOF
+
+
+%build
+peclbuild() {
+ %{_bindir}/${1}ize
+
+ # Ensure we use system library
+ # Need to be removed only after phpize because of m4_include
+ rm -r src/libbson
+ rm -r src/libmongoc
+
+ %configure \
+ --with-php-config=%{_bindir}/${1}-config \
+ --with-libbson \
+ --with-libmongoc \
+ --enable-mongodb
+
+ make %{?_smp_mflags}
+}
+
+cd NTS
+peclbuild php
+
+%if %{with_zts}
+cd ../ZTS
+peclbuild zts-php
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS \
+ install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS \
+ install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%check
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{?_licensedir:%license NTS/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Tue Oct 6 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.3-beta2
+- Update to 1.0.0beta1 (beta)
+
+* Fri Sep 11 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.2-beta1
+- Update to 1.0.0beta1 (beta)
+
+* Mon Aug 31 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.1.alpha2
+- Update to 1.0.0alpha2 (alpha)
+- buid with system libmongoc
+
+* Thu May 07 2015 Remi Collet <remi@fedoraproject.org> - 0.6.3-1
+- Update to 0.6.3 (alpha)
+
+* Wed May 06 2015 Remi Collet <remi@fedoraproject.org> - 0.6.2-1
+- Update to 0.6.2 (alpha)
+
+* Wed May 06 2015 Remi Collet <remi@fedoraproject.org> - 0.6.0-1
+- Update to 0.6.0 (alpha)
+
+* Sat Apr 25 2015 Remi Collet <remi@fedoraproject.org> - 0.5.1-1
+- Update to 0.5.1 (alpha)
+
+* Thu Apr 23 2015 Remi Collet <remi@fedoraproject.org> - 0.5.0-2
+- build with system libbson
+- open https://jira.mongodb.org/browse/PHPC-259
+
+* Wed Apr 22 2015 Remi Collet <remi@fedoraproject.org> - 0.5.0-1
+- initial package, version 0.5.0 (alpha) \ No newline at end of file
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 54de51d..398f3e1 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -18,12 +18,12 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global prever beta1
+%global prever beta2
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 0.2.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.3.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -188,14 +188,14 @@ fi
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
- --define extension=modules/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
%if %{with_zts}
cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
- --define extension=modules/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
%endif
@@ -220,6 +220,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Oct 6 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.3-beta2
+- Update to 1.0.0beta1 (beta)
+
* Fri Sep 11 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.2-beta1
- Update to 1.0.0beta1 (beta)