summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-28 08:48:06 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-28 08:48:06 +0200
commit78ee87da658f1a5819d8b1ebdbc2cf67223a8c10 (patch)
treeeb6e754bc2d97d69a2a3a9f33d10c057f14bfcf6
parent07704ea69c640c5d6b01be9dff575acab2ed8489 (diff)
php-pecl-mongodb: 1.2.0alpha3
-rw-r--r--REFLECTION-DEV1064
-rw-r--r--php-pecl-mongodb-dev.spec31
2 files changed, 617 insertions, 478 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
index b602e31..4711f10 100644
--- a/REFLECTION-DEV
+++ b/REFLECTION-DEV
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #139 mongodb version 1.2.0alpha1 ] {
+Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
- INI {
Entry [ mongodb.debug <ALL> ]
@@ -6,10 +6,9 @@ Extension [ <persistent> extension #139 mongodb version 1.2.0alpha1 ] {
}
}
- - Constants [3] {
- Constant [ string MONGODB_VERSION ] { 1.2.0alpha1 }
+ - Constants [2] {
+ Constant [ string MONGODB_VERSION ] { 1.2.0alpha3 }
Constant [ string MONGODB_STABILITY ] { alpha }
- Constant [ string BSON_NAMESPACE ] { MongoDB\BSON }
}
- Functions {
@@ -39,7 +38,576 @@ Extension [ <persistent> extension #139 mongodb version 1.2.0alpha1 ] {
}
}
- - Classes [37] {
+ - Classes [38] {
+ Interface [ <internal:mongodb> interface MongoDB\BSON\Type ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Interface [ <internal:mongodb> interface MongoDB\BSON\Serializable extends MongoDB\BSON\Type ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:mongodb> abstract public method bsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Interface [ <internal:mongodb> interface MongoDB\BSON\Unserializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:mongodb> abstract public method bsonUnserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+ }
+ }
+
+ Interface [ <internal:mongodb> interface MongoDB\BSON\Persistable extends MongoDB\BSON\Unserializable, MongoDB\BSON\Serializable, MongoDB\BSON\Type ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:mongodb, inherits MongoDB\BSON\Unserializable> abstract public method bsonUnserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
+ Method [ <internal:mongodb, inherits MongoDB\BSON\Serializable> abstract public method bsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\BSON\Binary implements MongoDB\BSON\Type, Serializable ] {
+
+ - Constants [7] {
+ Constant [ integer TYPE_GENERIC ] { 0 }
+ Constant [ integer TYPE_FUNCTION ] { 1 }
+ Constant [ integer TYPE_OLD_BINARY ] { 2 }
+ Constant [ integer TYPE_OLD_UUID ] { 3 }
+ Constant [ integer TYPE_UUID ] { 4 }
+ Constant [ integer TYPE_MD5 ] { 5 }
+ Constant [ integer TYPE_USER_DEFINED ] { 128 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:mongodb> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [6] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <required> $type ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getData ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getType ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\BSON\Decimal128 implements MongoDB\BSON\Type, Serializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:mongodb> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\BSON\Javascript implements MongoDB\BSON\Type, Serializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:mongodb> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [6] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $javascript ]
+ Parameter #1 [ <optional> $scope ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getCode ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getScope ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\BSON\MaxKey implements MongoDB\BSON\Type, Serializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:mongodb> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\BSON\MinKey implements MongoDB\BSON\Type, Serializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:mongodb> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\BSON\ObjectID implements MongoDB\BSON\Type, Serializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:mongodb> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $id ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getTimestamp ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\BSON\Regex implements MongoDB\BSON\Type, Serializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:mongodb> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [6] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $pattern ]
+ Parameter #1 [ <required> $flags ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getPattern ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getFlags ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\BSON\Timestamp implements MongoDB\BSON\Type, Serializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:mongodb> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $increment ]
+ Parameter #1 [ <required> $timestamp ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\BSON\UTCDateTime implements MongoDB\BSON\Type, Serializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:mongodb> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $milliseconds ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method toDateTime ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
Class [ <internal:mongodb> final class MongoDB\Driver\Command ] {
- Constants [0] {
@@ -274,7 +842,7 @@ Extension [ <persistent> extension #139 mongodb version 1.2.0alpha1 ] {
- Parameters [2] {
Parameter #0 [ <required> $filter ]
- Parameter #1 [ <optional> array $options ]
+ Parameter #1 [ <optional> array or NULL $options ]
}
}
@@ -286,11 +854,12 @@ Extension [ <persistent> extension #139 mongodb version 1.2.0alpha1 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\ReadConcern ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\ReadConcern implements MongoDB\BSON\Serializable, MongoDB\BSON\Type ] {
- - Constants [2] {
+ - Constants [3] {
Constant [ string LOCAL ] { local }
Constant [ string MAJORITY ] { majority }
+ Constant [ string LINEARIZABLE ] { linearizable }
}
- Static properties [0] {
@@ -316,7 +885,7 @@ Extension [ <persistent> extension #139 mongodb version 1.2.0alpha1 ] {
}
}
- Method [ <internal:mongodb> public method __wakeup ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\Serializable> final public method bsonSerialize ] {
- Parameters [0] {
}
@@ -324,7 +893,7 @@ Extension [ <persistent> extension #139 mongodb version 1.2.0alpha1 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\ReadPreference ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\ReadPreference implements MongoDB\BSON\Serializable, MongoDB\BSON\Type ] {
- Constants [5] {
Constant [ integer RP_PRIMARY ] { 1 }
@@ -343,12 +912,19 @@ Extension [ <persistent> extension #139 mongodb version 1.2.0alpha1 ] {
- Properties [0] {
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $mode ]
Parameter #1 [ <optional> array or NULL $tagSets ]
+ Parameter #2 [ <optional> array or NULL $options ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getMaxStalenessMS ] {
+
+ - Parameters [0] {
}
}
@@ -364,7 +940,7 @@ Extension [ <persistent> extension #139 mongodb version 1.2.0alpha1 ] {
}
}
- Method [ <internal:mongodb> public method __wakeup ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\Serializable> final public method bsonSerialize ] {
- Parameters [0] {
}
@@ -563,7 +1139,7 @@ Extension [ <persistent> extension #139 mongodb version 1.2.0alpha1 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\WriteConcern ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\WriteConcern implements MongoDB\BSON\Serializable, MongoDB\BSON\Type ] {
- Constants [1] {
Constant [ string MAJORITY ] { majority }
@@ -606,7 +1182,7 @@ Extension [ <persistent> extension #139 mongodb version 1.2.0alpha1 ] {
}
}
- Method [ <internal:mongodb> public method __wakeup ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\Serializable> final public method bsonSerialize ] {
- Parameters [0] {
}
@@ -1461,464 +2037,6 @@ Extension [ <persistent> extension #139 mongodb version 1.2.0alpha1 ] {
}
}
}
-
- Interface [ <internal:mongodb> interface MongoDB\BSON\Type ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [0] {
- }
- }
-
- Interface [ <internal:mongodb> interface MongoDB\BSON\Serializable extends MongoDB\BSON\Type ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [1] {
- Method [ <internal:mongodb> abstract public method bsonSerialize ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Interface [ <internal:mongodb> interface MongoDB\BSON\Unserializable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [1] {
- Method [ <internal:mongodb> abstract public method bsonUnserialize ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $data ]
- }
- }
- }
- }
-
- Interface [ <internal:mongodb> interface MongoDB\BSON\Persistable extends MongoDB\BSON\Unserializable, MongoDB\BSON\Serializable, MongoDB\BSON\Type ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [2] {
- Method [ <internal:mongodb, inherits MongoDB\BSON\Unserializable> abstract public method bsonUnserialize ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $data ]
- }
- }
-
- Method [ <internal:mongodb, inherits MongoDB\BSON\Serializable> abstract public method bsonSerialize ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:mongodb> final class MongoDB\BSON\Binary implements MongoDB\BSON\Type ] {
-
- - Constants [7] {
- Constant [ integer TYPE_GENERIC ] { 0 }
- Constant [ integer TYPE_FUNCTION ] { 1 }
- Constant [ integer TYPE_OLD_BINARY ] { 2 }
- Constant [ integer TYPE_OLD_UUID ] { 3 }
- Constant [ integer TYPE_UUID ] { 4 }
- Constant [ integer TYPE_MD5 ] { 5 }
- Constant [ integer TYPE_USER_DEFINED ] { 128 }
- }
-
- - Static properties [0] {
- }
-
- - Static methods [1] {
- Method [ <internal:mongodb> static public method __set_state ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $properties ]
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [5] {
- Method [ <internal:mongodb, ctor> final public method __construct ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $data ]
- Parameter #1 [ <required> $type ]
- }
- }
-
- Method [ <internal:mongodb> final public method __toString ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mongodb> public method __wakeup ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mongodb> final public method getData ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mongodb> final public method getType ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:mongodb> final class MongoDB\BSON\Javascript implements MongoDB\BSON\Type ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [1] {
- Method [ <internal:mongodb> static public method __set_state ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $properties ]
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [5] {
- Method [ <internal:mongodb, ctor> final public method __construct ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $javascript ]
- Parameter #1 [ <optional> $scope ]
- }
- }
-
- Method [ <internal:mongodb> final public method __toString ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mongodb> public method __wakeup ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mongodb> final public method getCode ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mongodb> final public method getScope ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:mongodb> final class MongoDB\BSON\MaxKey implements MongoDB\BSON\Type ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [1] {
- Method [ <internal:mongodb> static public method __set_state ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $properties ]
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [1] {
- Method [ <internal:mongodb> public method __wakeup ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:mongodb> final class MongoDB\BSON\MinKey implements MongoDB\BSON\Type ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [1] {
- Method [ <internal:mongodb> static public method __set_state ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $properties ]
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [1] {
- Method [ <internal:mongodb> public method __wakeup ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:mongodb> final class MongoDB\BSON\ObjectID implements MongoDB\BSON\Type ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [1] {
- Method [ <internal:mongodb> static public method __set_state ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $properties ]
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [3] {
- Method [ <internal:mongodb, ctor> final public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $id ]
- }
- }
-
- Method [ <internal:mongodb> final public method __toString ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mongodb> public method __wakeup ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:mongodb> final class MongoDB\BSON\Regex implements MongoDB\BSON\Type ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [1] {
- Method [ <internal:mongodb> static public method __set_state ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $properties ]
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [5] {
- Method [ <internal:mongodb, ctor> final public method __construct ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $pattern ]
- Parameter #1 [ <required> $flags ]
- }
- }
-
- Method [ <internal:mongodb> final public method __toString ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mongodb> public method __wakeup ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mongodb> final public method getPattern ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mongodb> final public method getFlags ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:mongodb> final class MongoDB\BSON\Timestamp implements MongoDB\BSON\Type ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [1] {
- Method [ <internal:mongodb> static public method __set_state ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $properties ]
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [3] {
- Method [ <internal:mongodb, ctor> final public method __construct ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $increment ]
- Parameter #1 [ <required> $timestamp ]
- }
- }
-
- Method [ <internal:mongodb> final public method __toString ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mongodb> public method __wakeup ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:mongodb> final class MongoDB\BSON\UTCDateTime implements MongoDB\BSON\Type ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [1] {
- Method [ <internal:mongodb> static public method __set_state ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $properties ]
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [4] {
- Method [ <internal:mongodb, ctor> final public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $milliseconds ]
- }
- }
-
- Method [ <internal:mongodb> final public method __toString ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mongodb> public method __wakeup ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mongodb> final public method toDateTime ] {
-
- - Parameters [0] {
- }
- }
- }
- }
}
}
diff --git a/php-pecl-mongodb-dev.spec b/php-pecl-mongodb-dev.spec
index 0b0032c..1576895 100644
--- a/php-pecl-mongodb-dev.spec
+++ b/php-pecl-mongodb-dev.spec
@@ -25,7 +25,7 @@
# After 40-smbclient.ini, see https://jira.mongodb.org/browse/PHPC-658
%global ini_name 50-%{pecl_name}.ini
%endif
-%global prever alpha1
+%global prever alpha3
%ifarch x86_64
%global with_tests 0%{?_with_tests:1}
@@ -36,10 +36,16 @@
%global with_tests 0%{?_with_tests:1}
%endif
+%if 0%{?fedora} > 99
+%global with_syslib 1
+%else
+%global with_syslib 0
+%endif
+
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.2.0
-Release: 0.1.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.2.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -52,8 +58,10 @@ BuildRequires: %{?scl_prefix}php-devel > 5.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
-BuildRequires: pkgconfig(libbson-1.0) >= 1.4
-BuildRequires: pkgconfig(libmongoc-1.0) >= 1.4
+%if %{with_syslib}
+BuildRequires: pkgconfig(libbson-1.0) >= 1.5
+BuildRequires: pkgconfig(libmongoc-1.0) >= 1.5
+%endif
%if %{with_tests}
BuildRequires: mongodb-server
%endif
@@ -119,7 +127,9 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%if %{with_syslib}
%patch0 -p0 -b .rpm
+%endif
# Sanity check, really often broken
extver=$(sed -n '/#define MONGODB_VERSION_S/{s/.* "//;s/".*$//;p}' php_phongo.h)
@@ -148,6 +158,7 @@ EOF
peclbuild() {
%{_bindir}/${1}ize
+%if %{with_syslib}
# Ensure we use system library
# Need to be removed only after phpize because of m4_include
rm -r src/libbson
@@ -159,6 +170,13 @@ peclbuild() {
--with-libmongoc \
--enable-mongodb
+%else
+
+ %configure \
+ --with-php-config=%{_bindir}/${1}-config \
+ --enable-mongodb
+%endif
+
make %{?_smp_mflags}
}
@@ -249,7 +267,6 @@ if [ -s server.pid ] ; then
%if "%{mongo_version}" < "3.4"
### With mongodb 3.2
rm ?TS/tests/manager/manager-debug-001.phpt
- rm ?TS/tests/manager/manager-debug-003.phpt
rm ?TS/tests/manager/manager-executequery-without-assignment.phpt
rm ?TS/tests/standalone/bug0487-002.phpt
rm ?TS/tests/standalone/bug0655.phpt
@@ -313,6 +330,10 @@ exit $ret
%changelog
+* Wed Sep 28 2016 Remi Collet <remi@fedoraproject.org> - 1.2.0-0.2.alpha3
+- update to 1.2.0alpha3
+- use bundled libbson and libmongoc
+
* Mon Aug 8 2016 Remi Collet <remi@fedoraproject.org> - 1.2.0-0.1.alpha1
- update to 1.2.0alpha1
- open https://jira.mongodb.org/browse/PHPC-762 missing symbols