summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-11-29 17:47:43 +0100
committerRemi Collet <fedora@famillecollet.com>2016-11-29 17:47:43 +0100
commit299b0b3dea3f52df0bf811be48953ed7c6ac9dfa (patch)
tree81b0a1b5c480c0024c9c847db970cce4199e722d
parentc3bfc02de7cde71497dfcd3e8cc7b0da2c86c8e6 (diff)
php-pecl-mongodb: 1.2.0
-rw-r--r--REFLECTION-DEV109
-rw-r--r--php-pecl-mongodb-dev.spec25
2 files changed, 101 insertions, 33 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
index 4711f10..5e99dd6 100644
--- a/REFLECTION-DEV
+++ b/REFLECTION-DEV
@@ -1,4 +1,11 @@
-Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
+Extension [ <persistent> extension #155 mongodb version 1.2.0 ] {
+
+ - Dependencies {
+ Dependency [ date (Required) ]
+ Dependency [ json (Required) ]
+ Dependency [ spl (Required) ]
+ Dependency [ standard (Required) ]
+ }
- INI {
Entry [ mongodb.debug <ALL> ]
@@ -7,8 +14,8 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.2.0alpha3 }
- Constant [ string MONGODB_STABILITY ] { alpha }
+ Constant [ string MONGODB_VERSION ] { 1.2.0 }
+ Constant [ string MONGODB_STABILITY ] { stable }
}
- Functions {
@@ -134,7 +141,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\Binary implements MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\Binary implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [7] {
Constant [ integer TYPE_GENERIC ] { 0 }
@@ -161,7 +168,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
- Properties [0] {
}
- - Methods [6] {
+ - Methods [7] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [2] {
@@ -176,6 +183,12 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
+ Method [ <internal:mongodb, prototype JsonSerializable> final public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
- Parameters [0] {
@@ -203,7 +216,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\Decimal128 implements MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\Decimal128 implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
}
@@ -223,7 +236,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
- Properties [0] {
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [1] {
@@ -237,6 +250,12 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
+ Method [ <internal:mongodb, prototype JsonSerializable> final public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
- Parameters [0] {
@@ -252,7 +271,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\Javascript implements MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\Javascript implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
}
@@ -272,7 +291,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
- Properties [0] {
}
- - Methods [6] {
+ - Methods [7] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [2] {
@@ -287,6 +306,12 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
+ Method [ <internal:mongodb, prototype JsonSerializable> final public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
- Parameters [0] {
@@ -314,7 +339,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\MaxKey implements MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\MaxKey implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
}
@@ -334,7 +359,13 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
- Properties [0] {
}
- - Methods [2] {
+ - Methods [3] {
+ Method [ <internal:mongodb, prototype JsonSerializable> final public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
- Parameters [0] {
@@ -350,7 +381,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\MinKey implements MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\MinKey implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
}
@@ -370,7 +401,13 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
- Properties [0] {
}
- - Methods [2] {
+ - Methods [3] {
+ Method [ <internal:mongodb, prototype JsonSerializable> final public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
- Parameters [0] {
@@ -386,7 +423,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\ObjectID implements MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\ObjectID implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
}
@@ -406,7 +443,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [6] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [1] {
@@ -426,6 +463,12 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
+ Method [ <internal:mongodb, prototype JsonSerializable> final public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
- Parameters [0] {
@@ -441,7 +484,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\Regex implements MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\Regex implements MongoDB\BSON\Type, Serializable, JsonSerializable ] {
- Constants [0] {
}
@@ -461,7 +504,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
- Properties [0] {
}
- - Methods [6] {
+ - Methods [7] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [2] {
@@ -476,6 +519,12 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
+ Method [ <internal:mongodb, prototype JsonSerializable> final public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
- Parameters [0] {
@@ -503,7 +552,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\Timestamp implements MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\Timestamp implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
}
@@ -523,7 +572,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
- Properties [0] {
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [2] {
@@ -538,6 +587,12 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
+ Method [ <internal:mongodb, prototype JsonSerializable> final public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
- Parameters [0] {
@@ -553,7 +608,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\BSON\UTCDateTime implements MongoDB\BSON\Type, Serializable ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\UTCDateTime implements JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [0] {
}
@@ -573,7 +628,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [6] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [1] {
@@ -587,6 +642,12 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
+ Method [ <internal:mongodb, prototype JsonSerializable> final public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
- Parameters [0] {
@@ -895,12 +956,14 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
Class [ <internal:mongodb> final class MongoDB\Driver\ReadPreference implements MongoDB\BSON\Serializable, MongoDB\BSON\Type ] {
- - Constants [5] {
+ - Constants [7] {
Constant [ integer RP_PRIMARY ] { 1 }
Constant [ integer RP_PRIMARY_PREFERRED ] { 5 }
Constant [ integer RP_SECONDARY ] { 2 }
Constant [ integer RP_SECONDARY_PREFERRED ] { 6 }
Constant [ integer RP_NEAREST ] { 10 }
+ Constant [ integer NO_MAX_STALENESS ] { -1 }
+ Constant [ integer SMALLEST_MAX_STALENESS_SECONDS ] { 90 }
}
- Static properties [0] {
@@ -922,7 +985,7 @@ Extension [ <persistent> extension #147 mongodb version 1.2.0alpha3 ] {
}
}
- Method [ <internal:mongodb> final public method getMaxStalenessMS ] {
+ Method [ <internal:mongodb> final public method getMaxStalenessSeconds ] {
- Parameters [0] {
}
diff --git a/php-pecl-mongodb-dev.spec b/php-pecl-mongodb-dev.spec
index 589af04..12e1326 100644
--- a/php-pecl-mongodb-dev.spec
+++ b/php-pecl-mongodb-dev.spec
@@ -7,11 +7,7 @@
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
%global sub_prefix %{scl_prefix}
-%endif
%scl_package php-pecl-mongodb
%else
%global _root_prefix %{_prefix}
@@ -25,7 +21,7 @@
# After 40-smbclient.ini, see https://jira.mongodb.org/browse/PHPC-658
%global ini_name 50-%{pecl_name}.ini
%endif
-%global prever alpha3
+#global prever alpha3
%ifarch x86_64
%global with_tests 0%{?_with_tests:1}
@@ -45,7 +41,7 @@
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.2.0
-Release: 0.2.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -56,6 +52,7 @@ Patch0: %{pecl_name}-tests.patch
BuildRequires: %{?scl_prefix}php-devel > 5.4
BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-json
BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
%if %{with_syslib}
@@ -68,6 +65,7 @@ BuildRequires: mongodb-server
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php-json%{?_isa}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
# Don't provide php-mongodb which is the pure PHP library
@@ -233,14 +231,17 @@ fi
%check
+OPT="-n"
+[ -f %{php_extdir}/json.so ] && OPT="$OPT -d extension=json.so"
+
: Minimal load test for NTS extension
-%{__php} --no-php-ini \
+%{__php} $OPT \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
%if %{with_zts}
: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
+%{__ztsphp} $OPT \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
%endif
@@ -289,7 +290,7 @@ if [ -s server.pid ] ; then
pushd NTS
TEST_PHP_EXECUTABLE=%{__php} \
- TEST_PHP_ARGS="-n -d extension=json.so -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+ TEST_PHP_ARGS="$OPT -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
php -n run-tests.php --show-diff || ret=1
@@ -298,7 +299,7 @@ if [ -s server.pid ] ; then
%if %{with_zts}
pushd ZTS
TEST_PHP_EXECUTABLE=%{__ztsphp} \
- TEST_PHP_ARGS="-n -d extension=json.so -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+ TEST_PHP_ARGS="$OPT -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
php -n run-tests.php --show-diff || ret=1
@@ -330,6 +331,10 @@ exit $ret
%changelog
+* Tue Nov 29 2016 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
+- update to 1.2.0
+- internal dependency on date, json, spl and standard
+
* Wed Sep 28 2016 Remi Collet <remi@fedoraproject.org> - 1.2.0-0.2.alpha3
- update to 1.2.0alpha3
- use bundled libbson and libmongoc