summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-16 08:31:56 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-16 08:31:56 +0100
commitc46ec36ee493ac281de79e4116436d5ce7d6578b (patch)
tree7029e0865fb906ce503a68b325481fe00c567625
parent1dbd88ab22a53bf0534f747b25795a03c5091307 (diff)
php-pecl-mongodb: 1.1.0 (php 5, stable)
-rw-r--r--REFLECTION48
-rw-r--r--php-pecl-mongodb-dev.spec17
-rw-r--r--php-pecl-mongodb.spec18
3 files changed, 67 insertions, 16 deletions
diff --git a/REFLECTION b/REFLECTION
index 6fe8582..434bce5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #126 mongodb version 1.0.1 ] {
+Extension [ <persistent> extension #130 mongodb version 1.1.0 ] {
- INI {
Entry [ mongodb.debug <ALL> ]
@@ -7,7 +7,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.1 ] {
}
- Constants [3] {
- Constant [ string MONGODB_VERSION ] { 1.0.1 }
+ Constant [ string MONGODB_VERSION ] { 1.1.0 }
Constant [ string MONGODB_STABILITY ] { stable }
Constant [ string BSON_NAMESPACE ] { MongoDB\BSON }
}
@@ -39,7 +39,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.1 ] {
}
}
- - Classes [36] {
+ - Classes [37] {
Class [ <internal:mongodb> final class MongoDB\Driver\Command ] {
- Constants [0] {
@@ -164,11 +164,11 @@ Extension [ <persistent> extension #126 mongodb version 1.0.1 ] {
- Properties [0] {
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <required> $uri ]
+ Parameter #0 [ <optional> $uri ]
Parameter #1 [ <optional> array $options ]
Parameter #2 [ <optional> array $driverOptions ]
}
@@ -201,6 +201,12 @@ Extension [ <persistent> extension #126 mongodb version 1.0.1 ] {
}
}
+ Method [ <internal:mongodb> final public method getReadConcern ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method getReadPreference ] {
- Parameters [0] {
@@ -259,6 +265,38 @@ Extension [ <persistent> extension #126 mongodb version 1.0.1 ] {
}
}
+ Class [ <internal:mongodb> final class MongoDB\Driver\ReadConcern ] {
+
+ - Constants [2] {
+ Constant [ string LOCAL ] { local }
+ Constant [ string MAJORITY ] { majority }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $level ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getLevel ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
Class [ <internal:mongodb> final class MongoDB\Driver\ReadPreference ] {
- Constants [5] {
diff --git a/php-pecl-mongodb-dev.spec b/php-pecl-mongodb-dev.spec
index dbfa441..b31edc4 100644
--- a/php-pecl-mongodb-dev.spec
+++ b/php-pecl-mongodb-dev.spec
@@ -19,10 +19,12 @@
%global ini_name 40-%{pecl_name}.ini
%endif
#global prever RC0
+# Still needed because of some private API
+%global buildver %(pkg-config --silence-errors --modversion libmongoc-priv 2>/dev/null || echo 65536)
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.0.1
+Version: 1.1.0
Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -34,13 +36,14 @@ BuildRequires: %{?scl_prefix}php-devel > 5.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
-BuildRequires: pkgconfig(libbson-1.0) >= 1.2.0
-BuildRequires: pkgconfig(libmongoc-1.0) >= 1.2.0
-BuildRequires: pkgconfig(libmongoc-priv) >= 1.2.0
-BuildRequires: pkgconfig(libmongoc-priv) < 1.3
+BuildRequires: pkgconfig(libbson-1.0) >= 1.3.0
+BuildRequires: pkgconfig(libmongoc-1.0) >= 1.3.0
+BuildRequires: pkgconfig(libmongoc-priv) >= 1.3.0
+BuildRequires: pkgconfig(libmongoc-priv) < 1.4
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: mongo-c-driver%{?_isa} >= %{buildver}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
# Don't provide php-mongodb which is the pure PHP library
@@ -220,6 +223,10 @@ rm -rf %{buildroot}
%changelog
+* Wed Dec 16 2015 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- Update to 1.1.0 (stable)
+- raise dependency on libmongoc >= 1.3.0
+
* Tue Dec 8 2015 Remi Collet <remi@fedoraproject.org> - 1.0.1-2
- update to 1.0.1 (stable)
- ensure libmongoc >= 1.2.0 and < 1.3 is used
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 3e753b6..9208cfc 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -19,11 +19,12 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-#global prever RC0
+# Still needed because of some private API
+%global buildver %(pkg-config --silence-errors --modversion libmongoc-priv 2>/dev/null || echo 65536)
Summary: MongoDB driver for PHP
Name: php-pecl-%{pecl_name}
-Version: 1.0.1
+Version: 1.1.0
Release: 1%{?dist}
License: BSD
Group: Development/Languages
@@ -34,13 +35,14 @@ BuildRequires: php-devel > 5.4
BuildRequires: php-pear
BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
-BuildRequires: pkgconfig(libbson-1.0) >= 1.2.0
-BuildRequires: pkgconfig(libmongoc-1.0) >= 1.2.0
-BuildRequires: pkgconfig(libmongoc-priv) >= 1.2.0
-BuildRequires: pkgconfig(libmongoc-priv) < 1.3
+BuildRequires: pkgconfig(libbson-1.0) >= 1.3.0
+BuildRequires: pkgconfig(libmongoc-1.0) >= 1.3.0
+BuildRequires: pkgconfig(libmongoc-priv) >= 1.3.0
+BuildRequires: pkgconfig(libmongoc-priv) < 1.4
Requires: php(zend-abi) = %{php_zend_api}
Requires: php(api) = %{php_core_api}
+Requires: mongo-c-driver%{?_isa} >= %{buildver}
# Don't provide php-mongodb which is the pure PHP library
Provides: php-pecl(%{pecl_name}) = %{version}
@@ -190,6 +192,10 @@ cd ../ZTS
%changelog
+* Wed Dec 16 2015 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- Update to 1.1.0 (stable)
+- raise dependency on libmongoc >= 1.3.0
+
* Tue Dec 8 2015 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
- update to 1.0.1 (stable)
- ensure libmongoc >= 1.2.0 and < 1.3 is used