summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-05 07:06:33 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-05 07:06:33 +0100
commitbb8cdd79f374d8fa3fa7e24697c02d2e5390b2d3 (patch)
treee98f94613c3d25d2cab3f2257dd3b18c96b93d83
parent5871a3676c0fefea23e0d2c766f3cb659115420a (diff)
php-pecl-mongodb: 1.1.3 (stable)
-rw-r--r--REFLECTION32
-rw-r--r--php-pecl-mongodb-dev.spec17
-rw-r--r--php-pecl-mongodb.spec17
3 files changed, 38 insertions, 28 deletions
diff --git a/REFLECTION b/REFLECTION
index 56bb867..bad7955 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #131 mongodb version 1.1.2 ] {
+Extension [ <persistent> extension #131 mongodb version 1.1.3 ] {
- INI {
Entry [ mongodb.debug <ALL> ]
@@ -7,7 +7,7 @@ Extension [ <persistent> extension #131 mongodb version 1.1.2 ] {
}
- Constants [3] {
- Constant [ string MONGODB_VERSION ] { 1.1.2 }
+ Constant [ string MONGODB_VERSION ] { 1.1.3 }
Constant [ string MONGODB_STABILITY ] { stable }
Constant [ string BSON_NAMESPACE ] { MongoDB\BSON }
}
@@ -479,21 +479,21 @@ Extension [ <persistent> extension #131 mongodb version 1.1.2 ] {
}
- Methods [6] {
- Method [ <internal:mongodb, ctor> public method __construct ] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [1] {
Parameter #0 [ <optional> array or NULL $options ]
}
}
- Method [ <internal:mongodb> public method insert ] {
+ Method [ <internal:mongodb> final public method insert ] {
- Parameters [1] {
Parameter #0 [ <required> $document ]
}
}
- Method [ <internal:mongodb> public method update ] {
+ Method [ <internal:mongodb> final public method update ] {
- Parameters [3] {
Parameter #0 [ <required> $query ]
@@ -502,7 +502,7 @@ Extension [ <persistent> extension #131 mongodb version 1.1.2 ] {
}
}
- Method [ <internal:mongodb> public method delete ] {
+ Method [ <internal:mongodb> final public method delete ] {
- Parameters [2] {
Parameter #0 [ <required> $query ]
@@ -510,7 +510,7 @@ Extension [ <persistent> extension #131 mongodb version 1.1.2 ] {
}
}
- Method [ <internal:mongodb, prototype Countable> public method count ] {
+ Method [ <internal:mongodb, prototype Countable> final public method count ] {
- Parameters [0] {
}
@@ -1513,7 +1513,7 @@ Extension [ <persistent> extension #131 mongodb version 1.1.2 ] {
}
- Methods [4] {
- Method [ <internal:mongodb, ctor> public method __construct ] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [2] {
Parameter #0 [ <required> $data ]
@@ -1521,13 +1521,13 @@ Extension [ <persistent> extension #131 mongodb version 1.1.2 ] {
}
}
- Method [ <internal:mongodb> public method getData ] {
+ Method [ <internal:mongodb> final public method getData ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> public method getType ] {
+ Method [ <internal:mongodb> final public method getType ] {
- Parameters [0] {
}
@@ -1621,14 +1621,14 @@ Extension [ <persistent> extension #131 mongodb version 1.1.2 ] {
}
- Methods [3] {
- Method [ <internal:mongodb, ctor> public method __construct ] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [1] {
Parameter #0 [ <optional> $id ]
}
}
- Method [ <internal:mongodb> public method __toString ] {
+ Method [ <internal:mongodb> final public method __toString ] {
- Parameters [0] {
}
@@ -1654,7 +1654,7 @@ Extension [ <persistent> extension #131 mongodb version 1.1.2 ] {
}
- Methods [5] {
- Method [ <internal:mongodb, ctor> public method __construct ] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [2] {
Parameter #0 [ <required> $pattern ]
@@ -1662,19 +1662,19 @@ Extension [ <persistent> extension #131 mongodb version 1.1.2 ] {
}
}
- Method [ <internal:mongodb> public method getPattern ] {
+ Method [ <internal:mongodb> final public method getPattern ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> public method getFlags ] {
+ Method [ <internal:mongodb> final public method getFlags ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> public method __toString ] {
+ Method [ <internal:mongodb> final public method __toString ] {
- Parameters [0] {
}
diff --git a/php-pecl-mongodb-dev.spec b/php-pecl-mongodb-dev.spec
index 2828315..41cd40b 100644
--- a/php-pecl-mongodb-dev.spec
+++ b/php-pecl-mongodb-dev.spec
@@ -7,9 +7,6 @@
# Please, preserve the changelog entries
#
%{?scl: %scl_package php-pecl-mongodb}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name mongodb
@@ -24,7 +21,7 @@
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.1.2
+Version: 1.1.3
Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -90,7 +87,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version}%{?prever} NTS
# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
@@ -169,6 +168,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -185,6 +185,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -223,6 +224,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 1.1.3-1
+- Update to 1.1.3 (stable)
+
* Thu Jan 07 2016 Remi Collet <remi@fedoraproject.org> - 1.1.2-2
- Update to 1.1.2 (stable)
@@ -276,4 +280,5 @@ rm -rf %{buildroot}
- open https://jira.mongodb.org/browse/PHPC-259
* Wed Apr 22 2015 Remi Collet <remi@fedoraproject.org> - 0.5.0-1
-- initial package, version 0.5.0 (alpha) \ No newline at end of file
+- initial package, version 0.5.0 (alpha)
+
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 5a76147..399987b 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -9,9 +9,6 @@
#
# Please, preserve the changelog entries
#
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
-
%global with_zts 0%{?__ztsphp:1}
%global pecl_name mongodb
%if "%{php_version}" < "5.6"
@@ -24,7 +21,7 @@
Summary: MongoDB driver for PHP
Name: php-pecl-%{pecl_name}
-Version: 1.1.2
+Version: 1.1.3
Release: 1%{?dist}
License: BSD
Group: Development/Languages
@@ -66,7 +63,9 @@ components necessary to build a fully-functional MongoDB driver.
mv %{pecl_name}-%{version}%{?prever} NTS
# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
@@ -143,6 +142,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- php-pear
if [ -x %{__pecl} ] ; then
@@ -159,6 +159,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -192,6 +193,9 @@ cd ../ZTS
%changelog
+* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 1.1.3-1
+- Update to 1.1.3 (stable)
+
* Thu Jan 07 2016 Remi Collet <remi@fedoraproject.org> - 1.1.2-1
- Update to 1.1.2 (stable)
@@ -248,4 +252,5 @@ cd ../ZTS
- open https://jira.mongodb.org/browse/PHPC-259
* Wed Apr 22 2015 Remi Collet <remi@fedoraproject.org> - 0.5.0-1
-- initial package, version 0.5.0 (alpha) \ No newline at end of file
+- initial package, version 0.5.0 (alpha)
+