summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-10-27 10:19:02 +0100
committerRemi Collet <fedora@famillecollet.com>2015-10-27 10:19:02 +0100
commit147fea03edc078c1ff7b4eb40981ced7a3878258 (patch)
treec6a1f2be3e06eb7d3813982a21c46d404b556a09
parent90324286159ee4c3aa3b7a7ba5119476c1ee8c71 (diff)
php-pecl-mongodb: 1.0.0RC0
-rw-r--r--REFLECTION238
-rw-r--r--php-pecl-mongodb-dev.spec7
-rw-r--r--php-pecl-mongodb.spec7
3 files changed, 58 insertions, 194 deletions
diff --git a/REFLECTION b/REFLECTION
index e5b56d4..f53155c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
+Extension [ <persistent> extension #126 mongodb version 1.0.0RC0 ] {
- INI {
Entry [ mongodb.debug <ALL> ]
@@ -7,7 +7,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
}
- Constants [3] {
- Constant [ string MONGODB_VERSION ] { 1.0.0beta2 }
+ Constant [ string MONGODB_VERSION ] { 1.0.0RC0 }
Constant [ string MONGODB_STABILITY ] { beta }
Constant [ string BSON_NAMESPACE ] { MongoDB\BSON }
}
@@ -39,7 +39,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
}
}
- - Classes [38] {
+ - Classes [36] {
Class [ <internal:mongodb> final class MongoDB\Driver\Command ] {
- Constants [0] {
@@ -164,7 +164,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Properties [0] {
}
- - Methods [12] {
+ - Methods [9] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [3] {
@@ -201,36 +201,6 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
}
}
- Method [ <internal:mongodb> final public method executeInsert ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $namespace ]
- Parameter #1 [ <required> $document ]
- Parameter #2 [ <optional> MongoDB\Driver\WriteConcern or NULL $writeConcern ]
- }
- }
-
- Method [ <internal:mongodb> final public method executeUpdate ] {
-
- - Parameters [5] {
- Parameter #0 [ <required> $namespace ]
- Parameter #1 [ <required> $zquery ]
- Parameter #2 [ <required> $newObj ]
- Parameter #3 [ <optional> array or NULL $updateOptions ]
- Parameter #4 [ <optional> MongoDB\Driver\WriteConcern or NULL $writeConcern ]
- }
- }
-
- Method [ <internal:mongodb> final public method executeDelete ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $namespace ]
- Parameter #1 [ <required> $query ]
- Parameter #2 [ <optional> array or NULL $deleteOptions ]
- Parameter #3 [ <optional> MongoDB\Driver\WriteConcern or NULL $writeConcern ]
- }
- }
-
Method [ <internal:mongodb> final public method getReadPreference ] {
- Parameters [0] {
@@ -474,7 +444,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
Method [ <internal:mongodb, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> $ordered ]
+ Parameter #0 [ <optional> array or NULL $options ]
}
}
@@ -660,7 +630,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Properties [0] {
}
- - Methods [13] {
+ - Methods [12] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
}
@@ -694,12 +664,6 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
}
}
- Method [ <internal:mongodb> final public method getInfo ] {
-
- - Parameters [0] {
- }
- }
-
Method [ <internal:mongodb> final public method getServer ] {
- Parameters [0] {
@@ -1095,7 +1059,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\Exception\SSLConnectionException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\SSLConnectionException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1152,7 +1116,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\WriteException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> abstract class MongoDB\Driver\Exception\WriteException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1216,70 +1180,6 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\WriteConcernException extends MongoDB\Driver\Exception\WriteException implements MongoDB\Driver\Exception\Exception ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [5] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- Property [ <default> protected $writeResult ]
- }
-
- - Methods [11] {
- Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\WriteException> final public method getWriteResult ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
- }
- }
-
- Method [ <internal:Core, inherits Exception> public method __wakeup ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
- }
-
- Method [ <internal:Core, inherits Exception> public method __toString ] {
- }
- }
- }
-
Class [ <internal:mongodb> class MongoDB\Driver\Exception\BulkWriteException extends MongoDB\Driver\Exception\WriteException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
@@ -1344,71 +1244,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\Exception\DuplicateKeyException extends MongoDB\Driver\Exception\WriteException implements MongoDB\Driver\Exception\Exception ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [5] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- Property [ <default> protected $writeResult ]
- }
-
- - Methods [11] {
- Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\WriteException> final public method getWriteResult ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
- }
- }
-
- Method [ <internal:Core, inherits Exception> public method __wakeup ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
- }
-
- Method [ <internal:Core, inherits Exception> public method __toString ] {
- }
- }
- }
-
- Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ExecutionTimeoutException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\ExecutionTimeoutException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1465,7 +1301,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ConnectionTimeoutException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\ConnectionTimeoutException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1617,7 +1453,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\BSON\Binary implements MongoDB\BSON\Type ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\Binary implements MongoDB\BSON\Type ] {
- Constants [7] {
Constant [ integer TYPE_GENERIC ] { 0 }
@@ -1638,7 +1474,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Properties [0] {
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:mongodb, ctor> public method __construct ] {
- Parameters [2] {
@@ -1658,10 +1494,13 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:mongodb> public method __wakeUp ] {
+ }
}
}
- Class [ <internal:mongodb> class MongoDB\BSON\Javascript implements MongoDB\BSON\Type ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\Javascript implements MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1675,7 +1514,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Properties [0] {
}
- - Methods [1] {
+ - Methods [2] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [2] {
@@ -1683,10 +1522,13 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
Parameter #1 [ <optional> $scope ]
}
}
+
+ Method [ <internal:mongodb> public method __wakeUp ] {
+ }
}
}
- Class [ <internal:mongodb> class MongoDB\BSON\MaxKey implements MongoDB\BSON\Type ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\MaxKey implements MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1700,11 +1542,13 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Properties [0] {
}
- - Methods [0] {
+ - Methods [1] {
+ Method [ <internal:mongodb> public method __wakeUp ] {
+ }
}
}
- Class [ <internal:mongodb> class MongoDB\BSON\MinKey implements MongoDB\BSON\Type ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\MinKey implements MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1718,11 +1562,13 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Properties [0] {
}
- - Methods [0] {
+ - Methods [1] {
+ Method [ <internal:mongodb> public method __wakeUp ] {
+ }
}
}
- Class [ <internal:mongodb> class MongoDB\BSON\ObjectID implements MongoDB\BSON\Type ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\ObjectID implements MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1736,7 +1582,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Properties [0] {
}
- - Methods [2] {
+ - Methods [3] {
Method [ <internal:mongodb, ctor> public method __construct ] {
- Parameters [1] {
@@ -1749,10 +1595,13 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:mongodb> public method __wakeUp ] {
+ }
}
}
- Class [ <internal:mongodb> class MongoDB\BSON\Regex implements MongoDB\BSON\Type ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\Regex implements MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1766,7 +1615,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Properties [0] {
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:mongodb, ctor> public method __construct ] {
- Parameters [2] {
@@ -1792,10 +1641,13 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:mongodb> public method __wakeUp ] {
+ }
}
}
- Class [ <internal:mongodb> class MongoDB\BSON\Timestamp implements MongoDB\BSON\Type ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\Timestamp implements MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1809,7 +1661,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Properties [0] {
}
- - Methods [2] {
+ - Methods [3] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [2] {
@@ -1823,10 +1675,13 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:mongodb> public method __wakeUp ] {
+ }
}
}
- Class [ <internal:mongodb> class MongoDB\BSON\UTCDateTime implements MongoDB\BSON\Type ] {
+ Class [ <internal:mongodb> final class MongoDB\BSON\UTCDateTime implements MongoDB\BSON\Type ] {
- Constants [0] {
}
@@ -1840,7 +1695,7 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Properties [0] {
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [1] {
@@ -1859,6 +1714,9 @@ Extension [ <persistent> extension #126 mongodb version 1.0.0beta2 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:mongodb> public method __wakeUp ] {
+ }
}
}
}
diff --git a/php-pecl-mongodb-dev.spec b/php-pecl-mongodb-dev.spec
index adc41df..8e7c6ab 100644
--- a/php-pecl-mongodb-dev.spec
+++ b/php-pecl-mongodb-dev.spec
@@ -18,12 +18,12 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global prever beta2
+%global prever RC0
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 0.3.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.5.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -220,6 +220,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Oct 27 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.5.RC0
+- Update to 1.0.0RC0 (beta)
+
* Tue Oct 6 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.3-beta2
- Update to 1.0.0beta2 (beta)
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 30a1cae..bf84f79 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -19,12 +19,12 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global prever beta2
+%global prever RC0
Summary: MongoDB driver for PHP
Name: php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 0.4.%{prever}%{?dist}
+Release: 0.6.%{prever}%{?dist}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -190,6 +190,9 @@ cd ../ZTS
%changelog
+* Tue Oct 27 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.6.RC0
+- Update to 1.0.0RC0 (beta)
+
* Tue Oct 6 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.4-beta2
- drop SCL compatibility for Fedora