summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--PHPINFO9
-rw-r--r--README.md264
-rw-r--r--REFLECTION32
-rw-r--r--php-pecl-memprof.spec183
5 files changed, 136 insertions, 354 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..a29e5ee
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,9 @@
+
+memprof
+
+memprof support => enabled
+memprof version => 3.0.2
+memprof native malloc support => No
+
+Directive => Local Value => Master Value
+memprof.output_dir => /tmp => /tmp
diff --git a/README.md b/README.md
deleted file mode 100644
index 2d5a721..0000000
--- a/README.md
+++ /dev/null
@@ -1,264 +0,0 @@
-# php-memprof
-
-php-memprof profiles memory usage of PHP scripts, and especially can tell which
-function has allocated every single byte of memory currently allocated.
-
-This is different from measuring the memory usage before and after a
-function call:
-
-``` php
-<?php
-
-// script 1
-
-function a() {
- $data = file_get_contents("huge-file");
-}
-
-a();
-
-$profile = memprof_dump_array();
-
-```
-
-In script 1, a before/after approach would designate file_get_contents() as huge
-memory consumer, while the memory it allocates is actually freed quickly after
-it returns. When dumping the memory usage after a() returns, the memprof
-approach would show that file_get_contents() is a small memory consumer since
-the memory it allocated has been freed at the time memprof_dump_array() is
-called.
-
-
-``` php
-<?php
-
-// script 2
-
-function a() {
- global $cache;
- $cache = file_get_contents("huge-file");
-}
-
-a();
-
-$profile = memprof_dump_array();
-```
-
-In script 2, the allocated memory remains allocated after file_get_contents()
-and a() return, and when memprof_dump_array() is called. This time a() and
-file_get_contents() are shown as huge memory consumers.
-
-## How it works
-
-See [INTERNALS.md][7]
-
-## Dependencies
-
- * [Judy Library][3] (e.g. libjudy-dev or judy package)
- * C Library with [malloc hooks][1] (optional; allows to track persistent allocations too)
-
-## Install
-
-### Using PECL
-
- pecl install memprof
-
-### Manually
-
-Download the source and run the following commands in the source directory:
-
- phpize
- ./configure
- make
- make install
-
-## Loading the extension
-
-The extension can be loaded on the command line, just for one script:
-
- php -dextension=memprof.so script.php
-
-Or permanently, in php.ini:
-
- extension=memprof.so
-
-## Usage
-
-Memprof can be enabled during script execution by calling ``memprof_enable()``.
-
-Then the memory usage can be dumped by calling one of the ``memprof_dump_``
-functions. Both tell which functions allocated all the currently allocated
-memory.
-
-Example:
-
-```
-<?php
-
-if (function_exists('memprof_enable')) {
- memprof_enable();
-}
-
-do_some_work();
-
-if (function_exists('memprof_enable')) {
- memprof_dump_callgrind(fopen("/tmp/callgrind.out", "w"));
-}
-```
-
-### memprof_enabled()
-
-Returns whether memprof is enabled.
-
-### memprof_enable()
-
-Enables memprof and start tracking memory allocations. Note: any memory
-allocation made before this call is ignored.
-
-### memprof_disable()
-
-Disables memprof and forget previous allocations.
-
-### memprof_dump_callgrind(resource $stream)
-
-The memprof_dump_callgrind function dumps the current memory usage to a stream
-in callgrind format. The file can then be read with tools such as
-[KCacheGrind][2] or [QCacheGrind][6].
-
-``` php
-<?php
-memprof_dump_callgrind(fopen("output", "w"));
-```
-
-Here is a KcacheGrind screenshot:
-
-![KCacheGrind screenshot](http://img820.imageshack.us/img820/5530/screenshot3kve.png)
-
-### memprof_dump_pprof(resource $stream)
-
-The memprof_dump_pprof function dumps the current memory usage to a stream in
-[pprof][4] format.
-
-``` php
-<?php
-memprof_dump_pprof(fopen("profile.heap", "w"));
-```
-
-The file can be visualized using [google-perftools][5]'s [``pprof``][4] tool.
-
-Display annotated call-graph in web browser or in ``gv``:
-
-```
-$ pprof --web profile.heap
-$ # or:
-$ pprof --gv profile.heap
-```
-
-![pprof call-graph screenshot](http://img707.imageshack.us/img707/7697/screenshot3go.png)
-
-Output one line per function, sorted by own memory usage:
-
-```
-$ pprof --text profile.heap
-```
-
-### memprof_dump_array()
-
-``` php
-<?php
-$dump = memprof_dump_array();
-```
-
-The dump exposes the following information:
-
- * Inclusive and exclusive memory usage of functions (counting only the memory
- that has is still in use when memprof_dump_array is called)
- * Inclusive and exclusive blocks count of functions (number of allocated;
- counting only the blocks that are still in use when memprof_dump_array is
- called)
- * The data is presented in call stacks. This way, if a function is called from
- multiple places, it is possible to see which call path caused it to leak the
- most memory
-
-Example output:
-
- Array
- (
- [memory_size] => 11578
- [blocks_count] => 236
- [memory_size_inclusive] => 10497691
- [blocks_count_inclusive] => 244
- [calls] => 1
- [called_functions] => Array
- (
- [main] => Array
- (
- [memory_size] => 288
- [blocks_count] => 3
- [memory_size_inclusive] => 10486113
- [blocks_count_inclusive] => 8
- [calls] => 1
- [called_functions] => Array
- (
- [a] => Array
- (
- [memory_size] => 4
- [blocks_count] => 1
- [memory_size_inclusive] => 10485825
- [blocks_count_inclusive] => 5
- [calls] => 1
- [called_functions] => Array
- (
- [b] => Array
- (
- [memory_size] => 10485821
- [blocks_count] => 4
- [memory_size_inclusive] => 10485821
- [blocks_count_inclusive] => 4
- [calls] => 1
- [called_functions] => Array
- (
- [str_repeat] => Array
- (
- [memory_size] => 0
- [blocks_count] => 0
- [memory_size_inclusive] => 0
- [blocks_count_inclusive] => 0
- [calls] => 1
- [called_functions] => Array
- (
- )
- )
- )
- )
- )
- )
- [memprof_dump_array] => Array
- (
- [memory_size] => 0
- [blocks_count] => 0
- [memory_size_inclusive] => 0
- [blocks_count_inclusive] => 0
- [calls] => 1
- [called_functions] => Array
- (
- )
- )
- )
- )
- )
- )
-
-## Todo
-
- * Support for tracking persistent (non-zend-alloc) allocations when libc
- doesn't have malloc hooks
-
-[1]: https://www.gnu.org/software/libc/manual/html_node/Hooks-for-Malloc.html#Hooks-for-Malloc
-[2]: http://kcachegrind.sourceforge.net/html/Home.html
-[3]: http://judy.sourceforge.net/index.html
-[4]: https://google-perftools.googlecode.com/svn/trunk/doc/heapprofile.html
-[5]: https://google-perftools.googlecode.com/
-[6]: https://www.google.com/search?q=qcachegrind
-[7]: https://github.com/arnaud-lb/php-memory-profiler/blob/master/INTERNALS.md
-
diff --git a/REFLECTION b/REFLECTION
index feef5ff..d8b1b3c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,49 +1,61 @@
-Extension [ <persistent> extension #107 memprof version 2.0.0 ] {
+Extension [ <persistent> extension #119 memprof version 3.0.2 ] {
+
+ - INI {
+ Entry [ memprof.output_dir <ALL> ]
+ Current = '/tmp'
+ }
+ }
- Functions {
Function [ <internal:memprof> function memprof_enabled ] {
- Parameters [0] {
}
+ - Return [ bool ]
+ }
+ Function [ <internal:memprof> function memprof_enabled_flags ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Function [ <internal:memprof> function memprof_enable ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
Function [ <internal:memprof> function memprof_disable ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
Function [ <internal:memprof> function memprof_dump_array ] {
- Parameters [0] {
}
+ - Return [ array ]
}
Function [ <internal:memprof> function memprof_dump_callgrind ] {
- Parameters [1] {
Parameter #0 [ <required> $handle ]
}
+ - Return [ void ]
}
Function [ <internal:memprof> function memprof_dump_pprof ] {
- Parameters [1] {
Parameter #0 [ <required> $handle ]
}
+ - Return [ void ]
}
- Function [ <internal:memprof> function memory_get_peak_usage ] {
+ Function [ <internal:memprof> function memprof_version ] {
- - Parameters [1] {
- Parameter #0 [ <optional> $real ]
- }
- }
- Function [ <internal:memprof> function memory_get_usage ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $real ]
+ - Parameters [0] {
}
+ - Return [ string ]
}
}
}
diff --git a/php-pecl-memprof.spec b/php-pecl-memprof.spec
index 9f8a9f5..67d231e 100644
--- a/php-pecl-memprof.spec
+++ b/php-pecl-memprof.spec
@@ -3,147 +3,112 @@
#
# Fedora spec file for php-pecl-memprof
#
-# Copyright (c) 2013-2019 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2013-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
-
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-memprof
+%if %{__isa_bits} < 64
+# some tests fail on 32-bit
+%bcond_with tests
+%else
+%bcond_without tests
%endif
+%{?scl:%scl_package php-pecl-memprof}
+
# ZTS build is broken
# https://github.com/arnaud-lb/php-memory-profiler/pull/7
-%global with_zts 0
-%global pecl_name memprof
-%global ini_name 40-%{pecl_name}.ini
+%global with_zts 0
+%global pecl_name memprof
+%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: Memory usage profiler
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.0.0
-Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: BSD
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 3.0.2
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+# see https://github.com/arnaud-lb/php-memory-profiler/issues/93
+License: MIT
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-devel >= 7.1
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: Judy-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
%description
-Memory usage profiler for PHP scripts.
+Memprof is a fast and accurate memory profiler that can be used
+to find the cause of memory leaks in PHP applications.
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
%setup -q -c
-mv %{pecl_name}-%{version} NTS
-mv package2.xml package.xml
# Don't install tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
-cd NTS
-# https://github.com/arnaud-lb/php-memory-profiler/pull/13
-sed -e '/MEMPROF_VERSION/s/1.0.0/%{version}/' -i php_memprof.h
-
+cd %{sources}
# Sanity check, really often broken
-extver=$(sed -n '/#define MEMPROF_VERSION/{s/.* "//;s/".*$//;p}' php_memprof.h)
+extver=$(sed -n '/#define PHP_MEMPROF_VERSION/{s/.* "//;s/".*$//;p}' php_memprof.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
exit 1
fi
cd ..
+mkdir NTS
%if %{with_zts}
# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
+
+; Configuration
+;memprof.output_dir = '/tmp'
EOF
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -167,8 +132,9 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Documentation
-for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+cd %{sources}
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -194,21 +160,43 @@ fi
%check
+# Unusable
+cd %{sources}
+rm tests/autodump-xdebug.phpt
+
: Minimal load test for NTS extension
-%{_bindir}/php --no-php-ini \
+%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with tests}
+grep "HAVE_MALLOC_HOOKS 1" ../NTS/config.h && export MEMPROF_EXPECT_NATIVE_TRACKING=1
+
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/php -n run-tests.php -q --show-diff
+%endif
%if %{with_zts}
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with tests}
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php -q --show-diff
+%endif
%endif
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -222,6 +210,41 @@ fi
%changelog
+* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 3.0.2-3
+- rebuild for PHP 8.3.0RC1
+
+* Thu Jul 13 2023 Remi Collet <remi@remirepo.net> - 3.0.2-2
+- build out of sources tree
+- open https://github.com/arnaud-lb/php-memory-profiler/issues/93
+ license clarification
+
+* Fri Jan 7 2022 Remi Collet <remi@remirepo.net> - 3.0.2-1
+- update to 3.0.2
+- drop patches merged upstream
+
+* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 3.0.1-2
+- rebuild for 8.1.0RC1
+
+* Fri Jul 2 2021 Remi Collet <remi@remirepo.net> - 3.0.1-1
+- update to 3.0.1
+- add patch for PHP 8.1 from
+ https://github.com/arnaud-lb/php-memory-profiler/pull/54
+
+* Tue Mar 30 2021 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- update to 3.0.0
+
+* Thu Nov 19 2020 Remi Collet <remi@remirepo.net> - 2.1.2-1
+- update to 2.1.2 (no change)
+- run upstream test suite during the build
+
+* Wed Nov 18 2020 Remi Collet <remi@remirepo.net> - 2.1.1-1
+- update to 2.1.1
+- open https://github.com/arnaud-lb/php-memory-profiler/pull/43
+ raise PHP minimal version to 7.1 and add tests to archive
+
+* Sun Jul 5 2020 Remi Collet <remi@remirepo.net> - 2.1.0-1
+- update to 2.1.0
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 2.0.0-6
- rebuild for 7.4.0RC1