summaryrefslogtreecommitdiffstats
path: root/php-pecl-memcached.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-memcached.spec')
-rw-r--r--php-pecl-memcached.spec25
1 files changed, 14 insertions, 11 deletions
diff --git a/php-pecl-memcached.spec b/php-pecl-memcached.spec
index c2c6078..527c4e5 100644
--- a/php-pecl-memcached.spec
+++ b/php-pecl-memcached.spec
@@ -33,7 +33,7 @@
Summary: Extension to work with the Memcached caching daemon
Name: %{?sub_prefix}php-pecl-memcached
Version: 3.1.5
-Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 7%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
@@ -69,25 +69,25 @@ BuildRequires: memcached
%endif
BuildRequires: pkgconfig(libevent) >= 2.0.2
-%if 0%{?rhel} == 7
+%if 0%{?rhel} == 7 || 0%{?rhel} == 8
%global move_to_opt 1
-BuildRequires: libmemcached-opt-devel >= 1.0.18
+BuildRequires: libmemcached-awesome-devel >= 1.1
Requires: fastlz%{?_isa}
Requires: cyrus-sasl-lib%{?_isa}
-Requires: libmemcached-opt-libs%{?_isa}
+Requires: libmemcached-awesome%{?_isa}
%else
%global move_to_opt 0
-BuildRequires: pkgconfig(libmemcached) >= 1.0.18
+BuildRequires: pkgconfig(libmemcached) >= 1.1
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-json%{?_isa}
%if %{with igbinary}
-Requires: %{?sub_prefix}php-pecl-igbinary%{?_isa}
+Requires: %{?sub_prefix}php-igbinary%{?_isa}
%endif
%if %{with msgpack}
-Requires: %{?sub_prefix}php-pecl-msgpack%{?_isa}
+Requires: %{?sub_prefix}php-msgpack%{?_isa}
%endif
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
@@ -142,8 +142,8 @@ Obsoletes: php81-pecl-%{pecl_name} <= %{version}
%description
-This extension uses libmemcached library to provide API for communicating
-with memcached servers.
+This extension uses libmemcached-awesome library to provide API for
+communicating with memcached servers.
memcached is a high-performance, distributed memory object caching system,
generic in nature, but intended for use in speeding up dynamic web
@@ -206,7 +206,7 @@ extension=%{pecl_name}.so
;session.save_path="localhost:11211"
; ----- Configuration options
-; http://php.net/manual/en/memcached.configuration.php
+; https://php.net/manual/en/memcached.configuration.php
EOF
@@ -222,7 +222,7 @@ cp -r NTS ZTS
%{?dtsenable}
%if %{move_to_opt}
-export PKG_CONFIG_PATH=/opt/libmemcached/%{_lib}/pkgconfig
+export PKG_CONFIG_PATH=/opt/remi/libmemcached-awesome/%{_lib}/pkgconfig
%endif
peclconf() {
@@ -375,6 +375,9 @@ exit $ret
%changelog
+* Thu Jun 24 2021 Remi Collet <remi@remirepo.net> - 3.1.5-6
+- rebuild using libmemcached-awesome
+
* Wed Jun 9 2021 Remi Collet <remi@remirepo.net> - 3.1.5-5
- rebuild with igbinary and msgpack enabled