summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO40
-rw-r--r--REFLECTION95
-rw-r--r--php-pecl-memcached.spec25
3 files changed, 81 insertions, 79 deletions
diff --git a/PHPINFO b/PHPINFO
index 9c480b2..2c03289 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,7 +3,7 @@ memcached
memcached support => enabled
Version => 3.1.5
-libmemcached version => 1.0.18
+libmemcached version => 1.1.0
SASL support => yes
Session support => yes
igbinary support => yes
@@ -11,30 +11,30 @@ json support => yes
msgpack support => yes
Directive => Local Value => Master Value
-memcached.compression_factor => 1.3 => 1.3
-memcached.compression_threshold => 2000 => 2000
-memcached.compression_type => fastlz => fastlz
-memcached.default_binary_protocol => Off => Off
-memcached.default_connect_timeout => 0 => 0
-memcached.default_consistent_hash => Off => Off
-memcached.serializer => igbinary => igbinary
+memcached.sess_locking => On => On
+memcached.sess_lock_wait_min => 150 => 150
+memcached.sess_lock_wait_max => 150 => 150
+memcached.sess_lock_retries => 5 => 5
+memcached.sess_lock_expire => 0 => 0
memcached.sess_binary_protocol => On => On
-memcached.sess_connect_timeout => 0 => 0
memcached.sess_consistent_hash => On => On
memcached.sess_consistent_hash_type => ketama => ketama
-memcached.sess_lock_expire => 0 => 0
-memcached.sess_lock_max_wait => not set => not set
-memcached.sess_lock_retries => 5 => 5
-memcached.sess_lock_wait => not set => not set
-memcached.sess_lock_wait_max => 150 => 150
-memcached.sess_lock_wait_min => 150 => 150
-memcached.sess_locking => On => On
memcached.sess_number_of_replicas => 0 => 0
-memcached.sess_persistent => Off => Off
-memcached.sess_prefix => memc.sess.key. => memc.sess.key.
memcached.sess_randomize_replica_read => Off => Off
memcached.sess_remove_failed_servers => Off => Off
-memcached.sess_sasl_password => no value => no value
-memcached.sess_sasl_username => no value => no value
memcached.sess_server_failure_limit => 0 => 0
+memcached.sess_connect_timeout => 0 => 0
+memcached.sess_sasl_username => no value => no value
+memcached.sess_sasl_password => no value => no value
+memcached.sess_persistent => Off => Off
+memcached.sess_prefix => memc.sess.key. => memc.sess.key.
+memcached.sess_lock_wait => not set => not set
+memcached.sess_lock_max_wait => not set => not set
+memcached.compression_type => fastlz => fastlz
+memcached.compression_factor => 1.3 => 1.3
+memcached.compression_threshold => 2000 => 2000
+memcached.serializer => igbinary => igbinary
memcached.store_retry_count => 2 => 2
+memcached.default_consistent_hash => Off => Off
+memcached.default_binary_protocol => Off => Off
+memcached.default_connect_timeout => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index 6f3e7d8..c8f3c88 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,69 +1,56 @@
-Extension [ <persistent> extension #181 memcached version 3.1.5 ] {
+Extension [ <persistent> extension #114 memcached version 3.1.5 ] {
- Dependencies {
Dependency [ session (Required) ]
Dependency [ igbinary (Required) ]
Dependency [ msgpack (Required) ]
- Dependency [ spl (Required) ]
}
- INI {
- Entry [ memcached.compression_factor <ALL> ]
- Current = '1.3'
- }
- Entry [ memcached.compression_threshold <ALL> ]
- Current = '2000'
+ Entry [ memcached.sess_locking <ALL> ]
+ Current = '1'
}
- Entry [ memcached.compression_type <ALL> ]
- Current = 'fastlz'
+ Entry [ memcached.sess_lock_wait_min <ALL> ]
+ Current = '150'
}
- Entry [ memcached.default_binary_protocol <ALL> ]
- Current = '0'
+ Entry [ memcached.sess_lock_wait_max <ALL> ]
+ Current = '150'
}
- Entry [ memcached.default_connect_timeout <ALL> ]
- Current = '0'
+ Entry [ memcached.sess_lock_retries <ALL> ]
+ Current = '5'
}
- Entry [ memcached.default_consistent_hash <ALL> ]
+ Entry [ memcached.sess_lock_expire <ALL> ]
Current = '0'
}
- Entry [ memcached.serializer <ALL> ]
- Current = 'igbinary'
- }
Entry [ memcached.sess_binary_protocol <ALL> ]
Current = '1'
}
- Entry [ memcached.sess_connect_timeout <ALL> ]
- Current = '0'
- }
Entry [ memcached.sess_consistent_hash <ALL> ]
Current = '1'
}
Entry [ memcached.sess_consistent_hash_type <ALL> ]
Current = 'ketama'
}
- Entry [ memcached.sess_lock_expire <ALL> ]
+ Entry [ memcached.sess_number_of_replicas <ALL> ]
Current = '0'
}
- Entry [ memcached.sess_lock_max_wait <ALL> ]
- Current = 'not set'
- }
- Entry [ memcached.sess_lock_retries <ALL> ]
- Current = '5'
+ Entry [ memcached.sess_randomize_replica_read <ALL> ]
+ Current = '0'
}
- Entry [ memcached.sess_lock_wait <ALL> ]
- Current = 'not set'
+ Entry [ memcached.sess_remove_failed_servers <ALL> ]
+ Current = '0'
}
- Entry [ memcached.sess_lock_wait_max <ALL> ]
- Current = '150'
+ Entry [ memcached.sess_server_failure_limit <ALL> ]
+ Current = '0'
}
- Entry [ memcached.sess_lock_wait_min <ALL> ]
- Current = '150'
+ Entry [ memcached.sess_connect_timeout <ALL> ]
+ Current = '0'
}
- Entry [ memcached.sess_locking <ALL> ]
- Current = '1'
+ Entry [ memcached.sess_sasl_username <ALL> ]
+ Current = ''
}
- Entry [ memcached.sess_number_of_replicas <ALL> ]
- Current = '0'
+ Entry [ memcached.sess_sasl_password <ALL> ]
+ Current = ''
}
Entry [ memcached.sess_persistent <ALL> ]
Current = '0'
@@ -71,31 +58,43 @@ Extension [ <persistent> extension #181 memcached version 3.1.5 ] {
Entry [ memcached.sess_prefix <ALL> ]
Current = 'memc.sess.key.'
}
- Entry [ memcached.sess_randomize_replica_read <ALL> ]
- Current = '0'
+ Entry [ memcached.sess_lock_wait <ALL> ]
+ Current = 'not set'
}
- Entry [ memcached.sess_remove_failed_servers <ALL> ]
- Current = '0'
+ Entry [ memcached.sess_lock_max_wait <ALL> ]
+ Current = 'not set'
}
- Entry [ memcached.sess_sasl_password <ALL> ]
- Current = ''
+ Entry [ memcached.compression_type <ALL> ]
+ Current = 'fastlz'
}
- Entry [ memcached.sess_sasl_username <ALL> ]
- Current = ''
+ Entry [ memcached.compression_factor <ALL> ]
+ Current = '1.3'
}
- Entry [ memcached.sess_server_failure_limit <ALL> ]
- Current = '0'
+ Entry [ memcached.compression_threshold <ALL> ]
+ Current = '2000'
+ }
+ Entry [ memcached.serializer <ALL> ]
+ Current = 'igbinary'
}
Entry [ memcached.store_retry_count <ALL> ]
Current = '2'
}
+ Entry [ memcached.default_consistent_hash <ALL> ]
+ Current = '0'
+ }
+ Entry [ memcached.default_binary_protocol <ALL> ]
+ Current = '0'
+ }
+ Entry [ memcached.default_connect_timeout <ALL> ]
+ Current = '0'
+ }
}
- Classes [3] {
Class [ <internal:memcached> class Memcached ] {
- Constants [133] {
- Constant [ public int LIBMEMCACHED_VERSION_HEX ] { 16777240 }
+ Constant [ public int LIBMEMCACHED_VERSION_HEX ] { 16781312 }
Constant [ public int OPT_COMPRESSION ] { -1001 }
Constant [ public int OPT_COMPRESSION_TYPE ] { -1004 }
Constant [ public int OPT_PREFIX_KEY ] { -1002 }
@@ -729,7 +728,7 @@ Extension [ <persistent> extension #181 memcached version 3.1.5 ] {
}
}
- Class [ <internal:memcached> class MemcachedException extends RuntimeException implements Throwable ] {
+ Class [ <internal:memcached> class MemcachedException extends Exception implements Throwable ] {
- Constants [0] {
}
diff --git a/php-pecl-memcached.spec b/php-pecl-memcached.spec
index c2c6078..527c4e5 100644
--- a/php-pecl-memcached.spec
+++ b/php-pecl-memcached.spec
@@ -33,7 +33,7 @@
Summary: Extension to work with the Memcached caching daemon
Name: %{?sub_prefix}php-pecl-memcached
Version: 3.1.5
-Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 7%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
@@ -69,25 +69,25 @@ BuildRequires: memcached
%endif
BuildRequires: pkgconfig(libevent) >= 2.0.2
-%if 0%{?rhel} == 7
+%if 0%{?rhel} == 7 || 0%{?rhel} == 8
%global move_to_opt 1
-BuildRequires: libmemcached-opt-devel >= 1.0.18
+BuildRequires: libmemcached-awesome-devel >= 1.1
Requires: fastlz%{?_isa}
Requires: cyrus-sasl-lib%{?_isa}
-Requires: libmemcached-opt-libs%{?_isa}
+Requires: libmemcached-awesome%{?_isa}
%else
%global move_to_opt 0
-BuildRequires: pkgconfig(libmemcached) >= 1.0.18
+BuildRequires: pkgconfig(libmemcached) >= 1.1
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-json%{?_isa}
%if %{with igbinary}
-Requires: %{?sub_prefix}php-pecl-igbinary%{?_isa}
+Requires: %{?sub_prefix}php-igbinary%{?_isa}
%endif
%if %{with msgpack}
-Requires: %{?sub_prefix}php-pecl-msgpack%{?_isa}
+Requires: %{?sub_prefix}php-msgpack%{?_isa}
%endif
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
@@ -142,8 +142,8 @@ Obsoletes: php81-pecl-%{pecl_name} <= %{version}
%description
-This extension uses libmemcached library to provide API for communicating
-with memcached servers.
+This extension uses libmemcached-awesome library to provide API for
+communicating with memcached servers.
memcached is a high-performance, distributed memory object caching system,
generic in nature, but intended for use in speeding up dynamic web
@@ -206,7 +206,7 @@ extension=%{pecl_name}.so
;session.save_path="localhost:11211"
; ----- Configuration options
-; http://php.net/manual/en/memcached.configuration.php
+; https://php.net/manual/en/memcached.configuration.php
EOF
@@ -222,7 +222,7 @@ cp -r NTS ZTS
%{?dtsenable}
%if %{move_to_opt}
-export PKG_CONFIG_PATH=/opt/libmemcached/%{_lib}/pkgconfig
+export PKG_CONFIG_PATH=/opt/remi/libmemcached-awesome/%{_lib}/pkgconfig
%endif
peclconf() {
@@ -375,6 +375,9 @@ exit $ret
%changelog
+* Thu Jun 24 2021 Remi Collet <remi@remirepo.net> - 3.1.5-6
+- rebuild using libmemcached-awesome
+
* Wed Jun 9 2021 Remi Collet <remi@remirepo.net> - 3.1.5-5
- rebuild with igbinary and msgpack enabled