summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-02 13:38:40 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-02 13:38:40 +0100
commit072d145521245754507f67cbed38e101e53f9cef (patch)
tree6aa6b8bc6febd8733f454500019574fe72efc9a9
parentc37ac7a99bae3f576e7522f17c3fd57d327d4b8a (diff)
php-pecl-memcached: enable igbinary
-rw-r--r--REFLECTION-PHP7 (renamed from reflection-2.2.0)93
-rw-r--r--memcached-pr3.patch42
-rw-r--r--php-pecl-memcached-dev.spec25
-rw-r--r--php-pecl-memcached.spec2
-rw-r--r--reflection-2.1.0624
5 files changed, 85 insertions, 701 deletions
diff --git a/reflection-2.2.0 b/REFLECTION-PHP7
index 48dec61..94f1b1a 100644
--- a/reflection-2.2.0
+++ b/REFLECTION-PHP7
@@ -1,14 +1,14 @@
-Extension [ <persistent> extension #156 memcached version 2.2.0 ] {
+Extension [ <persistent> extension #85 memcached version 2.2.1-dev ] {
- INI {
Entry [ memcached.sess_locking <ALL> ]
Current = '1'
}
Entry [ memcached.sess_consistent_hash <ALL> ]
- Current = '0'
+ Current = ''
}
Entry [ memcached.sess_binary <ALL> ]
- Current = '0'
+ Current = ''
}
Entry [ memcached.sess_lock_wait <ALL> ]
Current = '150000'
@@ -26,10 +26,10 @@ Extension [ <persistent> extension #156 memcached version 2.2.0 ] {
Current = '0'
}
Entry [ memcached.sess_randomize_replica_read <ALL> ]
- Current = '0'
+ Current = ''
}
Entry [ memcached.sess_remove_failed <ALL> ]
- Current = '0'
+ Current = '1'
}
Entry [ memcached.sess_connect_timeout <ALL> ]
Current = '1000'
@@ -53,17 +53,17 @@ Extension [ <persistent> extension #156 memcached version 2.2.0 ] {
Current = 'igbinary'
}
Entry [ memcached.use_sasl <SYSTEM> ]
- Current = '0'
+ Current = ''
}
Entry [ memcached.store_retry_count <ALL> ]
Current = '2'
}
}
- - Classes [3] {
+ - Classes [2] {
Class [ <internal:memcached> class Memcached ] {
- - Constants [130] {
+ - Constants [99] {
Constant [ integer LIBMEMCACHED_VERSION_HEX ] { 16777240 }
Constant [ integer OPT_COMPRESSION ] { -1001 }
Constant [ integer OPT_COMPRESSION_TYPE ] { -1004 }
@@ -162,37 +162,6 @@ Extension [ <persistent> extension #156 memcached version 2.2.0 ] {
Constant [ integer COMPRESSION_FASTLZ ] { 2 }
Constant [ integer COMPRESSION_ZLIB ] { 1 }
Constant [ integer GET_PRESERVE_ORDER ] { 1 }
- Constant [ integer ON_CONNECT ] { 0 }
- Constant [ integer ON_ADD ] { 1 }
- Constant [ integer ON_APPEND ] { 2 }
- Constant [ integer ON_DECREMENT ] { 3 }
- Constant [ integer ON_DELETE ] { 4 }
- Constant [ integer ON_FLUSH ] { 5 }
- Constant [ integer ON_GET ] { 6 }
- Constant [ integer ON_INCREMENT ] { 7 }
- Constant [ integer ON_NOOP ] { 8 }
- Constant [ integer ON_PREPEND ] { 9 }
- Constant [ integer ON_QUIT ] { 10 }
- Constant [ integer ON_REPLACE ] { 11 }
- Constant [ integer ON_SET ] { 12 }
- Constant [ integer ON_STAT ] { 13 }
- Constant [ integer ON_VERSION ] { 14 }
- Constant [ integer RESPONSE_SUCCESS ] { 0 }
- Constant [ integer RESPONSE_KEY_ENOENT ] { 1 }
- Constant [ integer RESPONSE_KEY_EEXISTS ] { 2 }
- Constant [ integer RESPONSE_E2BIG ] { 3 }
- Constant [ integer RESPONSE_EINVAL ] { 4 }
- Constant [ integer RESPONSE_NOT_STORED ] { 5 }
- Constant [ integer RESPONSE_DELTA_BADVAL ] { 6 }
- Constant [ integer RESPONSE_NOT_MY_VBUCKET ] { 7 }
- Constant [ integer RESPONSE_AUTH_ERROR ] { 32 }
- Constant [ integer RESPONSE_AUTH_CONTINUE ] { 33 }
- Constant [ integer RESPONSE_UNKNOWN_COMMAND ] { 129 }
- Constant [ integer RESPONSE_ENOMEM ] { 130 }
- Constant [ integer RESPONSE_NOT_SUPPORTED ] { 131 }
- Constant [ integer RESPONSE_EINTERNAL ] { 132 }
- Constant [ integer RESPONSE_EBUSY ] { 133 }
- Constant [ integer RESPONSE_ETMPFAIL ] { 134 }
Constant [ boolean GET_ERROR_RETURN_VALUE ] { }
}
@@ -684,30 +653,7 @@ Extension [ <persistent> extension #156 memcached version 2.2.0 ] {
}
}
- Class [ <internal:memcached> class MemcachedServer ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [2] {
- Method [ <internal:memcached> public method run ] {
- }
-
- Method [ <internal:memcached> public method on ] {
- }
- }
- }
-
- Class [ <internal:memcached> class MemcachedException extends RuntimeException ] {
+ Class [ <internal:memcached> class MemcachedException extends RuntimeException implements Throwable ] {
- Constants [0] {
}
@@ -725,7 +671,7 @@ Extension [ <persistent> extension #156 memcached version 2.2.0 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -735,28 +681,31 @@ Extension [ <persistent> extension #156 memcached version 2.2.0 ] {
}
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
diff --git a/memcached-pr3.patch b/memcached-pr3.patch
new file mode 100644
index 0000000..5e0e194
--- /dev/null
+++ b/memcached-pr3.patch
@@ -0,0 +1,42 @@
+From 5c49c02dfd0b12f46ba2909aaec31938c6e96728 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Wed, 2 Mar 2016 11:37:50 +0100
+Subject: [PATCH] Fix build with igbinary
+
+Using https://github.com/igbinary/igbinary7
+---
+ php_memcached.c | 10 ++++++++--
+ 1 file changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/php_memcached.c b/php_memcached.c
+index 9195bfc..09df000 100644
+--- a/php_memcached.c
++++ b/php_memcached.c
+@@ -3088,11 +3088,17 @@ zend_bool s_serialize_value (enum memcached_serializer serializer, zval *value,
+ */
+ #ifdef HAVE_MEMCACHED_IGBINARY
+ case SERIALIZER_IGBINARY:
+- if (igbinary_serialize((uint8_t **) &buf->c, &buf->len, value) != 0) {
++ {
++ char *s;
++ size_t l;
++ if (igbinary_serialize((uint8_t **) &s, &l, value) != 0) {
+ php_error_docref(NULL, E_WARNING, "could not serialize value with igbinary");
+ return 0;
+ }
++ smart_str_setl(buf, s, l);
++ efree(s);
+ MEMC_VAL_SET_TYPE(*flags, MEMC_VAL_IS_IGBINARY);
++ }
+ break;
+ #endif
+
+@@ -3306,7 +3312,7 @@ zend_bool s_unserialize_value (enum memcached_serializer serializer, int val_typ
+
+ case MEMC_VAL_IS_IGBINARY:
+ #ifdef HAVE_MEMCACHED_IGBINARY
+- if (igbinary_unserialize((uint8_t *)payload, payload_len, &value)) {
++ if (igbinary_unserialize((const uint8_t *)payload, payload_len, value)) {
+ ZVAL_FALSE(value);
+ php_error_docref(NULL, E_WARNING, "could not unserialize value with igbinary");
+ return 0;
diff --git a/php-pecl-memcached-dev.spec b/php-pecl-memcached-dev.spec
index aaaf8be..c0c08b0 100644
--- a/php-pecl-memcached-dev.spec
+++ b/php-pecl-memcached-dev.spec
@@ -24,7 +24,7 @@
%{!?__php: %global __php %{_bindir}/php}
%global with_fastlz 1
-%global with_igbin 0
+%global with_igbin 1
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
%global pecl_name memcached
@@ -49,13 +49,16 @@
Summary: Extension to work with the Memcached caching daemon
Name: %{?sub_prefix}php-pecl-memcached
Version: 2.2.1
-Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}-%{gh_short}.tar.gz
+# https://github.com/rlerdorf/php-memcached/pull/3
+Patch0: %{pecl_name}-pr3.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# 5.2.10 required to HAVE_JSON enabled
BuildRequires: %{?scl_prefix}php-devel >= 5.2.10
@@ -163,9 +166,12 @@ sed -e '/PHP_MEMCACHED_VERSION/s/2.2.0/%{version}-dev/' -i NTS/php_memcached.h
'
# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
+%patch0 -p1 -b .pr3
%if %{with_fastlz}
rm -r fastlz
@@ -274,6 +280,7 @@ done
rm -rf %{buildroot}
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -290,6 +297,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -316,6 +324,9 @@ ret=0
: Launch the Memcached service
memcached -p 11211 -U 11211 -d -P $PWD/memcached.pid
+rm ?TS/tests/experimental/serializer_json.phpt
+rm ?TS/tests/experimental/serializer_igbinary.phpt
+
: Run the upstream test Suite for NTS extension
pushd NTS
rm tests/flush_buffers.phpt tests/touch_binary.phpt
@@ -323,7 +334,7 @@ TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php || ret=1
+%{__php} -n run-tests.php --show-diff || ret=1
popd
%if %{with_zts}
@@ -334,7 +345,7 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php || ret=1
+%{__ztsphp} -n run-tests.php --show-diff || ret=1
popd
%endif
@@ -363,6 +374,10 @@ exit $ret
%changelog
+* Wed Mar 2 2016 Remi Collet <remi@fedoraproject.org> - 2.2.1-0.2.20150628git3c79a97
+- add patch for igbinary, see
+ https://github.com/rlerdorf/php-memcached/pull/3
+
* Sun Jan 10 2016 Remi Collet <remi@fedoraproject.org> - 2.2.1-0.1.20150628git3c79a97
- bump version to 2.2.1-dev, stability=devel
diff --git a/php-pecl-memcached.spec b/php-pecl-memcached.spec
index c6fd2e9..5ba3518 100644
--- a/php-pecl-memcached.spec
+++ b/php-pecl-memcached.spec
@@ -256,6 +256,7 @@ done
rm -rf %{buildroot}
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -272,6 +273,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
diff --git a/reflection-2.1.0 b/reflection-2.1.0
deleted file mode 100644
index 6c16b0d..0000000
--- a/reflection-2.1.0
+++ /dev/null
@@ -1,624 +0,0 @@
-Extension [ <persistent> extension #60 memcached version 2.1.0 ] {
-
- - Dependencies {
- Dependency [ session (Required) ]
- Dependency [ igbinary (Required) ]
- Dependency [ spl (Required) ]
- }
-
- - INI {
- Entry [ memcached.sess_locking <ALL> ]
- Current = '1'
- }
- Entry [ memcached.sess_binary <ALL> ]
- Current = '0'
- }
- Entry [ memcached.sess_lock_wait <ALL> ]
- Current = '150000'
- }
- Entry [ memcached.sess_prefix <ALL> ]
- Current = 'memc.sess.key.'
- }
- Entry [ memcached.compression_type <ALL> ]
- Current = 'fastlz'
- }
- Entry [ memcached.compression_factor <ALL> ]
- Current = '1.3'
- }
- Entry [ memcached.compression_threshold <ALL> ]
- Current = '2000'
- }
- Entry [ memcached.serializer <ALL> ]
- Current = 'igbinary'
- }
- Entry [ memcached.use_sasl <SYSTEM> ]
- Current = '0'
- }
- }
-
- - Classes [2] {
- Class [ <internal:memcached> class Memcached ] {
-
- - Constants [89] {
- Constant [ integer OPT_COMPRESSION ] { -1001 }
- Constant [ integer OPT_COMPRESSION_TYPE ] { -1004 }
- Constant [ integer OPT_PREFIX_KEY ] { -1002 }
- Constant [ integer OPT_SERIALIZER ] { -1003 }
- Constant [ integer HAVE_IGBINARY ] { 1 }
- Constant [ integer HAVE_JSON ] { 1 }
- Constant [ integer HAVE_SESSION ] { 1 }
- Constant [ integer HAVE_SASL ] { 1 }
- Constant [ integer OPT_HASH ] { 2 }
- Constant [ integer HASH_DEFAULT ] { 0 }
- Constant [ integer HASH_MD5 ] { 1 }
- Constant [ integer HASH_CRC ] { 2 }
- Constant [ integer HASH_FNV1_64 ] { 3 }
- Constant [ integer HASH_FNV1A_64 ] { 4 }
- Constant [ integer HASH_FNV1_32 ] { 5 }
- Constant [ integer HASH_FNV1A_32 ] { 6 }
- Constant [ integer HASH_HSIEH ] { 7 }
- Constant [ integer HASH_MURMUR ] { 8 }
- Constant [ integer OPT_DISTRIBUTION ] { 9 }
- Constant [ integer DISTRIBUTION_MODULA ] { 0 }
- Constant [ integer DISTRIBUTION_CONSISTENT ] { 1 }
- Constant [ integer DISTRIBUTION_VIRTUAL_BUCKET ] { 6 }
- Constant [ integer OPT_LIBKETAMA_COMPATIBLE ] { 16 }
- Constant [ integer OPT_LIBKETAMA_HASH ] { 17 }
- Constant [ integer OPT_TCP_KEEPALIVE ] { 32 }
- Constant [ integer OPT_BUFFER_WRITES ] { 10 }
- Constant [ integer OPT_BINARY_PROTOCOL ] { 18 }
- Constant [ integer OPT_NO_BLOCK ] { 0 }
- Constant [ integer OPT_TCP_NODELAY ] { 1 }
- Constant [ integer OPT_SOCKET_SEND_SIZE ] { 4 }
- Constant [ integer OPT_SOCKET_RECV_SIZE ] { 5 }
- Constant [ integer OPT_CONNECT_TIMEOUT ] { 14 }
- Constant [ integer OPT_RETRY_TIMEOUT ] { 15 }
- Constant [ integer OPT_SEND_TIMEOUT ] { 19 }
- Constant [ integer OPT_RECV_TIMEOUT ] { 20 }
- Constant [ integer OPT_POLL_TIMEOUT ] { 8 }
- Constant [ integer OPT_CACHE_LOOKUPS ] { 6 }
- Constant [ integer OPT_SERVER_FAILURE_LIMIT ] { 21 }
- Constant [ integer OPT_AUTO_EJECT_HOSTS ] { 28 }
- Constant [ integer OPT_HASH_WITH_PREFIX_KEY ] { 25 }
- Constant [ integer OPT_NOREPLY ] { 26 }
- Constant [ integer OPT_SORT_HOSTS ] { 12 }
- Constant [ integer OPT_VERIFY_KEY ] { 13 }
- Constant [ integer OPT_USE_UDP ] { 27 }
- Constant [ integer OPT_NUMBER_OF_REPLICAS ] { 29 }
- Constant [ integer OPT_RANDOMIZE_REPLICA_READ ] { 30 }
- Constant [ integer OPT_REMOVE_FAILED_SERVERS ] { 35 }
- Constant [ integer RES_SUCCESS ] { 0 }
- Constant [ integer RES_FAILURE ] { 1 }
- Constant [ integer RES_HOST_LOOKUP_FAILURE ] { 2 }
- Constant [ integer RES_UNKNOWN_READ_FAILURE ] { 7 }
- Constant [ integer RES_PROTOCOL_ERROR ] { 8 }
- Constant [ integer RES_CLIENT_ERROR ] { 9 }
- Constant [ integer RES_SERVER_ERROR ] { 10 }
- Constant [ integer RES_WRITE_FAILURE ] { 5 }
- Constant [ integer RES_DATA_EXISTS ] { 12 }
- Constant [ integer RES_NOTSTORED ] { 14 }
- Constant [ integer RES_NOTFOUND ] { 16 }
- Constant [ integer RES_PARTIAL_READ ] { 18 }
- Constant [ integer RES_SOME_ERRORS ] { 19 }
- Constant [ integer RES_NO_SERVERS ] { 20 }
- Constant [ integer RES_END ] { 21 }
- Constant [ integer RES_ERRNO ] { 26 }
- Constant [ integer RES_BUFFERED ] { 32 }
- Constant [ integer RES_TIMEOUT ] { 31 }
- Constant [ integer RES_BAD_KEY_PROVIDED ] { 33 }
- Constant [ integer RES_STORED ] { 15 }
- Constant [ integer RES_DELETED ] { 22 }
- Constant [ integer RES_STAT ] { 24 }
- Constant [ integer RES_ITEM ] { 25 }
- Constant [ integer RES_NOT_SUPPORTED ] { 28 }
- Constant [ integer RES_FETCH_NOTFINISHED ] { 30 }
- Constant [ integer RES_SERVER_MARKED_DEAD ] { 35 }
- Constant [ integer RES_UNKNOWN_STAT_KEY ] { 36 }
- Constant [ integer RES_INVALID_HOST_PROTOCOL ] { 34 }
- Constant [ integer RES_MEMORY_ALLOCATION_FAILURE ] { 17 }
- Constant [ integer RES_CONNECTION_SOCKET_CREATE_FAILURE ] { 11 }
- Constant [ integer RES_AUTH_PROBLEM ] { 40 }
- Constant [ integer RES_AUTH_FAILURE ] { 41 }
- Constant [ integer RES_AUTH_CONTINUE ] { 42 }
- Constant [ integer RES_PAYLOAD_FAILURE ] { -1001 }
- Constant [ integer SERIALIZER_PHP ] { 1 }
- Constant [ integer SERIALIZER_IGBINARY ] { 2 }
- Constant [ integer SERIALIZER_JSON ] { 3 }
- Constant [ integer SERIALIZER_JSON_ARRAY ] { 4 }
- Constant [ integer COMPRESSION_FASTLZ ] { 2 }
- Constant [ integer COMPRESSION_ZLIB ] { 1 }
- Constant [ integer GET_PRESERVE_ORDER ] { 1 }
- Constant [ boolean GET_ERROR_RETURN_VALUE ] { }
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [51] {
- Method [ <internal:memcached, ctor> public method __construct ] {
-
- - Parameters [2] {
- Parameter #0 [ <optional> $persistent_id ]
- Parameter #1 [ <optional> $callback ]
- }
- }
-
- Method [ <internal:memcached> public method getResultCode ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:memcached> public method getResultMessage ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:memcached> public method get ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> $cache_cb ]
- Parameter #2 [ <optional> &$cas_token ]
- }
- }
-
- Method [ <internal:memcached> public method getByKey ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $server_key ]
- Parameter #1 [ <required> $key ]
- Parameter #2 [ <optional> $cache_cb ]
- Parameter #3 [ <optional> &$cas_token ]
- }
- }
-
- Method [ <internal:memcached> public method getMulti ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> array $keys ]
- Parameter #1 [ <optional> &$cas_tokens ]
- Parameter #2 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:memcached> public method getMultiByKey ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $server_key ]
- Parameter #1 [ <required> array $keys ]
- Parameter #2 [ <optional> &$cas_tokens ]
- Parameter #3 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:memcached> public method getDelayed ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> array $keys ]
- Parameter #1 [ <optional> $with_cas ]
- Parameter #2 [ <optional> $value_cb ]
- }
- }
-
- Method [ <internal:memcached> public method getDelayedByKey ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $server_key ]
- Parameter #1 [ <required> array $keys ]
- Parameter #2 [ <optional> $with_cas ]
- Parameter #3 [ <optional> $value_cb ]
- }
- }
-
- Method [ <internal:memcached> public method fetch ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:memcached> public method fetchAll ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:memcached> public method set ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method setByKey ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $server_key ]
- Parameter #1 [ <required> $key ]
- Parameter #2 [ <required> $value ]
- Parameter #3 [ <optional> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method touch ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method touchByKey ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $server_key ]
- Parameter #1 [ <required> $key ]
- Parameter #2 [ <required> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method setMulti ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> array $items ]
- Parameter #1 [ <optional> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method setMultiByKey ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $server_key ]
- Parameter #1 [ <required> array $items ]
- Parameter #2 [ <optional> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method cas ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $cas_token ]
- Parameter #1 [ <required> $key ]
- Parameter #2 [ <required> $value ]
- Parameter #3 [ <optional> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method casByKey ] {
-
- - Parameters [5] {
- Parameter #0 [ <required> $cas_token ]
- Parameter #1 [ <required> $server_key ]
- Parameter #2 [ <required> $key ]
- Parameter #3 [ <required> $value ]
- Parameter #4 [ <optional> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method add ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method addByKey ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $server_key ]
- Parameter #1 [ <required> $key ]
- Parameter #2 [ <required> $value ]
- Parameter #3 [ <optional> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method append ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method appendByKey ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $server_key ]
- Parameter #1 [ <required> $key ]
- Parameter #2 [ <required> $value ]
- Parameter #3 [ <optional> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method prepend ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method prependByKey ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $server_key ]
- Parameter #1 [ <required> $key ]
- Parameter #2 [ <required> $value ]
- Parameter #3 [ <optional> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method replace ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method replaceByKey ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $server_key ]
- Parameter #1 [ <required> $key ]
- Parameter #2 [ <required> $value ]
- Parameter #3 [ <optional> $expiration ]
- }
- }
-
- Method [ <internal:memcached> public method delete ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> $time ]
- }
- }
-
- Method [ <internal:memcached> public method deleteMulti ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $keys ]
- Parameter #1 [ <optional> $time ]
- }
- }
-
- Method [ <internal:memcached> public method deleteByKey ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $server_key ]
- Parameter #1 [ <required> $key ]
- Parameter #2 [ <optional> $time ]
- }
- }
-
- Method [ <internal:memcached> public method deleteMultiByKey ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $server_key ]
- Parameter #1 [ <required> $keys ]
- Parameter #2 [ <optional> $time ]
- }
- }
-
- Method [ <internal:memcached> public method increment ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> $offset ]
- Parameter #2 [ <optional> $initial_value ]
- Parameter #3 [ <optional> $expiry ]
- }
- }
-
- Method [ <internal:memcached> public method decrement ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> $offset ]
- Parameter #2 [ <optional> $initial_value ]
- Parameter #3 [ <optional> $expiry ]
- }
- }
-
- Method [ <internal:memcached> public method incrementByKey ] {
-
- - Parameters [5] {
- Parameter #0 [ <required> $server_key ]
- Parameter #1 [ <required> $key ]
- Parameter #2 [ <optional> $offset ]
- Parameter #3 [ <optional> $initial_value ]
- Parameter #4 [ <optional> $expiry ]
- }
- }
-
- Method [ <internal:memcached> public method decrementByKey ] {
-
- - Parameters [5] {
- Parameter #0 [ <required> $server_key ]
- Parameter #1 [ <required> $key ]
- Parameter #2 [ <optional> $offset ]
- Parameter #3 [ <optional> $initial_value ]
- Parameter #4 [ <optional> $expiry ]
- }
- }
-
- Method [ <internal:memcached> public method addServer ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $host ]
- Parameter #1 [ <required> $port ]
- Parameter #2 [ <optional> $weight ]
- }
- }
-
- Method [ <internal:memcached> public method addServers ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $servers ]
- }
- }
-
- Method [ <internal:memcached> public method getServerList ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:memcached> public method getServerByKey ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $server_key ]
- }
- }
-
- Method [ <internal:memcached> public method resetServerList ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:memcached> public method quit ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:memcached> public method getStats ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:memcached> public method getVersion ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:memcached> public method getAllKeys ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:memcached> public method flush ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $delay ]
- }
- }
-
- Method [ <internal:memcached> public method getOption ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $option ]
- }
- }
-
- Method [ <internal:memcached> public method setOption ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $option ]
- Parameter #1 [ <required> $value ]
- }
- }
-
- Method [ <internal:memcached> public method setOptions ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $options ]
- }
- }
-
- Method [ <internal:memcached> public method setSaslAuthData ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $username ]
- Parameter #1 [ <required> $password ]
- }
- }
-
- Method [ <internal:memcached> public method isPersistent ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:memcached> public method isPristine ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:memcached> class MemcachedException extends RuntimeException ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- }
-
- - Methods [9] {
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
- }
- }
-
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
- }
-
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
- }
-
- Method [ <internal:Core, inherits Exception> public method __toString ] {
- }
- }
- }
- }
-}
-