summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-05 14:08:36 +0200
committerRemi Collet <remi@remirepo.net>2017-10-05 14:08:36 +0200
commite17f6d3c18d467d52c042a2eaae576111395a068 (patch)
tree760e43e9a90fa74a2159cf5c022a1f16f5f3a602
parentcd75597ffffbcaeb97f1c8283fa9815c51f0cd01 (diff)
cleanup
-rw-r--r--REFLECTION-DEV295
-rw-r--r--php-pecl-memcache-dev.spec458
2 files changed, 0 insertions, 753 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
deleted file mode 100644
index a7c17af..0000000
--- a/REFLECTION-DEV
+++ /dev/null
@@ -1,295 +0,0 @@
-Extension [ <persistent> extension #105 memcache version 3.0.9-dev ] {
-
- - INI {
- Entry [ memcache.allow_failover <ALL> ]
- Current = '1'
- }
- Entry [ memcache.max_failover_attempts <ALL> ]
- Current = '20'
- }
- Entry [ memcache.default_port <ALL> ]
- Current = '11211'
- }
- Entry [ memcache.chunk_size <ALL> ]
- Current = '32768'
- }
- Entry [ memcache.protocol <ALL> ]
- Current = 'ascii'
- }
- Entry [ memcache.hash_strategy <ALL> ]
- Current = 'consistent'
- }
- Entry [ memcache.hash_function <ALL> ]
- Current = 'crc32'
- }
- Entry [ memcache.redundancy <ALL> ]
- Current = '1'
- }
- Entry [ memcache.session_redundancy <ALL> ]
- Current = '2'
- }
- Entry [ memcache.compress_threshold <ALL> ]
- Current = '20000'
- }
- Entry [ memcache.lock_timeout <ALL> ]
- Current = '15'
- }
- }
-
- - Constants [6] {
- Constant [ integer MEMCACHE_COMPRESSED ] { 2 }
- Constant [ integer MEMCACHE_USER1 ] { 65536 }
- Constant [ integer MEMCACHE_USER2 ] { 131072 }
- Constant [ integer MEMCACHE_USER3 ] { 262144 }
- Constant [ integer MEMCACHE_USER4 ] { 524288 }
- Constant [ integer MEMCACHE_HAVE_SESSION ] { 1 }
- }
-
- - Functions {
- Function [ <internal:memcache> function memcache_connect ] {
- }
- Function [ <internal:memcache> function memcache_pconnect ] {
- }
- Function [ <internal:memcache> function memcache_add_server ] {
- }
- Function [ <internal:memcache> function memcache_set_server_params ] {
- }
- Function [ <internal:memcache> function memcache_set_failure_callback ] {
- }
- Function [ <internal:memcache> function memcache_get_server_status ] {
- }
- Function [ <internal:memcache> function memcache_get_version ] {
- }
- Function [ <internal:memcache> function memcache_add ] {
- }
- Function [ <internal:memcache> function memcache_set ] {
- }
- Function [ <internal:memcache> function memcache_replace ] {
- }
- Function [ <internal:memcache> function memcache_cas ] {
- }
- Function [ <internal:memcache> function memcache_append ] {
- }
- Function [ <internal:memcache> function memcache_prepend ] {
- }
- Function [ <internal:memcache> function memcache_get ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $param0 ]
- Parameter #1 [ <required> $param1 ]
- Parameter #2 [ <required> &$param2 ]
- Parameter #3 [ <required> &$param3 ]
- }
- }
- Function [ <internal:memcache> function memcache_delete ] {
- }
- Function [ <internal:memcache> function memcache_debug ] {
- }
- Function [ <internal:memcache> function memcache_get_stats ] {
- }
- Function [ <internal:memcache> function memcache_get_extended_stats ] {
- }
- Function [ <internal:memcache> function memcache_set_compress_threshold ] {
- }
- Function [ <internal:memcache> function memcache_increment ] {
- }
- Function [ <internal:memcache> function memcache_decrement ] {
- }
- Function [ <internal:memcache> function memcache_close ] {
- }
- Function [ <internal:memcache> function memcache_flush ] {
- }
- Function [ <internal:memcache> function memcache_set_sasl_auth_data ] {
- }
- }
-
- - Classes [2] {
- Class [ <internal:memcache> class MemcachePool ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [23] {
- Method [ <internal:memcache> public method connect ] {
- }
-
- Method [ <internal:memcache> public method addserver ] {
- }
-
- Method [ <internal:memcache> public method setserverparams ] {
- }
-
- Method [ <internal:memcache> public method setfailurecallback ] {
- }
-
- Method [ <internal:memcache> public method getserverstatus ] {
- }
-
- Method [ <internal:memcache> public method findserver ] {
- }
-
- Method [ <internal:memcache> public method getversion ] {
- }
-
- Method [ <internal:memcache> public method add ] {
- }
-
- Method [ <internal:memcache> public method set ] {
- }
-
- Method [ <internal:memcache> public method replace ] {
- }
-
- Method [ <internal:memcache> public method cas ] {
- }
-
- Method [ <internal:memcache> public method append ] {
- }
-
- Method [ <internal:memcache> public method prepend ] {
- }
-
- Method [ <internal:memcache> public method get ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $param0 ]
- Parameter #1 [ <required> &$param1 ]
- Parameter #2 [ <required> &$param2 ]
- }
- }
-
- Method [ <internal:memcache> public method delete ] {
- }
-
- Method [ <internal:memcache> public method getstats ] {
- }
-
- Method [ <internal:memcache> public method getextendedstats ] {
- }
-
- Method [ <internal:memcache> public method setcompressthreshold ] {
- }
-
- Method [ <internal:memcache> public method increment ] {
- }
-
- Method [ <internal:memcache> public method decrement ] {
- }
-
- Method [ <internal:memcache> public method close ] {
- }
-
- Method [ <internal:memcache> public method flush ] {
- }
-
- Method [ <internal:memcache> public method setSaslAuthData ] {
- }
- }
- }
-
- Class [ <internal:memcache> class Memcache extends MemcachePool ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [24] {
- Method [ <internal:memcache, overwrites MemcachePool, prototype MemcachePool> public method connect ] {
- }
-
- Method [ <internal:memcache> public method pconnect ] {
- }
-
- Method [ <internal:memcache, overwrites MemcachePool, prototype MemcachePool> public method addserver ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method setserverparams ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method setfailurecallback ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method getserverstatus ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method findserver ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method getversion ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method add ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method set ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method replace ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method cas ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method append ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method prepend ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method get ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $param0 ]
- Parameter #1 [ <required> &$param1 ]
- Parameter #2 [ <required> &$param2 ]
- }
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method delete ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method getstats ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method getextendedstats ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method setcompressthreshold ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method increment ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method decrement ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method close ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method flush ] {
- }
-
- Method [ <internal:memcache, inherits MemcachePool> public method setSaslAuthData ] {
- }
- }
- }
- }
-}
-
diff --git a/php-pecl-memcache-dev.spec b/php-pecl-memcache-dev.spec
deleted file mode 100644
index 002fa9d..0000000
--- a/php-pecl-memcache-dev.spec
+++ /dev/null
@@ -1,458 +0,0 @@
-# spec file for php-pecl-memcache
-#
-# Copyright (c) 2007-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-memcache
-%endif
-
-# https://github.com/websupport-sk/pecl-memcache/commits/NON_BLOCKING_IO_php7
-%global gh_commit df7735e813d247ea141458e1774d163ad4e2d068
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner websupport-sk
-%global gh_project pecl-memcache
-%global gh_date 20161124
-%global pecl_name memcache
-# Not ready, some failed UDP tests. Neded investigation.
-%global with_tests 0%{?_with_tests:1}
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
-%global ini_name 40-%{pecl_name}.ini
-%endif
-
-Summary: Extension to work with the Memcached caching daemon
-Name: %{?scl_prefix}php-pecl-memcache
-Version: 3.0.9
-%if 0%{?gh_date:1}
-Release: 0.8.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%endif
-License: PHP
-Group: Development/Languages
-URL: http://pecl.php.net/package/%{pecl_name}
-
-%if 0%{?gh_date:1}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
-%else
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-%endif
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel
-BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: zlib-devel
-%if %{with_tests}
-BuildRequires: memcached
-%endif
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-Memcached is a caching daemon designed especially for
-dynamic web applications to decrease database load by
-storing objects in memory.
-
-This extension allows you to work with memcached through
-handy OO and procedural interfaces.
-
-Memcache can be used as a PHP session handler.
-
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
-
-%prep
-%setup -c -q
-%if 0%{?gh_date:1}
-mv %{gh_project}-%{gh_commit} NTS
-%{__php} -r '
- $pkg = simplexml_load_file("NTS/package.xml");
- $pkg->date = substr("%{gh_date}",0,4)."-".substr("%{gh_date}",4,2)."-".substr("%{gh_date}",6,2);
- $pkg->version->release = "%{version}dev";
- $pkg->stability->release = "devel";
- $pkg->asXML("package.xml");
-'
-%else
-mv %{pecl_name}-%{version} NTS
-%endif
-
-# Don't install/register tests
-sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- -i package.xml
-
-pushd NTS
-
-# Chech version as upstream often forget to update this
-dir=php$(%{__php} -r 'echo PHP_MAJOR_VERSION;')
-extver=$(sed -n '/#define PHP_MEMCACHE_VERSION/{s/.* "//;s/".*$//;p}' $dir/php_memcache.h)
-if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
- : Error: Upstream version is now ${extver}, expecting %{version}%{?gh_date:-dev}.
- : Update the pdover macro and rebuild.
- exit 1
-fi
-popd
-
-cat >%{ini_name} << 'EOF'
-; ----- Enable %{pecl_name} extension module
-extension=%{pecl_name}.so
-
-; ----- Options for the %{pecl_name} module
-; see http://www.php.net/manual/en/memcache.ini.php
-
-; Whether to transparently failover to other servers on errors
-;memcache.allow_failover=1
-; Data will be transferred in chunks of this size
-;memcache.chunk_size=32768
-; Autocompress large data
-;memcache.compress_threshold=20000
-; The default TCP port number to use when connecting to the memcached server
-;memcache.default_port=11211
-; Hash function {crc32, fnv}
-;memcache.hash_function=crc32
-; Hash strategy {standard, consistent}
-;memcache.hash_strategy=consistent
-; Defines how many servers to try when setting and getting data.
-;memcache.max_failover_attempts=20
-; The protocol {ascii, binary} : You need a memcached >= 1.3.0 to use the binary protocol
-; The binary protocol results in less traffic and is more efficient
-;memcache.protocol=ascii
-; Redundancy : When enabled the client sends requests to N servers in parallel
-;memcache.redundancy=1
-;memcache.session_redundancy=2
-; Lock Timeout
-;memcache.lock_timeout = 15
-
-; ----- Options to use the memcache session handler
-
-; RPM note : save_handler and save_path are defined
-; for mod_php, in /etc/httpd/conf.d/php.conf
-; for php-fpm, in /etc/php-fpm.d/*conf
-
-; Use memcache as a session handler
-;session.save_handler=memcache
-; Defines a comma separated of server urls to use for session storage
-;session.save_path="tcp://localhost:11211?persistent=1&weight=1&timeout=1&retry_interval=15"
-EOF
-
-%if %{with_zts}
-cp -r NTS ZTS
-%endif
-
-
-%build
-cd NTS
-%{_bindir}/phpize
-%configure --with-php-config=%{_bindir}/php-config
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-%configure --with-php-config=%{_bindir}/zts-php-config
-make %{?_smp_mflags}
-%endif
-
-%install
-rm -rf %{buildroot}
-
-make -C NTS install INSTALL_ROOT=%{buildroot}
-
-# Drop in the bit of configuration
-install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-# Install XML package description
-install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-# Documentation
-for i in $(grep '<file .* role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
-done
-
-
-%check
-: Minimal load test for NTS extension
-%{__php} --no-php-ini \
- --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- -m | grep %{pecl_name}
-
-%if %{with_zts}
-: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- -m | grep %{pecl_name}
-%endif
-
-%if %{with_tests}
-: Configuration for tests
-cd NTS
-sed -e "s:/var/run/memcached/memcached.sock:$PWD/memcached.sock:" \
- -i tests/connect.inc
-
-: Udp tests
-rm tests/0{36,38,39,55,57}.phpt
-
-: Launch the daemons
-memcached -p 11211 -U 11211 -d -P $PWD/memcached1.pid
-memcached -p 11212 -U 11212 -d -P $PWD/memcached2.pid
-memcached -s $PWD/memcached.sock -d -P $PWD/memcached3.pid
-
-: Upstream test suite for NTS extension
-ret=0
-TEST_PHP_EXECUTABLE=%{_bindir}/php \
-TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{_bindir}/php -n run-tests.php --show-diff || ret=1
-
-: Cleanup
-if [ -f memcached2.pid ]; then
- kill $(cat memcached?.pid)
-fi
-
-exit $ret
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
-%files
-%defattr(-, root, root, -)
-%{?_licensedir:%license NTS/LICENSE}
-%doc %{pecl_docdir}/%{pecl_name}
-%{pecl_xmldir}/%{name}.xml
-
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
-
-%changelog
-* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 3.0.9-0.8.20161124gitdf7735e
-- rebuild for PHP 7.2.0beta1 new API
-
-* Fri Dec 2 2016 Remi Collet <remi@fedoraproject.org> - 3.0.9-0.7.20161124gitdf7735e
-- refresh to more recent snapshot
-
-* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 3.0.9-0.6.20160311git4991c2f
-- rebuild with PHP 7.1.0 GA
-
-* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 3.0.9-0.5.20160311git4991c2f
-- rebuild for PHP 7.1 new API version
-
-* Sat Jun 11 2016 Remi Collet <rcollet@redhat.com> - 3.0.9-0.4.20160311git4991c2f
-- refresh
-
-* Sat Mar 5 2016 Remi Collet <rcollet@redhat.com> - 3.0.9-0.3.20151130gitfdbd46b
-- adapt for F24
-
-* Sun Jan 10 2016 Remi Collet <rcollet@redhat.com> - 3.0.9-0.2.20151130gitfdbd46b
-- set stability = devel in package.xml
-
-* Sun Jan 3 2016 Remi Collet <rcollet@redhat.com> - 3.0.9-0.1.20151130gitfdbd46b
-- git snapshopt for PHP 7
-- sources from https://github.com/websupport-sk/pecl-memcache (for PHP 7)
-- drop runtime dependency on pear, new scriptlets
-- don't install/register tests
-
-* Tue Feb 10 2015 Remi Collet <rcollet@redhat.com> - 3.0.8-7
-- fix gcc 5 FTBFS
-
-* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 3.0.8-5.1
-- Fedora 21 SCL mass rebuild
-
-* Mon Aug 25 2014 Remi Collet <rcollet@redhat.com> - 3.0.8-5
-- allow SCL build
-
-* Fri Apr 25 2014 Remi Collet <remi@fedoraproject.org> - 3.0.8-4
-- bump release (for EL-7)
-
-* Thu Apr 10 2014 Remi Collet <remi@fedoraproject.org> - 3.0.8-3
-- add numerical prefix to extension configuration file
-
-* Fri Mar 7 2014 Remi Collet <remi@fedoraproject.org> - 3.0.8-2
-- cleanups
-- install doc in pecl_docdir
-- install tests in pecl_testdir
-
-* Mon Apr 08 2013 Remi Collet <remi@fedoraproject.org> - 3.0.8-1
-- Update to 3.0.8
-
-* Sat Dec 29 2012 Remi Collet <remi@fedoraproject.org> - 3.0.7-5
-- add patch for https://bugs.php.net/59602
- segfault in getExtendedStats
-
-* Fri Nov 30 2012 Remi Collet <remi@fedoraproject.org> - 3.0.7-4.1
-- also provides php-memcache
-
-* Fri Oct 19 2012 Remi Collet <remi@fedoraproject.org> - 3.0.7-4
-- improve comment in configuration about session.
-
-* Mon Sep 24 2012 Remi Collet <remi@fedoraproject.org> - 3.0.7-3
-- switch back to previous patch (memleak better than segfault)
-
-* Sun Sep 23 2012 Remi Collet <remi@fedoraproject.org> - 3.0.7-2
-- use upstream patch instead of our (memleak)
-
-* Sun Sep 23 2012 Remi Collet <remi@fedoraproject.org> - 3.0.7-1
-- update to 3.0.7
-- drop patches merged upstream
-- cleanup spec
-
-* Sat Sep 8 2012 Remi Collet <remi@fedoraproject.org> - 3.0.6-5
-- add LICENSE
-- Obsoletes php53*, php54* on EL
-
-* Sat Jul 7 2012 Remi Collet <remi@fedoraproject.org> - 3.0.6-4
-- sync patch with rawhide
-
-* Thu Jul 5 2012 Joe Orton <jorton@redhat.com> - 3.0.6-4
-- fix php_stream_cast() usage
-- fix memory corruption after unserialization (Paul Clifford)
-- package license
-
-* Sun Nov 13 2011 Remi Collet <remi@fedoraproject.org> - 3.0.6-3
-- build against php 5.4
-- add patch for ZTS build, see https://bugs.php.net/60284
-
-* Mon Oct 03 2011 Remi Collet <Fedora@FamilleCollet.com> 3.0.6-2
-- clean spec for latest macros
-- build zts extension
-
-* Mon Apr 11 2011 Remi Collet <Fedora@FamilleCollet.com> 3.0.6-1
-- update to 3.0.6
-
-* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.5-3
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
-
-* Mon Dec 27 2010 Remi Collet <rpms@famillecollet.com> 3.0.5-3
-- relocate using phpname macro
-
-* Sat Oct 23 2010 Remi Collet <Fedora@FamilleCollet.com> 3.0.5-2
-- add filter_provides to avoid private-shared-object-provides memcache.so
-
-* Tue Oct 05 2010 Remi Collet <Fedora@FamilleCollet.com> 3.0.5-1
-- update to 3.0.5
-
-* Thu Sep 30 2010 Remi Collet <Fedora@FamilleCollet.com> 3.0.4-4
-- patch for bug #599305 (upstream #17566)
-- add minimal load test in %%check
-
-* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.4-3
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
-
-* Sun Jul 12 2009 Remi Collet <Fedora@FamilleCollet.com> 3.0.4-2
-- rebuild for new PHP 5.3.0 ABI (20090626)
-
-* Sat Feb 28 2009 Remi Collet <Fedora@FamilleCollet.com> 3.0.4-1
-- new version 3.0.4
-
-* Tue Jan 13 2009 Remi Collet <Fedora@FamilleCollet.com> 3.0.3-1
-- new version 3.0.3
-
-* Thu Sep 11 2008 Remi Collet <Fedora@FamilleCollet.com> 3.0.2-1
-- new version 3.0.2
-
-* Thu Sep 11 2008 Remi Collet <Fedora@FamilleCollet.com> 2.2.4-1
-- new version 2.2.4 (bug fixes)
-
-* Sat Feb 9 2008 Remi Collet <Fedora@FamilleCollet.com> 2.2.3-1
-- new version
-
-* Thu Jan 10 2008 Remi Collet <Fedora@FamilleCollet.com> 2.2.2-1
-- new version
-
-* Thu Nov 01 2007 Remi Collet <Fedora@FamilleCollet.com> 2.2.1-1
-- new version
-
-* Sat Sep 22 2007 Remi Collet <Fedora@FamilleCollet.com> 2.2.0-1
-- new version
-- add new INI directives (hash_strategy + hash_function) to config
-- add BR on php-devel >= 4.3.11
-
-* Mon Aug 20 2007 Remi Collet <Fedora@FamilleCollet.com> 2.1.2-1
-- initial RPM