summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore9
-rw-r--r--2_02.txt75
-rw-r--r--REFLECTION2
-rw-r--r--REFLECTION-PHP797
-rw-r--r--php-pecl-mailparse-php7.spec360
-rw-r--r--php-pecl-mailparse.spec88
6 files changed, 51 insertions, 580 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..6f69818
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/2_02.txt b/2_02.txt
deleted file mode 100644
index af5b01c..0000000
--- a/2_02.txt
+++ /dev/null
@@ -1,75 +0,0 @@
---------------------------------------------------------------------
- The PHP License, version 2.02
-Copyright (c) 1999 - 2002 The PHP Group. All rights reserved.
---------------------------------------------------------------------
-
-Redistribution and use in source and binary forms, with or without
-modification, is permitted provided that the following conditions
-are met:
-
- 1. Redistributions of source code must retain the above copyright
- notice, this list of conditions and the following disclaimer.
-
- 2. Redistributions in binary form must reproduce the above
- copyright notice, this list of conditions and the following
- disclaimer in the documentation and/or other materials provided
- with the distribution.
-
- 3. The name "PHP" must not be used to endorse or promote products
- derived from this software without prior permission from the
- PHP Group. This does not apply to add-on libraries or tools
- that work in conjunction with PHP. In such a case the PHP
- name may be used to indicate that the product supports PHP.
-
- 4. The PHP Group may publish revised and/or new versions of the
- license from time to time. Each version will be given a
- distinguishing version number.
- Once covered code has been published under a particular version
- of the license, you may always continue to use it under the
- terms of that version. You may also choose to use such covered
- code under the terms of any subsequent version of the license
- published by the PHP Group. No one other than the PHP Group has
- the right to modify the terms applicable to covered code created
- under this License.
-
- 5. Redistributions of any form whatsoever must retain the following
- acknowledgment:
- "This product includes PHP, freely available from
- http://www.php.net/".
-
- 6. The software incorporates the Zend Engine, a product of Zend
- Technologies, Ltd. ("Zend"). The Zend Engine is licensed to the
- PHP Association (pursuant to a grant from Zend that can be
- found at http://www.php.net/license/ZendGrant/) for
- distribution to you under this license agreement, only as a
- part of PHP. In the event that you separate the Zend Engine
- (or any portion thereof) from the rest of the software, or
- modify the Zend Engine, or any portion thereof, your use of the
- separated or modified Zend Engine software shall not be governed
- by this license, and instead shall be governed by the license
- set forth at http://www.zend.com/license/ZendLicense/.
-
-
-
-THIS SOFTWARE IS PROVIDED BY THE PHP DEVELOPMENT TEAM ``AS IS'' AND
-ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
-THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
-PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE PHP
-DEVELOPMENT TEAM OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
-INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
-STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
-ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
-OF THE POSSIBILITY OF SUCH DAMAGE.
-
---------------------------------------------------------------------
-
-This software consists of voluntary contributions made by many
-individuals on behalf of the PHP Group.
-
-The PHP Group can be contacted via Email at group@php.net.
-
-For more information on the PHP Group and the PHP project,
-please see <http://www.php.net>.
diff --git a/REFLECTION b/REFLECTION
index f9e50be..ba888d8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #104 mailparse version 2.1.6 ] {
+Extension [ <persistent> extension #104 mailparse version 3.0.2 ] {
- INI {
Entry [ mailparse.def_charset <ALL> ]
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
deleted file mode 100644
index ba888d8..0000000
--- a/REFLECTION-PHP7
+++ /dev/null
@@ -1,97 +0,0 @@
-Extension [ <persistent> extension #104 mailparse version 3.0.2 ] {
-
- - INI {
- Entry [ mailparse.def_charset <ALL> ]
- Current = 'us-ascii'
- }
- }
-
- - Constants [3] {
- Constant [ integer MAILPARSE_EXTRACT_OUTPUT ] { 0 }
- Constant [ integer MAILPARSE_EXTRACT_STREAM ] { 1 }
- Constant [ integer MAILPARSE_EXTRACT_RETURN ] { 2 }
- }
-
- - Functions {
- Function [ <internal:mailparse> function mailparse_msg_parse_file ] {
- }
- Function [ <internal:mailparse> function mailparse_msg_get_part ] {
- }
- Function [ <internal:mailparse> function mailparse_msg_get_structure ] {
- }
- Function [ <internal:mailparse> function mailparse_msg_get_part_data ] {
- }
- Function [ <internal:mailparse> function mailparse_msg_extract_part ] {
- }
- Function [ <internal:mailparse> function mailparse_msg_extract_part_file ] {
- }
- Function [ <internal:mailparse> function mailparse_msg_extract_whole_part_file ] {
- }
- Function [ <internal:mailparse> function mailparse_msg_create ] {
- }
- Function [ <internal:mailparse> function mailparse_msg_free ] {
- }
- Function [ <internal:mailparse> function mailparse_msg_parse ] {
- }
- Function [ <internal:mailparse> function mailparse_rfc822_parse_addresses ] {
- }
- Function [ <internal:mailparse> function mailparse_determine_best_xfer_encoding ] {
- }
- Function [ <internal:mailparse> function mailparse_stream_encode ] {
- }
- Function [ <internal:mailparse> function mailparse_uudecode_all ] {
- }
- Function [ <internal:mailparse> function mailparse_test ] {
- }
- }
-
- - Classes [1] {
- Class [ <internal:mailparse> class mimemessage ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [10] {
- Method [ <internal:mailparse, ctor> public method mimemessage ] {
- }
-
- Method [ <internal:mailparse> public method get_child ] {
- }
-
- Method [ <internal:mailparse> public method get_child_count ] {
- }
-
- Method [ <internal:mailparse> public method get_parent ] {
- }
-
- Method [ <internal:mailparse> public method extract_headers ] {
- }
-
- Method [ <internal:mailparse> public method extract_body ] {
- }
-
- Method [ <internal:mailparse> public method enum_uue ] {
- }
-
- Method [ <internal:mailparse> public method extract_uue ] {
- }
-
- Method [ <internal:mailparse> public method remove ] {
- }
-
- Method [ <internal:mailparse> public method add_child ] {
- }
- }
- }
- }
-}
-
diff --git a/php-pecl-mailparse-php7.spec b/php-pecl-mailparse-php7.spec
deleted file mode 100644
index 36ee385..0000000
--- a/php-pecl-mailparse-php7.spec
+++ /dev/null
@@ -1,360 +0,0 @@
-# remirepo spec file for php-pecl-mailparse
-# With SCL stuff, from Fedora:
-#
-# Fedora spec file for php-pecl-mailparse
-#
-# Copyright (c) 2008-2017 Remi Collet
-# Copyright (c) 2004-2007 Matthias Saou
-#
-# License: MIT
-# http://opensource.org/licenses/MIT
-#
-# Please, preserve the changelog entries
-#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-mailparse
-%endif
-
-%global pecl_name mailparse
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global ini_name 40-%{pecl_name}.ini
-
-Summary: PHP PECL package for parsing and working with email messages
-Name: %{?sub_prefix}php-pecl-mailparse
-Version: 3.0.2
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: PHP
-Group: Development/Languages
-URL: http://pecl.php.net/package/mailparse
-Source0: http://pecl.php.net/get/mailparse-%{version}.tgz
-
-BuildRequires: %{?scl_prefix}php-devel > 7
-BuildRequires: %{?scl_prefix}php-pear
-# mbstring need for tests
-BuildRequires: %{?scl_prefix}php-mbstring
-# Required by phpize
-BuildRequires: autoconf, automake, libtool
-
-Requires: %{?scl_prefix}php-mbstring%{?_isa}
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-Mailparse is an extension for parsing and working with email messages.
-It can deal with rfc822 and rfc2045 (MIME) compliant messages.
-
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
-
-%prep
-%setup -q -c
-
-mv %{pecl_name}-%{version} NTS
-
-# Don't install/register tests
-sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- -i package.xml
-
-cd NTS
-extver=$(sed -n '/#define PHP_MAILPARSE_VERSION/{s/.* "//;s/".*$//;p}' php_mailparse.h)
-if test "x${extver}" != "x%{version}"; then
- : Error: Upstream version is ${extver}, expecting %{version}.
- exit 1
-fi
-cd ..
-
-cat > %{ini_name} << 'EOF'
-; Enable mailparse extension module
-extension = mailparse.so
-
-; Set the default charset
-;mailparse.def_charset = us-ascii
-EOF
-
-%if %{with_zts}
-cp -pr NTS ZTS
-%endif
-
-
-%build
-cd NTS
-%{_bindir}/phpize
-%configure --with-php-config=%{_bindir}/php-config
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-%configure --with-php-config=%{_bindir}/zts-php-config
-make %{?_smp_mflags}
-%endif
-
-
-%install
-make -C NTS install INSTALL_ROOT=%{buildroot}
-# Drop in the bit of configuration
-install -Dpm 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
-# Drop in the bit of configuration
-install -Dpm 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-# Install XML package description
-install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-# Documentation
-for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
-done
-
-
-%check
-: Minimal load test for NTS extension
-%{__php} --no-php-ini \
- --define extension=mbstring.so \
- --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-: Upstream test suite for NTS extension
-cd NTS
-TEST_PHP_EXECUTABLE=%{__php} \
-NO_INTERACTION=1 \
-%{__php} run-tests.php \
- -n -q \
- -d extension=mbstring.so \
- -d extension=$PWD/modules/%{pecl_name}.so
-
-%if %{with_zts}
-: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=mbstring.so \
- --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-: Upstream test suite for ZTS extension
-cd ../ZTS
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-NO_INTERACTION=1 \
-php run-tests.php \
- -n -q \
- -d extension=mbstring.so \
- -d extension=$PWD/modules/%{pecl_name}.so
-%endif
-
-
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
-%files
-%{?_licensedir:%license NTS/LICENSE}
-%doc %{pecl_docdir}/%{pecl_name}
-%{pecl_xmldir}/%{name}.xml
-
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
-
-%changelog
-* Wed Dec 7 2016 Remi Collet <remi@fedoraproject.org> - 3.0.2-1
-- update to 3.0.2
-
-* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-4
-- rebuild with PHP 7.1.0 GA
-
-* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-3
-- rebuild for PHP 7.1 new API version
-
-* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-2
-- adapt for F24
-
-* Fri Jan 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-1
-- update to 3.0.1 (php 7, stable)
-
-* Sat Dec 26 2015 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
-- update to 3.0.0 for PHP 7
-
-* Tue Jun 23 2015 Remi Collet <rcollet@redhat.com> - 2.1.6-9
-- allow build against rh-php56 (as more-php56)
-- don't install/register tests
-- drop runtime dependency on pear, new scriptlets
-
-* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 2.1.6-8.1
-- Fedora 21 SCL mass rebuild
-
-* Mon Aug 25 2014 Remi Collet <rcollet@redhat.com> - 2.1.6-8
-- improve SCL build
-
-* Wed Apr 9 2014 Remi Collet <remi@fedoraproject.org> - 2.1.6-7
-- add numerical prefix to extension configuration file
-
-* Wed Mar 19 2014 Remi Collet <rcollet@redhat.com> - 2.1.6-6
-- allow SCL build
-
-* Sun Feb 2 2014 Remi Collet <remi@fedoraproject.org> - 2.1.6-5
-- cleanups
-- install documentation in pecl_docdir
-- install tests in pecl_testdir
-- add missing License file
-
-* Fri Nov 30 2012 Remi Collet <remi@fedoraproject.org> - 2.1.6-3.1
-- also provides php-mailparse
-
-* Sun Oct 21 2012 Remi Collet <remi@fedoraproject.org> - 2.1.6-3
-- rebuild
-
-* Sat Mar 10 2012 Remi Collet <remi@fedoraproject.org> - 2.1.6-2
-- rebuild for PHP 5.4
-
-* Sat Mar 10 2012 Remi Collet <remi@fedoraproject.org> - 2.1.6-1
-- update to 2.1.6
-- enable ZTS build
-
-* Thu Jan 19 2012 Remi Collet <remi@fedoraproject.org> - 2.1.5-6
-- rebuild against PHP 5.4, with patch
-- fix filters
-
-* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.5-5
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
-
-* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.5-4
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
-
-* Sat Oct 23 2010 Remi Collet <Fedora@FamilleCollet.com> 2.1.5-3
-- add filter_provides to avoid private-shared-object-provides mailparse.so
-- spec cleanup
-
-* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.5-2
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
-
-* Sun Jul 12 2009 Remi Collet <Fedora@FamilleCollet.com> 2.1.5-1
-- update to 2.1.5 (bugfix + php 5.3.0 compatibility)
-
-* Mon Apr 14 2008 Remi Collet <Fedora@FamilleCollet.com> 2.1.4-1
-- update to 2.1.4 (bugfix)
-- package2.xml is now provided
-
-* Sun Feb 24 2008 Remi Collet <Fedora@FamilleCollet.com> 2.1.3-1
-- update to 2.1.3
-- add post(un) scriplet
-- add check
-
-* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.1.1-9
-- Autorebuild for GCC 4.3
-
-* Wed Aug 22 2007 Matthias Saou <http://freshrpms.net/> 2.1.1-8
-- Rebuild for new BuildID feature.
-
-* Mon Aug 6 2007 Matthias Saou <http://freshrpms.net/> 2.1.1-7
-- Update License field.
-- Remove dist tag, since the package will seldom change.
-
-* Tue Jun 19 2007 Matthias Saou <http://freshrpms.net/> 2.1.1-6
-- Fix package requirements by adding build-time zend-abi version.
-- Clean up spec to conform to current PHP packaging rules.
-- No longer bundle part of mbstring (mbfl), at last! (makes spec F7+ specific)
-
-* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 2.1.1-5
-- FC6 rebuild.
-- Add php-api requirement and php-pecl(mailparse) provides.
-
-* Mon Mar 6 2006 Matthias Saou <http://freshrpms.net/> 2.1.1-4
-- Add missing php-mbstring requirement (#197410).
-
-* Mon Mar 6 2006 Matthias Saou <http://freshrpms.net/> 2.1.1-3
-- FC5 rebuild.
-
-* Thu Feb 9 2006 Matthias Saou <http://freshrpms.net/> 2.1.1-2
-- Rebuild for new gcc/glibc and FC5's PHP 5.1.
-
-* Wed Jul 20 2005 Matthias Saou <http://freshrpms.net/> 2.1.1-1
-- Update to 2.1.1.
-- Update mbfl tarball to 4.4.0 PHP sources.
-- Rename .ini file to "z-<name>" to have it load after mbstring.so.
-
-* Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
-- rebuilt
-
-* Wed Feb 16 2005 Matthias Saou <http://freshrpms.net/> 2.1-1
-- Update to 2.1.
-
-* Thu Jan 13 2005 Matthias Saou <http://freshrpms.net/> 2.0b-5
-- Bump release.
-
-* Tue Jul 27 2004 Matthias Saou <http://freshrpms.net/> 2.0b-4
-- Update included mbfl source to 4.3.8 as the current 4.3.4 doesn't work
- anymore.
-
-* Fri May 21 2004 Matthias Saou <http://freshrpms.net/> 2.0b-3
-- Rebuild for Fedora Core 2.
-- No need for a strict dependency on this package, it works fine with
- php 4.3.6 when compiled against 4.3.4.
-
-* Fri May 7 2004 Matthias Saou <http://freshrpms.net/> 2.0b-2
-- Added php.d entry to auto-load the module with recent php packages.
-- Added more macros to the spec file.
-
-* Mon Apr 26 2004 Matthias Saou <http://freshrpms.net/> 2.0b-1
-- Initial RPM release.
-- Included part of php-4.3.4's mbfl includes, ugly.
-
diff --git a/php-pecl-mailparse.spec b/php-pecl-mailparse.spec
index 09c6027..137f7eb 100644
--- a/php-pecl-mailparse.spec
+++ b/php-pecl-mailparse.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-mailparse
#
-# Copyright (c) 2008-2017 Remi Collet
+# Copyright (c) 2008-2018 Remi Collet
# Copyright (c) 2004-2007 Matthias Saou
#
# License: MIT
@@ -12,40 +12,23 @@
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-mailparse
%endif
-%endif
-
-%{?scl: %scl_package php-pecl-mailparse}
%global pecl_name mailparse
-%global with_zts 0%{?__ztsphp:1}
-%if "%{php_version}" < "5.6"
-# After mbstring
-%global ini_name z-%{pecl_name}.ini
-%else
-# After 20-mbstring
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%endif
Summary: PHP PECL package for parsing and working with email messages
Name: %{?sub_prefix}php-pecl-mailparse
-Version: 2.1.6
-Release: 10%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 3.0.2
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
-Group: Development/Languages
URL: http://pecl.php.net/package/mailparse
Source0: http://pecl.php.net/get/mailparse-%{version}.tgz
-# https://bugs.php.net/65861 - Please Provides LICENSE file
-# URL from mailparse.c header
-Source1: http://www.php.net/license/2_02.txt
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
# mbstring need for tests
BuildRequires: %{?scl_prefix}php-mbstring
@@ -57,12 +40,14 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
@@ -70,13 +55,15 @@ Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
Obsoletes: php54-pecl-%{pecl_name} <= %{version}
Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -100,10 +87,11 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version} NTS
# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
-cp %{SOURCE1} LICENSE
extver=$(sed -n '/#define PHP_MAILPARSE_VERSION/{s/.* "//;s/".*$//;p}' php_mailparse.h)
if test "x${extver}" != "x%{version}"; then
: Error: Upstream version is ${extver}, expecting %{version}.
@@ -119,8 +107,6 @@ extension = mailparse.so
;mailparse.def_charset = us-ascii
EOF
-chmod -x NTS/*.{php,c,h}
-
%if %{with_zts}
cp -pr NTS ZTS
%endif
@@ -141,7 +127,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
make -C NTS install INSTALL_ROOT=%{buildroot}
# Drop in the bit of configuration
install -Dpm 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -159,7 +144,6 @@ install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%{!?_licensedir:install -Dpm 644 NTS/LICENSE %{buildroot}%{pecl_docdir}/%{pecl_name}/LICENSE}
%check
@@ -173,7 +157,7 @@ done
cd NTS
TEST_PHP_EXECUTABLE=%{__php} \
NO_INTERACTION=1 \
-%{__php} -n run-tests.php \
+%{__php} run-tests.php \
-n -q \
-d extension=mbstring.so \
-d extension=$PWD/modules/%{pecl_name}.so
@@ -189,18 +173,14 @@ NO_INTERACTION=1 \
cd ../ZTS
TEST_PHP_EXECUTABLE=%{__ztsphp} \
NO_INTERACTION=1 \
-php -n run-tests.php \
+php run-tests.php \
-n -q \
-d extension=mbstring.so \
-d extension=$PWD/modules/%{pecl_name}.so
%endif
-%clean
-rm -rf %{buildroot}
-
-
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -221,7 +201,6 @@ fi
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -236,9 +215,24 @@ fi
%changelog
-* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 2.1.6-10
+* Wed Dec 7 2016 Remi Collet <remi@fedoraproject.org> - 3.0.2-1
+- update to 3.0.2
+
+* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-4
+- rebuild with PHP 7.1.0 GA
+
+* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-3
+- rebuild for PHP 7.1 new API version
+
+* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-2
- adapt for F24
+* Fri Jan 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-1
+- update to 3.0.1 (php 7, stable)
+
+* Sat Dec 26 2015 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
+- update to 3.0.0 for PHP 7
+
* Tue Jun 23 2015 Remi Collet <rcollet@redhat.com> - 2.1.6-9
- allow build against rh-php56 (as more-php56)
- don't install/register tests