summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-26 17:53:27 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-26 17:53:27 +0100
commitd999ccc5e4bbcf10dd001b02553b3bc90bf85ff3 (patch)
treef94f89518dbe42fa77c8ead1c68ba871ca91eef4
parent940ffda7375b90fd2146efffffaa0f2a654b2d57 (diff)
php-pecl-mailparse: 3.0.0 (php 7)
-rw-r--r--REFLECTION-PHP797
-rw-r--r--php-pecl-mailparse-php7.spec354
-rw-r--r--php-pecl-mailparse.spec2
3 files changed, 452 insertions, 1 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
new file mode 100644
index 0000000..7f203d7
--- /dev/null
+++ b/REFLECTION-PHP7
@@ -0,0 +1,97 @@
+Extension [ <persistent> extension #56 mailparse version 3.0.0 ] {
+
+ - INI {
+ Entry [ mailparse.def_charset <ALL> ]
+ Current = 'us-ascii'
+ }
+ }
+
+ - Constants [3] {
+ Constant [ integer MAILPARSE_EXTRACT_OUTPUT ] { 0 }
+ Constant [ integer MAILPARSE_EXTRACT_STREAM ] { 1 }
+ Constant [ integer MAILPARSE_EXTRACT_RETURN ] { 2 }
+ }
+
+ - Functions {
+ Function [ <internal:mailparse> function mailparse_msg_parse_file ] {
+ }
+ Function [ <internal:mailparse> function mailparse_msg_get_part ] {
+ }
+ Function [ <internal:mailparse> function mailparse_msg_get_structure ] {
+ }
+ Function [ <internal:mailparse> function mailparse_msg_get_part_data ] {
+ }
+ Function [ <internal:mailparse> function mailparse_msg_extract_part ] {
+ }
+ Function [ <internal:mailparse> function mailparse_msg_extract_part_file ] {
+ }
+ Function [ <internal:mailparse> function mailparse_msg_extract_whole_part_file ] {
+ }
+ Function [ <internal:mailparse> function mailparse_msg_create ] {
+ }
+ Function [ <internal:mailparse> function mailparse_msg_free ] {
+ }
+ Function [ <internal:mailparse> function mailparse_msg_parse ] {
+ }
+ Function [ <internal:mailparse> function mailparse_rfc822_parse_addresses ] {
+ }
+ Function [ <internal:mailparse> function mailparse_determine_best_xfer_encoding ] {
+ }
+ Function [ <internal:mailparse> function mailparse_stream_encode ] {
+ }
+ Function [ <internal:mailparse> function mailparse_uudecode_all ] {
+ }
+ Function [ <internal:mailparse> function mailparse_test ] {
+ }
+ }
+
+ - Classes [1] {
+ Class [ <internal:mailparse> class mimemessage ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [10] {
+ Method [ <internal:mailparse, ctor> public method mimemessage ] {
+ }
+
+ Method [ <internal:mailparse> public method get_child ] {
+ }
+
+ Method [ <internal:mailparse> public method get_child_count ] {
+ }
+
+ Method [ <internal:mailparse> public method get_parent ] {
+ }
+
+ Method [ <internal:mailparse> public method extract_headers ] {
+ }
+
+ Method [ <internal:mailparse> public method extract_body ] {
+ }
+
+ Method [ <internal:mailparse> public method enum_uue ] {
+ }
+
+ Method [ <internal:mailparse> public method extract_uue ] {
+ }
+
+ Method [ <internal:mailparse> public method remove ] {
+ }
+
+ Method [ <internal:mailparse> public method add_child ] {
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-mailparse-php7.spec b/php-pecl-mailparse-php7.spec
new file mode 100644
index 0000000..279461d
--- /dev/null
+++ b/php-pecl-mailparse-php7.spec
@@ -0,0 +1,354 @@
+# remirepo spec file for php-pecl-mailparse
+# With SCL stuff, from Fedora:
+#
+# Fedora spec file for php-pecl-mailparse
+#
+# Copyright (c) 2008-2015 Remi Collet
+# Copyright (c) 2004-2007 Matthias Saou
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%if "%{scl}" == "rh-php56"
+%global sub_prefix more-php56-
+%else
+%global sub_prefix %{scl_prefix}
+%endif
+%endif
+
+%{?scl: %scl_package php-pecl-mailparse}
+%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
+%{!?__pecl: %global __pecl %{_bindir}/pecl}
+%{!?__php: %global __php %{_bindir}/php}
+
+%global pecl_name mailparse
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+
+Summary: PHP PECL package for parsing and working with email messages
+Name: %{?sub_prefix}php-pecl-mailparse
+Version: 3.0.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: PHP
+Group: Development/Languages
+URL: http://pecl.php.net/package/mailparse
+Source0: http://pecl.php.net/get/mailparse-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-pear
+# mbstring need for tests
+BuildRequires: %{?scl_prefix}php-mbstring
+# Required by phpize
+BuildRequires: autoconf, automake, libtool
+
+Requires: %{?scl_prefix}php-mbstring%{?_isa}
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name}
+Obsoletes: php53u-pecl-%{pecl_name}
+Obsoletes: php54-pecl-%{pecl_name}
+Obsoletes: php54w-pecl-%{pecl_name}
+Obsoletes: php55u-pecl-%{pecl_name}
+Obsoletes: php55w-pecl-%{pecl_name}
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name}
+Obsoletes: php56w-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name}
+Obsoletes: php70w-pecl-%{pecl_name}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+Mailparse is an extension for parsing and working with email messages.
+It can deal with rfc822 and rfc2045 (MIME) compliant messages.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+
+mv %{pecl_name}-%{version} NTS
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' -i package.xml
+
+cd NTS
+extver=$(sed -n '/#define PHP_MAILPARSE_VERSION/{s/.* "//;s/".*$//;p}' php_mailparse.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+cat > %{ini_name} << 'EOF'
+; Enable mailparse extension module
+extension = mailparse.so
+
+; Set the default charset
+;mailparse.def_charset = us-ascii
+EOF
+
+chmod -x NTS/*.{php,c,h}
+
+%if %{with_zts}
+cp -pr NTS ZTS
+%endif
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+make -C NTS install INSTALL_ROOT=%{buildroot}
+# Drop in the bit of configuration
+install -Dpm 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+# Drop in the bit of configuration
+install -Dpm 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Install XML package description
+install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=mbstring.so \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for NTS extension
+cd NTS
+TEST_PHP_EXECUTABLE=%{__php} \
+NO_INTERACTION=1 \
+%{__php} run-tests.php \
+ -n -q \
+ -d extension=mbstring.so \
+ -d extension=$PWD/modules/%{pecl_name}.so
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=mbstring.so \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for ZTS extension
+cd ../ZTS
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+NO_INTERACTION=1 \
+php run-tests.php \
+ -n -q \
+ -d extension=mbstring.so \
+ -d extension=$PWD/modules/%{pecl_name}.so
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%{?_licensedir:%license NTS/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Sat Dec 26 2015 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
+- update to 3.0.0 for PHP 7
+
+* Tue Jun 23 2015 Remi Collet <rcollet@redhat.com> - 2.1.6-9
+- allow build against rh-php56 (as more-php56)
+- don't install/register tests
+- drop runtime dependency on pear, new scriptlets
+
+* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 2.1.6-8.1
+- Fedora 21 SCL mass rebuild
+
+* Mon Aug 25 2014 Remi Collet <rcollet@redhat.com> - 2.1.6-8
+- improve SCL build
+
+* Wed Apr 9 2014 Remi Collet <remi@fedoraproject.org> - 2.1.6-7
+- add numerical prefix to extension configuration file
+
+* Wed Mar 19 2014 Remi Collet <rcollet@redhat.com> - 2.1.6-6
+- allow SCL build
+
+* Sun Feb 2 2014 Remi Collet <remi@fedoraproject.org> - 2.1.6-5
+- cleanups
+- install documentation in pecl_docdir
+- install tests in pecl_testdir
+- add missing License file
+
+* Fri Nov 30 2012 Remi Collet <remi@fedoraproject.org> - 2.1.6-3.1
+- also provides php-mailparse
+
+* Sun Oct 21 2012 Remi Collet <remi@fedoraproject.org> - 2.1.6-3
+- rebuild
+
+* Sat Mar 10 2012 Remi Collet <remi@fedoraproject.org> - 2.1.6-2
+- rebuild for PHP 5.4
+
+* Sat Mar 10 2012 Remi Collet <remi@fedoraproject.org> - 2.1.6-1
+- update to 2.1.6
+- enable ZTS build
+
+* Thu Jan 19 2012 Remi Collet <remi@fedoraproject.org> - 2.1.5-6
+- rebuild against PHP 5.4, with patch
+- fix filters
+
+* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.5-5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.5-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Sat Oct 23 2010 Remi Collet <Fedora@FamilleCollet.com> 2.1.5-3
+- add filter_provides to avoid private-shared-object-provides mailparse.so
+- spec cleanup
+
+* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.5-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Sun Jul 12 2009 Remi Collet <Fedora@FamilleCollet.com> 2.1.5-1
+- update to 2.1.5 (bugfix + php 5.3.0 compatibility)
+
+* Mon Apr 14 2008 Remi Collet <Fedora@FamilleCollet.com> 2.1.4-1
+- update to 2.1.4 (bugfix)
+- package2.xml is now provided
+
+* Sun Feb 24 2008 Remi Collet <Fedora@FamilleCollet.com> 2.1.3-1
+- update to 2.1.3
+- add post(un) scriplet
+- add check
+
+* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.1.1-9
+- Autorebuild for GCC 4.3
+
+* Wed Aug 22 2007 Matthias Saou <http://freshrpms.net/> 2.1.1-8
+- Rebuild for new BuildID feature.
+
+* Mon Aug 6 2007 Matthias Saou <http://freshrpms.net/> 2.1.1-7
+- Update License field.
+- Remove dist tag, since the package will seldom change.
+
+* Tue Jun 19 2007 Matthias Saou <http://freshrpms.net/> 2.1.1-6
+- Fix package requirements by adding build-time zend-abi version.
+- Clean up spec to conform to current PHP packaging rules.
+- No longer bundle part of mbstring (mbfl), at last! (makes spec F7+ specific)
+
+* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 2.1.1-5
+- FC6 rebuild.
+- Add php-api requirement and php-pecl(mailparse) provides.
+
+* Mon Mar 6 2006 Matthias Saou <http://freshrpms.net/> 2.1.1-4
+- Add missing php-mbstring requirement (#197410).
+
+* Mon Mar 6 2006 Matthias Saou <http://freshrpms.net/> 2.1.1-3
+- FC5 rebuild.
+
+* Thu Feb 9 2006 Matthias Saou <http://freshrpms.net/> 2.1.1-2
+- Rebuild for new gcc/glibc and FC5's PHP 5.1.
+
+* Wed Jul 20 2005 Matthias Saou <http://freshrpms.net/> 2.1.1-1
+- Update to 2.1.1.
+- Update mbfl tarball to 4.4.0 PHP sources.
+- Rename .ini file to "z-<name>" to have it load after mbstring.so.
+
+* Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
+- rebuilt
+
+* Wed Feb 16 2005 Matthias Saou <http://freshrpms.net/> 2.1-1
+- Update to 2.1.
+
+* Thu Jan 13 2005 Matthias Saou <http://freshrpms.net/> 2.0b-5
+- Bump release.
+
+* Tue Jul 27 2004 Matthias Saou <http://freshrpms.net/> 2.0b-4
+- Update included mbfl source to 4.3.8 as the current 4.3.4 doesn't work
+ anymore.
+
+* Fri May 21 2004 Matthias Saou <http://freshrpms.net/> 2.0b-3
+- Rebuild for Fedora Core 2.
+- No need for a strict dependency on this package, it works fine with
+ php 4.3.6 when compiled against 4.3.4.
+
+* Fri May 7 2004 Matthias Saou <http://freshrpms.net/> 2.0b-2
+- Added php.d entry to auto-load the module with recent php packages.
+- Added more macros to the spec file.
+
+* Mon Apr 26 2004 Matthias Saou <http://freshrpms.net/> 2.0b-1
+- Initial RPM release.
+- Included part of php-4.3.4's mbfl includes, ugly.
+
diff --git a/php-pecl-mailparse.spec b/php-pecl-mailparse.spec
index fefaea7..5098947 100644
--- a/php-pecl-mailparse.spec
+++ b/php-pecl-mailparse.spec
@@ -92,7 +92,7 @@ Obsoletes: php56w-pecl-%{pecl_name}
Mailparse is an extension for parsing and working with email messages.
It can deal with rfc822 and rfc2045 (MIME) compliant messages.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep