summaryrefslogtreecommitdiffstats
path: root/php-pecl-luasandbox.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-luasandbox.spec')
-rw-r--r--php-pecl-luasandbox.spec47
1 files changed, 19 insertions, 28 deletions
diff --git a/php-pecl-luasandbox.spec b/php-pecl-luasandbox.spec
index 6705923..4473855 100644
--- a/php-pecl-luasandbox.spec
+++ b/php-pecl-luasandbox.spec
@@ -1,22 +1,22 @@
# remirepo spec file for php-pecl-luasandbox
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-luasandbox
%else
%global _root_libdir %{_libdir}
%endif
+%bcond_without tests
+
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global proj_name LuaSandbox
%global pecl_name luasandbox
-%global with_tests 0%{!?_without_tests:1}
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
%else
@@ -24,8 +24,8 @@
%endif
Summary: Lua interpreter with limits and safe environment
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 4.0.2
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 4.1.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{proj_name}
@@ -50,23 +50,6 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{proj_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{proj_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
%description
@@ -88,6 +71,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+sed -e '/LUASANDBOX_VERSION/s/4.0.2/%{version}/' -i luasandbox_version.h
+
: Sanity check, really often broken
extver=$(sed -n '/#define LUASANDBOX_VERSION /{s/.* "//;s/".*$//;p}' luasandbox_version.h)
if test "x${extver}" != "x%{version}"; then
@@ -161,12 +146,12 @@ cd NTS
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep -i %{pecl_name}
+%if %{with tests}
: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{_bindir}/php \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/php -n run-tests.php --show-diff
+%{_bindir}/php -n run-tests.php -q -P --show-diff
+%endif
%if %{with_zts}
cd ../ZTS
@@ -176,11 +161,11 @@ cd ../ZTS
--modules | grep -i %{pecl_name}
: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
+%if %{with tests}
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q -P --show-diff
+%endif
%endif
@@ -219,6 +204,12 @@ fi
%changelog
+* Fri Sep 23 2022 Remi Collet <remi@remirepo.net> - 4.1.0-1
+- update to 4.1.0
+
+* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 4.0.2-2
+- add upstream patch for 8.2
+
* Wed May 19 2021 Remi Collet <remi@remirepo.net> - 4.0.2-1
- update to 4.0.2 (no change)