summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-12 06:17:28 +0200
committerRemi Collet <remi@remirepo.net>2017-07-12 06:17:28 +0200
commit1804a3eaf551d65a57919cb0e71f09386f3d3855 (patch)
tree2f95c7ba7a42dfeceda313e2ba4a122702d1ee2b
parent9a1f8f27af84596591180d3004ea88c24c3d666c (diff)
cleanup
-rw-r--r--REFLECTION-PHP7188
-rw-r--r--php-pecl-lua-php7.spec268
2 files changed, 0 insertions, 456 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
deleted file mode 100644
index b77ab2b..0000000
--- a/REFLECTION-PHP7
+++ /dev/null
@@ -1,188 +0,0 @@
-Extension [ <persistent> extension #102 lua version 2.0.3 ] {
-
- - Constants [8] {
- Constant [ integer LUA_OK ] { 0 }
- Constant [ integer LUA_YIELD ] { 1 }
- Constant [ integer LUA_ERRRUN ] { 2 }
- Constant [ integer LUA_ERRSYNTAX ] { 3 }
- Constant [ integer LUA_ERRMEM ] { 4 }
- Constant [ integer LUA_ERRGCMM ] { 5 }
- Constant [ integer LUA_ERRERR ] { 6 }
- Constant [ integer LUA_ERRFILE ] { 7 }
- }
-
- - Classes [3] {
- Class [ <internal:lua> final class Lua ] {
-
- - Constants [1] {
- Constant [ string LUA_VERSION ] { Lua 5.3.3 }
- }
-
- - Static properties [1] {
- Property [ private static $_callbacks ]
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [8] {
- Method [ <internal:lua, ctor> public method __construct ] {
- }
-
- Method [ <internal:lua> public method eval ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $statements ]
- }
- }
-
- Method [ <internal:lua> public method include ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $file ]
- }
- }
-
- Method [ <internal:lua> public method call ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $method ]
- Parameter #1 [ <required> $args ]
- }
- }
-
- Method [ <internal:lua> public method assign ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> $value ]
- }
- }
-
- Method [ <internal:lua> public method getVersion ] {
- }
-
- Method [ <internal:lua> public method registerCallback ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> $function ]
- }
- }
-
- Method [ <internal:lua> public method __call ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $method ]
- Parameter #1 [ <required> $args ]
- }
- }
- }
- }
-
- Class [ <internal:lua> final class LuaClosure ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [2] {
- Property [ <default> private $_closure ]
- Property [ <default> private $_lua_object ]
- }
-
- - Methods [5] {
- Method [ <internal:lua, ctor> private method __construct ] {
- }
-
- Method [ <internal:lua, dtor> public method __destruct ] {
- }
-
- Method [ <internal:lua> private method __clone ] {
- }
-
- Method [ <internal:lua> public method invoke ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $arg ]
- Parameter #1 [ <optional> $... ]
- }
- }
-
- Method [ <internal:lua> public method __invoke ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $arg ]
- Parameter #1 [ <optional> $... ]
- }
- }
- }
- }
-
- Class [ <internal:lua> class LuaException extends Exception implements Throwable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- }
-
- - Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
- }
- }
-
- Method [ <internal:Core, inherits Exception> public method __wakeup ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
- }
- }
- }
- }
-}
-
diff --git a/php-pecl-lua-php7.spec b/php-pecl-lua-php7.spec
deleted file mode 100644
index e37c29a..0000000
--- a/php-pecl-lua-php7.spec
+++ /dev/null
@@ -1,268 +0,0 @@
-# spec file for php-pecl-lua
-#
-# Copyright (c) 2013-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-lua
-%else
-%global _root_prefix %{_prefix}
-%endif
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global pecl_name lua
-%global ini_name 40-%{pecl_name}.ini
-
-Summary: Embedded lua interpreter
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.0.3
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: PHP
-Group: Development/Languages
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-
-BuildRequires: lua-devel
-BuildRequires: %{?scl_prefix}php-devel > 7
-BuildRequires: %{?scl_prefix}php-pear
-# For tests
-BuildRequires: %{?scl_prefix}php-json
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name}
-Obsoletes: php53u-pecl-%{pecl_name}
-Obsoletes: php54-pecl-%{pecl_name}
-Obsoletes: php54w-pecl-%{pecl_name}
-Obsoletes: php55u-pecl-%{pecl_name}
-Obsoletes: php55w-pecl-%{pecl_name}
-Obsoletes: php56u-pecl-%{pecl_name}
-Obsoletes: php56w-pecl-%{pecl_name}
-Obsoletes: php70u-pecl-%{pecl_name}
-Obsoletes: php70w-pecl-%{pecl_name}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name}
-Obsoletes: php71w-pecl-%{pecl_name}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-Lua is a powerful, fast, light-weight, embeddable scripting language.
-
-This extension embeds the lua interpreter and offers an OO-API to lua
-variables and functions.
-
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
-
-%prep
-%setup -q -c
-
-# Don't install/register tests
-sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- -i package.xml
-
-mv %{pecl_name}-%{version} NTS
-
-cd NTS
-
-# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_LUA_VERSION/{s/.* "//;s/".*$//;p}' php_lua.h)
-if test "x${extver}" != "x%{version}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}.
- exit 1
-fi
-cd ..
-
-%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
-%endif
-
-# Create configuration file
-cat > %{ini_name} << 'EOF'
-; Enable %{pecl_name} extension module
-extension=%{pecl_name}.so
-EOF
-
-
-%build
-%{?dtsenable}
-
-cd NTS
-%{_bindir}/phpize
-%configure \
- --with-lua=%{_root_prefix} \
- --with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-%configure \
- --with-lua=%{_root_prefix} \
- --with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
-make %{?_smp_mflags}
-%endif
-
-
-%install
-%{?dtsenable}
-
-make -C NTS \
- install INSTALL_ROOT=%{buildroot}
-
-# install config file
-install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-# Install XML package description
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-%if %{with_zts}
-make -C ZTS \
- install INSTALL_ROOT=%{buildroot}
-
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-# Test & Documentation
-for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
-done
-for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
-done
-
-
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
-%check
-cd NTS
-# Minimal load test for NTS extension
-%{__php} --no-php-ini \
- --define extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-# Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension=json.so -d extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php
-
-%if %{with_zts}
-cd ../ZTS
-# Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-# Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=json.so -d extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php
-%endif
-
-
-%files
-%{?_licensedir:%license NTS/LICENSE}
-%doc %{pecl_docdir}/%{pecl_name}
-%{pecl_xmldir}/%{name}.xml
-
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
-
-%changelog
-* Fri Feb 10 2017 Remi Collet <remi@fedoraproject.org> - 2.0.3-1
-- update to 2.0.3 (php 7, stable)
-
-* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-3
-- rebuild with PHP 7.1.0 GA
-
-* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-2
-- rebuild for PHP 7.1 new API version
-
-* Thu May 26 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-1
-- update to 2.0.2 for PHP 7
-
-* Tue Apr 12 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
-- update to 2.0.1 for PHP 7
-
-* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 1.1.0-6
-- adapt for F24
-- drop runtime dependency on pear, new scriptlets
-- fix license management
-- don't install/register tests
-
-* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 1.1.0-5.1
-- Fedora 21 SCL mass rebuild
-
-* Tue Aug 26 2014 Remi Collet <rcollet@redhat.com> - 1.1.0-5
-- improve SCL build
-
-* Wed Apr 16 2014 Remi Collet <remi@fedoraproject.org> - 1.1.0-4
-- add numerical prefix to extension configuration file
-
-* Tue Mar 18 2014 Remi Collet <rcollet@redhat.com> - 1.1.0-3
-- adapt for SCL
-
-* Wed Nov 6 2013 Remi Collet <remi@fedoraproject.org> - 1.1.0-2
-- fix build against PHP 5.3.3 for Copr
-- open https://github.com/laruence/php-lua/pull/7
-
-* Wed Oct 23 2013 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
-- initial package, version 1.1.0 (beta)
-- open https://github.com/laruence/php-lua/pull/6
-