summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION59
-rw-r--r--php-pecl-jsonpath.spec5
3 files changed, 52 insertions, 14 deletions
diff --git a/PHPINFO b/PHPINFO
index 4406207..b708f9b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
jsonpath
jsonpath support => enabled
-jsonpath version => 0.9.5
+jsonpath version => 0.9.6
diff --git a/REFLECTION b/REFLECTION
index 00edf2d..8123941 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #121 jsonpath version 0.9.5 ] {
+Extension [ <persistent> extension #111 jsonpath version 0.9.6 ] {
- Classes [2] {
Class [ <internal:jsonpath> class JsonPath\JsonPath ] {
@@ -19,14 +19,15 @@ Extension [ <persistent> extension #121 jsonpath version 0.9.5 ] {
Method [ <internal:jsonpath> public method find ] {
- Parameters [2] {
- Parameter #0 [ <required> $data ]
- Parameter #1 [ <required> $expression ]
+ Parameter #0 [ <required> array $data ]
+ Parameter #1 [ <required> string $expression ]
}
+ - Return [ array|bool ]
}
}
}
- Class [ <internal:jsonpath> class JsonPath\JsonPathException extends RuntimeException implements Throwable ] {
+ Class [ <internal:jsonpath> class JsonPath\JsonPathException extends RuntimeException implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -38,47 +39,81 @@ Extension [ <persistent> extension #121 jsonpath version 0.9.5 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
diff --git a/php-pecl-jsonpath.spec b/php-pecl-jsonpath.spec
index ad14d53..6c00b8f 100644
--- a/php-pecl-jsonpath.spec
+++ b/php-pecl-jsonpath.spec
@@ -25,7 +25,7 @@
Summary: Extract data using JSONPath notation
Name: %{?sub_prefix}php-pecl-jsonpath
-Version: 0.9.5
+Version: 0.9.6
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
@@ -195,6 +195,9 @@ cd ../ZTS
%changelog
+* Thu Jan 13 2022 Remi Collet <remi@remirepo.net> - 0.9.6-1
+- update to 0.9.6
+
* Mon Nov 1 2021 Remi Collet <remi@remirepo.net> - 0.9.5-1
- update to 0.9.5