summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-ip2proxy.spec30
3 files changed, 17 insertions, 17 deletions
diff --git a/PHPINFO b/PHPINFO
index 10293ff..26ed163 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,4 +3,4 @@ ip2proxy
ip2proxy support => enabled
extension version => 3.0.1
-library version => 3.2.0
+library version => 4.0.1
diff --git a/REFLECTION b/REFLECTION
index 7035e00..927d06d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #79 ip2proxy version 3.0.1 ] {
+Extension [ <persistent> extension #117 ip2proxy version 3.0.1 ] {
- Constants [4] {
Constant [ int IP2PROXY_FILE_IO ] { 0 }
diff --git a/php-pecl-ip2proxy.spec b/php-pecl-ip2proxy.spec
index 07fa908..1d4a31d 100644
--- a/php-pecl-ip2proxy.spec
+++ b/php-pecl-ip2proxy.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-ip2proxy
#
-# Copyright (c) 2020 Remi Collet
+# Copyright (c) 2020-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -27,7 +27,8 @@
# see https://github.com/ip2location/ip2proxy-c/commits/master
%global gh_owner ip2location
%global gh_project ip2proxy-c
-%global gh_commit 436bd401f49a94cf706192ae5e62bc72cfef799c
+%global gh_commit 00154dc0b5d260d6c6ba86f9d997b9395c56fd22
+%global gh_version 4.0.1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
Summary: Get proxy information of an IP address
@@ -35,15 +36,16 @@ Name: %{?sub_prefix}php-pecl-%{pecl_name}
# library is MIT, extension is PHP
License: MIT and PHP
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
URL: https://pecl.php.net/package/igbinary
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-# library without release not API nor ABI management
-Source1: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{gh_short}.tar.gz
+# library with no API nor ABI management
+Source1: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{gh_version}-%{gh_short}.tar.gz
Patch0: %{pecl_name}-bundledlib.patch
-Provides: bundled(%{gh_project}) = 3.2.0
+Provides: bundled(%{gh_project}) = %{gh_version}
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-devel
@@ -72,12 +74,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
@@ -174,9 +173,8 @@ done
cd NTS
TEST_PHP_EXECUTABLE=%{_bindir}/php \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/php -n run-tests.php --show-diff
+%{_bindir}/php -n run-tests.php -q --show-diff
%endif
%if %{with_zts}
@@ -190,9 +188,8 @@ REPORT_EXIT_STATUS=1 \
cd ../ZTS
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q --show-diff
%endif
%endif
@@ -234,6 +231,9 @@ fi
%changelog
+* Tue Nov 23 2021 Remi Collet <remi@remirepo.net> - 3.0.1-2
+- update bundled libip2proxy to 4.0.1
+
* Fri Oct 23 2020 Remi Collet <remi@remirepo.net> - 3.0.1-1
- update to 3.0.1