summaryrefslogtreecommitdiffstats
path: root/php-pecl-ion.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-ion.spec')
-rw-r--r--php-pecl-ion.spec227
1 files changed, 227 insertions, 0 deletions
diff --git a/php-pecl-ion.spec b/php-pecl-ion.spec
new file mode 100644
index 0000000..53b45e4
--- /dev/null
+++ b/php-pecl-ion.spec
@@ -0,0 +1,227 @@
+# remirepo spec file for php-pecl-ion
+#
+# Copyright (c) 2022 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+# TODO use system ion-c (not yet available)
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
+%if 0%{?scl:1}
+%scl_package php-pecl-ion
+%else
+%global _root_bindir %{_bindir}
+%endif
+
+%bcond_without tests
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name ion
+%global ini_name 40-%{pecl_name}.ini
+
+%global upstream_version 0.1.0
+#global upstream_prever a1
+
+# Bundled library https://github.com/amzn/ion-c/releases
+# see https://github.com/awesomized/ext-ion for used commit reference
+%global gh_commit fcbfeaed29a39de03efdc3d2bc825a425312ecf7
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner amzn
+%global gh_project ion-c
+%global gh_version 1.4.0
+
+Summary: Amazon ION support
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+
+License: BSD
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Source1: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{gh_version}-%{gh_short}.tar.gz
+
+BuildRequires: make
+%if 0%{?rhel} == 7
+BuildRequires: cmake3 >= 3.6
+%else
+BuildRequires: cmake >= 3.6
+%endif
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel >= 8.1
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+# Bundled library
+Provides: bundled(ion-c) = %{gh_version}
+
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
+
+
+%description
+This PHP extension provides support for the Amazon ION serialization format.
+
+Documentation: https://awesomized.github.io/ext-ion/
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -qc -a1
+mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd NTS
+# use bundled library
+ln -s ../%{gh_project}-%{gh_commit} ion-c
+
+# don't build test and tools
+sed -e '/add_subdirectory(test)/d;/add_subdirectory(tools)/d' -i ion-c/CMakeLists.txt
+
+# use system build options
+sed -e 's/CFLAGS=.* //' -i Makefile.frag
+
+# Check version as upstream often forget to update this
+extver=$(sed -n '/define PHP_ION_VERSION/{s/.* "//;s/".*$//;p}' php_ion.h)
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:-dev}"; then
+ : Error: Upstream version is ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?gh_date:-dev}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+%if 0%{?rhel} == 7
+export CMAKE=%{_root_bindir}/cmake3
+%endif
+
+peclconf() {
+%configure \
+ --with-ion \
+ --with-php-config=$1
+}
+
+cd NTS
+%{_bindir}/phpize
+peclconf %{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+peclconf %{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# Install the ZTS stuff
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do [ -f NTS/$i ] && install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+: Minimal load test for NTS extension
+%{_bindir}/php --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%endif
+
+%if %{with tests}
+cd NTS
+: Run upstream test suite
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+%{__php} -n run-tests.php -q --show-diff %{?_smp_mflags}
+%endif
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%{php_ztsextdir}/%{pecl_name}.so
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%endif
+
+
+%changelog
+* Tue Feb 1 2022 Remi Collet <remi@remirepo.net> - 0.1.0-1
+- initial package