summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ion-php84.patch29
-rw-r--r--php-pecl-ion.spec7
2 files changed, 21 insertions, 15 deletions
diff --git a/ion-php84.patch b/ion-php84.patch
index fef1c36..a27bd66 100644
--- a/ion-php84.patch
+++ b/ion-php84.patch
@@ -1,4 +1,4 @@
-From fc5e95874bc8c56c398399b85f17663919c8e904 Mon Sep 17 00:00:00 2001
+From a943cb87d31bf6471b30211937e1606a9a335773 Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Tue, 1 Oct 2024 09:18:00 +0200
Subject: [PATCH] Relax test for 8.4 "refcount" vs "packed refcount"
@@ -9,7 +9,7 @@ Subject: [PATCH] Relax test for 8.4 "refcount" vs "packed refcount"
2 files changed, 10 insertions(+), 10 deletions(-)
diff --git a/tests/serialize/backref.phpt b/tests/serialize/backref.phpt
-index 4538ab5..44ce077 100644
+index 4538ab5..43fb1e2 100644
--- a/tests/serialize/backref.phpt
+++ b/tests/serialize/backref.phpt
@@ -30,16 +30,16 @@ array(1) {
@@ -17,10 +17,10 @@ index 4538ab5..44ce077 100644
}
[[R::r::1],["a",r::4,o::{},r::5,[1,2,3],r::6],r::3,r::4,r::5,r::6]
-array(6) refcount(2){
-+array(6) %srefcount(2){
++array(6) %sefcount(2){
[0]=>
- array(1) refcount(2){
-+ array(1) %srefcount(2){
++ array(1) %sefcount(2){
[0]=>
reference refcount(1) {
*RECURSION*
@@ -28,7 +28,7 @@ index 4538ab5..44ce077 100644
}
[1]=>
- array(6) refcount(2){
-+ array(6) %srefcount(2){
++ array(6) %sefcount(2){
[0]=>
string(1) "a" refcount(3)
[1]=>
@@ -37,7 +37,7 @@ index 4538ab5..44ce077 100644
}
[4]=>
- array(3) refcount(3){
-+ array(3) %srefcount(3){
++ array(3) %sefcount(3){
[0]=>
int(1)
[1]=>
@@ -46,7 +46,7 @@ index 4538ab5..44ce077 100644
}
[5]=>
- array(3) refcount(3){
-+ array(3) %srefcount(3){
++ array(3) %sefcount(3){
[0]=>
int(1)
[1]=>
@@ -55,7 +55,7 @@ index 4538ab5..44ce077 100644
}
[2]=>
- array(6) refcount(2){
-+ array(6) %srefcount(2){
++ array(6) %sefcount(2){
[0]=>
string(1) "a" refcount(3)
[1]=>
@@ -64,7 +64,7 @@ index 4538ab5..44ce077 100644
}
[4]=>
- array(3) refcount(3){
-+ array(3) %srefcount(3){
++ array(3) %sefcount(3){
[0]=>
int(1)
[1]=>
@@ -73,7 +73,7 @@ index 4538ab5..44ce077 100644
}
[5]=>
- array(3) refcount(3){
-+ array(3) %srefcount(3){
++ array(3) %sefcount(3){
[0]=>
int(1)
[1]=>
@@ -82,12 +82,12 @@ index 4538ab5..44ce077 100644
}
[5]=>
- array(3) refcount(3){
-+ array(3) %srefcount(3){
++ array(3) %sefcount(3){
[0]=>
int(1)
[1]=>
diff --git a/tests/serialize/serializable.phpt b/tests/serialize/serializable.phpt
-index 5f66227..aa93347 100644
+index 5f66227..6a26af0 100644
--- a/tests/serialize/serializable.phpt
+++ b/tests/serialize/serializable.phpt
@@ -85,7 +85,7 @@ Deprecated: recursive implements the Serializable interface, which is deprecated
@@ -95,7 +95,10 @@ index 5f66227..aa93347 100644
[S::test::{{"foobar"}},r::1]
-array(2) refcount(2){
-+array(2) %srefcount(2){
++array(2) %sefcount(2){
[0]=>
object(test)#%d (1) refcount(2){
["data":protected]=>
+--
+2.47.0
+
diff --git a/php-pecl-ion.spec b/php-pecl-ion.spec
index 1a469aa..5e0f051 100644
--- a/php-pecl-ion.spec
+++ b/php-pecl-ion.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-ion
#
-# Copyright (c) 2022-2023 Remi Collet
+# Copyright (c) 2022-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -37,7 +37,7 @@
Summary: Amazon ION support
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD-2-Clause
URL: https://pecl.php.net/package/%{pecl_name}
@@ -199,6 +199,9 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
%changelog
+* Wed Nov 20 2024 Remi Collet <remi@remirepo.net> - 0.2.1-6
+- fix previous patch to fix PHP < 8.4 builds
+
* Tue Oct 1 2024 Remi Collet <remi@remirepo.net> - 0.2.1-5
- fix test suite with 8.4 using patch from
https://github.com/awesomized/ext-ion/pull/10