summaryrefslogtreecommitdiffstats
path: root/php-pecl-imap.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-19 13:51:11 +0100
committerRemi Collet <remi@php.net>2023-12-19 13:51:11 +0100
commit88bd0cc578dc32d8c3880062a5bb9ddc270a144a (patch)
treea4f28346e9babdeb32e501158744d4d40e6ab49e /php-pecl-imap.spec
initial package for version 1.0.0 (PHP 8.4)
Diffstat (limited to 'php-pecl-imap.spec')
-rw-r--r--php-pecl-imap.spec194
1 files changed, 194 insertions, 0 deletions
diff --git a/php-pecl-imap.spec b/php-pecl-imap.spec
new file mode 100644
index 0000000..2cb8e52
--- /dev/null
+++ b/php-pecl-imap.spec
@@ -0,0 +1,194 @@
+# remirepo spec file for php-pecl-imap
+#
+# Copyright (c) 2023 Remi Collet
+# License: CC-BY-SA-4.0
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%{?scl:%scl_package php-pecl-imap}
+
+%bcond_without tests
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name imap
+%global ini_name 30-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
+
+Summary: Extension to operate with the IMAP protocol
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 1.0.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: PHP-3.01
+URL: https://pecl.php.net/package/%{pecl_name}
+
+Source0: https://pecl.php.net/get/%{sources}.tgz
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+# 8.3+ is supported by upstream but part of php-src until 8.4
+BuildRequires: %{?scl_prefix}php-devel >= 8.4
+BuildRequires: pkgconfig(krb5)
+BuildRequires: pkgconfig(krb5-gssapi)
+BuildRequires: openssl-devel >= 1.0.2
+BuildRequires: libc-client-devel
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+# Set epoch so provides is > 0:8.4
+Obsoletes: %{?scl_prefix}php-%{pecl_name} < 8.4
+Provides: %{?scl_prefix}php-%{pecl_name} = 1:%{version}-%{release}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = 1:%{version}-%{release}
+
+
+%description
+An extension to operate with the IMAP protocol, as well as the NNTP,
+POP3, and local mailbox access methods.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
+
+
+%prep
+%setup -c -q
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd %{sources}
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_IMAP_VERSION/{s/.* "//;s/".*$//;p}' php_imap.h)
+if test "x${extver}" != "x%{version}%{?prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
+ exit 1
+fi
+cd ..
+
+: Create the configuration file
+cat >%{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}
+EOF
+
+mkdir NTS
+%if %{with_zts}
+mkdir ZTS
+%endif
+
+
+%build
+%{?dtsenable}
+
+peclconf() {
+%configure \
+ --with-imap \
+ --with-kerberos \
+ --with-imap-ssl \
+ --with-libdir=%{_lib} \
+ --with-php-config=$1
+}
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
+peclconf %{__phpconfig}
+
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+peclconf %{__ztsphpconfig}
+
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+cd %{sources}
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+cd %{sources}
+: minimal load test of NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+OPT="%{?_smp_mflags} -q --show-diff"
+
+%if %{with tests}
+: upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+%{__php} -n run-tests.php $OPT
+%endif
+
+%if %{with_zts}
+: minimal load test of ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+%endif
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%files
+%{?_licensedir:%license %{sources}/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Tue Dec 19 2023 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package for version 1.0.0 (PHP 8.4)