summaryrefslogtreecommitdiffstats
path: root/php-pecl-imagick.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-imagick.spec')
-rw-r--r--php-pecl-imagick.spec16
1 files changed, 15 insertions, 1 deletions
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index 96cebdf..2399ecf 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -39,7 +39,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.9.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 17%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 18%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
License: PHP
@@ -51,6 +51,7 @@ Patch2: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull
Patch3: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull/348.patch
Patch4: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull/350.patch
Patch5: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull/375.patch
+Patch6: %{pecl_name}-php81.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -119,6 +120,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -172,6 +176,7 @@ cd NTS
%patch3 -p1 -b .pr348
%patch4 -p1 -b .pr350
%patch5 -p1 -b .pr375
+%patch6 -p1 -b .php81
extver=$(sed -n '/#define PHP_IMAGICK_VERSION/{s/.* "//;s/".*$//;p}' php_imagick.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -287,7 +292,11 @@ cd NTS
: upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+%if "%{php_version}" > "7.4"
+%{__php} -n run-tests.php -q --show-diff %{?_smp_mflags}
+%else
%{__php} -n run-tests.php -q --show-diff
+%endif
%if %{with_zts}
: simple module load test for ZTS extension
@@ -322,6 +331,11 @@ cd ../ZTS
%changelog
+* Wed Jun 9 2021 Remi Collet <remi@remirepo.net> - 3.4.4-18
+- add patches for PHP 8.1 from upstream and from
+ https://github.com/Imagick/imagick/pull/413
+- run tests in parallel (7.4+)
+
* Mon Feb 22 2021 Remi Collet <remi@remirepo.net> - 3.4.4-17
- build against ImageMagick6 and new soname