summaryrefslogtreecommitdiffstats
path: root/php-pecl-imagick.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-imagick.spec')
-rw-r--r--php-pecl-imagick.spec6
1 files changed, 6 insertions, 0 deletions
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index 372067d..7613313 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -34,6 +34,8 @@
%global gh_owner imagick
%global gh_project imagick
%global pecl_name imagick
+%global pie_vend imagick
+%global pie_proj imagick
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
%global upstream_version 3.8.0
@@ -80,6 +82,8 @@ Provides: %{?scl_prefix}php-pecl-imagick%{?_isa} = 1:%{version}-%{rel
%endif
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pie(%{pie_vend}/%{pie_proj}) = %{version}
+Provides: %{?scl_prefix}php-%{pie_vend}-%{pie_proj} = %{version}
Conflicts: %{?scl_prefix}php-pecl-gmagick
%if %{with im6}
@@ -266,8 +270,10 @@ export REPORT_EXIT_STATUS=1
rm tests/229_Tutorial_fxAnalyzeImage_case1.phpt
rm tests/244_Tutorial_psychedelicFontGif_basic.phpt
# very long, and erratic results, sometime segfault on shutdown (EL-7/8)
+# also see https://github.com/Imagick/imagick/issues/724
rm tests/073_Imagick_forwardFourierTransformImage_basic.phpt
rm tests/086_Imagick_forwardFourierTransformImage_basic.phpt
+rm tests/151_Imagick_subImageMatch_basic.phpt
: simple module load test for NTS extension
%{__php} --no-php-ini \