summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION152
-rw-r--r--php-pecl-imagick.spec18
2 files changed, 112 insertions, 58 deletions
diff --git a/REFLECTION b/REFLECTION
index c0ef2c0..9cf79c5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
+Extension [ <persistent> extension #97 imagick version 3.4.3RC2 ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -17,7 +17,7 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
}
- Classes [10] {
- Class [ <internal:imagick> class ImagickException extends Exception ] {
+ Class [ <internal:imagick> class ImagickException extends Exception implements Throwable ] {
- Constants [0] {
}
@@ -48,33 +48,33 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
- Class [ <internal:imagick> class ImagickDrawException extends Exception ] {
+ Class [ <internal:imagick> class ImagickDrawException extends Exception implements Throwable ] {
- Constants [0] {
}
@@ -105,33 +105,33 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
- Class [ <internal:imagick> class ImagickPixelIteratorException extends Exception ] {
+ Class [ <internal:imagick> class ImagickPixelIteratorException extends Exception implements Throwable ] {
- Constants [0] {
}
@@ -162,33 +162,33 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
- Class [ <internal:imagick> class ImagickPixelException extends Exception ] {
+ Class [ <internal:imagick> class ImagickPixelException extends Exception implements Throwable ] {
- Constants [0] {
}
@@ -219,33 +219,33 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
- Class [ <internal:imagick> class ImagickKernelException extends Exception ] {
+ Class [ <internal:imagick> class ImagickKernelException extends Exception implements Throwable ] {
- Constants [0] {
}
@@ -276,35 +276,35 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
Class [ <internal:imagick> <iterateable> class Imagick implements Iterator, Traversable, Countable ] {
- - Constants [569] {
+ - Constants [570] {
Constant [ integer COLOR_BLACK ] { 11 }
Constant [ integer COLOR_BLUE ] { 12 }
Constant [ integer COLOR_CYAN ] { 13 }
@@ -316,7 +316,7 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
Constant [ integer COLOR_ALPHA ] { 19 }
Constant [ integer COLOR_FUZZ ] { 20 }
Constant [ integer IMAGICK_EXTNUM ] { 30403 }
- Constant [ string IMAGICK_EXTVER ] { 3.4.3RC1 }
+ Constant [ string IMAGICK_EXTVER ] { 3.4.3RC2 }
Constant [ integer QUANTUM_RANGE ] { 65535 }
Constant [ integer USE_ZEND_MM ] { 0 }
Constant [ integer COMPOSITE_DEFAULT ] { 40 }
@@ -788,6 +788,7 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
Constant [ integer SPARSECOLORMETHOD_SPEPARDS ] { 16 }
Constant [ integer SPARSECOLORMETHOD_VORONOI ] { 18 }
Constant [ integer SPARSECOLORMETHOD_INVERSE ] { 19 }
+ Constant [ integer SPARSECOLORMETHOD_MANHATTAN ] { 20 }
Constant [ integer DITHERMETHOD_UNDEFINED ] { 0 }
Constant [ integer DITHERMETHOD_NO ] { 1 }
Constant [ integer DITHERMETHOD_RIEMERSMA ] { 2 }
@@ -1019,7 +1020,7 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
- Properties [0] {
}
- - Methods [350] {
+ - Methods [351] {
Method [ <internal:imagick> public method optimizeimagelayers ] {
- Parameters [0] {
@@ -3636,6 +3637,14 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
Parameter #2 [ <required> $GRAVITY ]
}
}
+
+ Method [ <internal:imagick> public method localcontrastimage ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $radius ]
+ Parameter #1 [ <required> $strength ]
+ }
+ }
}
}
@@ -3653,7 +3662,7 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
- Properties [0] {
}
- - Methods [130] {
+ - Methods [134] {
Method [ <internal:imagick> public method resetvectorgraphics ] {
- Parameters [0] {
@@ -4562,6 +4571,19 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
}
}
+ Method [ <internal:imagick> public method getopacity ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:imagick> public method setopacity ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $opacity ]
+ }
+ }
+
Method [ <internal:imagick> public method getfontresolution ] {
- Parameters [0] {
@@ -4589,6 +4611,19 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
}
}
+ Method [ <internal:imagick> public method setdensity ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $density ]
+ }
+ }
+
+ Method [ <internal:imagick> public method getdensity ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:imagick> public method gettextdirection ] {
- Parameters [0] {
@@ -4768,7 +4803,7 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
- Properties [0] {
}
- - Methods [21] {
+ - Methods [22] {
Method [ <internal:imagick> public method gethsl ] {
- Parameters [0] {
@@ -4913,6 +4948,13 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:imagick> public method setcolorfrompixel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ImagickPixel $srcPixel ]
+ }
+ }
}
}
@@ -4945,7 +4987,13 @@ Extension [ <persistent> extension #108 imagick version 3.4.3RC1 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [6] {
+ Method [ <internal:imagick, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:imagick> public method addkernel ] {
- Parameters [1] {
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index 1d59ea2..f4c9e9d 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -7,8 +7,8 @@
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-imagick
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-imagick
%endif
%global gh_commit 623a3ac0386c93d62c60cbfe610505f2e35780f3
@@ -17,12 +17,12 @@
%global gh_project imagick
#global gh_date 20151204
%global pecl_name imagick
-%global prever RC1
+%global prever RC2
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
+%global ini_name %{pecl_name}.ini
%else
-%global ini_name 40-%{pecl_name}.ini
+%global ini_name 40-%{pecl_name}.ini
%endif
# We don't really rely on upstream ABI
@@ -35,7 +35,7 @@ Version: 3.4.3
Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 0.4.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.5.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
%endif
License: PHP
@@ -178,6 +178,8 @@ cp -r NTS ZTS
%build
+%{?dtsenable}
+
: Standard NTS build
cd NTS
%{_bindir}/phpize
@@ -194,6 +196,7 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
rm -rf %{buildroot}
make install INSTALL_ROOT=%{buildroot} -C NTS
@@ -302,6 +305,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Jan 18 2017 Remi Collet <remi@fedoraproject.org> - 3.4.3-0.5.RC2
+- Update to 3.4.3RC2
+
* Sun Dec 11 2016 Remi Collet <remi@fedoraproject.org> - 3.4.3-0.4.RC1
- rebuild against ImageMagick6 (6.9.6-8)