summaryrefslogtreecommitdiffstats
path: root/php-pecl-imagick.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-15 09:20:41 +0200
committerRemi Collet <remi@remirepo.net>2021-06-15 09:20:41 +0200
commit562f84b239bcc69367b43c9ac9c1d7767bc92fa3 (patch)
tree8aaff96f28b9a6b97f3764cdb7585de9a0b07bb3 /php-pecl-imagick.spec
parent584b39db5c3d09d2dbb0b12b77a9314b4314f02b (diff)
update to 3.5.0RC1
drop all patches, all merged upstream add patch to fix some methods reflection from https://github.com/Imagick/imagick/pull/421
Diffstat (limited to 'php-pecl-imagick.spec')
-rw-r--r--php-pecl-imagick.spec32
1 files changed, 15 insertions, 17 deletions
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index 2399ecf..f4eed8a 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -29,8 +29,8 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 3.4.4
-#global upstream_prever RC2
+%global upstream_version 3.5.0
+%global upstream_prever RC1
Summary: Extension to create and modify images using ImageMagick
Name: %{?sub_prefix}php-pecl-imagick
@@ -39,19 +39,14 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.9.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 18%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
License: PHP
URL: https://pecl.php.net/package/imagick
-Patch0: %{pecl_name}-php8.patch
-Patch1: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull/346.patch
-Patch2: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull/347.patch
-Patch3: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull/348.patch
-Patch4: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull/350.patch
-Patch5: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull/375.patch
-Patch6: %{pecl_name}-php81.patch
+# From https://github.com/Imagick/imagick/pull/421
+Patch0: %{pecl_name}-arginfo.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -170,13 +165,7 @@ then : "Font files detected!"
fi
cd NTS
-%patch0 -p1 -b .up
-%patch1 -p1 -b .pr346
-%patch2 -p1 -b .pr347
-%patch3 -p1 -b .pr348
-%patch4 -p1 -b .pr350
-%patch5 -p1 -b .pr375
-%patch6 -p1 -b .php81
+%patch0 -p1 -b .pr421
extver=$(sed -n '/#define PHP_IMAGICK_VERSION/{s/.* "//;s/".*$//;p}' php_imagick.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -203,6 +192,9 @@ imagick.skip_version_check=1
; multi-thread management
;imagick.set_single_thread => 1 => 1
;imagick.shutdown_sleep_count => 10 => 10
+
+; to allow null images
+;imagick.allow_zero_dimension_images => 0 => 0
EOF
%if %{with_zts}
@@ -331,6 +323,12 @@ cd ../ZTS
%changelog
+* Tue Jun 15 2021 Remi Collet <remi@remirepo.net> - 3.5.0~RC1-1
+- update to 3.5.0RC1
+- drop all patches, all merged upstream
+- add patch to fix some methods reflection from
+ https://github.com/Imagick/imagick/pull/421
+
* Wed Jun 9 2021 Remi Collet <remi@remirepo.net> - 3.4.4-18
- add patches for PHP 8.1 from upstream and from
https://github.com/Imagick/imagick/pull/413