summaryrefslogtreecommitdiffstats
path: root/php-pecl-imagick.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-02-22 11:20:54 +0100
committerRemi Collet <remi@remirepo.net>2021-02-22 11:20:54 +0100
commit2ffb12fa2aa3209b78bfaf5b7c9c7854ec620656 (patch)
tree2c9dc678e04d532f157199be88cfed66c9c7332a /php-pecl-imagick.spec
parent20085ef9b7d532733489f9be43b2db4efd08f261 (diff)
build against ImageMagick6 and new soname
Diffstat (limited to 'php-pecl-imagick.spec')
-rw-r--r--php-pecl-imagick.spec26
1 files changed, 22 insertions, 4 deletions
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index 268876a..96cebdf 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -39,7 +39,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.9.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 15%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 17%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
License: PHP
@@ -50,16 +50,22 @@ Patch1: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull
Patch2: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull/347.patch
Patch3: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull/348.patch
Patch4: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull/350.patch
+Patch5: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull/375.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 5.4
+BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: pcre-devel
%if %{with im7}
BuildRequires: ImageMagick7-devel
%else
+# Ensure we use the more recent version from remi repo
+%if 0%{?fedora} >= 99 || 0%{?rhel} >= 99
BuildRequires: ImageMagick-devel
+%else
+BuildRequires: ImageMagick6-devel
+%endif
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -165,6 +171,7 @@ cd NTS
%patch2 -p1 -b .pr347
%patch3 -p1 -b .pr348
%patch4 -p1 -b .pr350
+%patch5 -p1 -b .pr375
extver=$(sed -n '/#define PHP_IMAGICK_VERSION/{s/.* "//;s/".*$//;p}' php_imagick.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -187,6 +194,10 @@ imagick.skip_version_check=1
; Used to enable the image progress monitor.
;imagick.progress_monitor=0
+
+; multi-thread management
+;imagick.set_single_thread => 1 => 1
+;imagick.shutdown_sleep_count => 10 => 10
EOF
%if %{with_zts}
@@ -271,7 +282,7 @@ cd NTS
%{__php} --no-php-ini \
--define extension_dir=%{buildroot}%{php_extdir} \
--define extension=%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
: upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
@@ -284,7 +295,7 @@ cd ../ZTS
%{__ztsphp} --no-php-ini \
--define extension_dir=%{buildroot}%{php_ztsextdir} \
--define extension=%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%endif
@@ -311,6 +322,13 @@ cd ../ZTS
%changelog
+* Mon Feb 22 2021 Remi Collet <remi@remirepo.net> - 3.4.4-17
+- build against ImageMagick6 and new soname
+
+* Mon Jan 25 2021 Remi Collet <remi@remirepo.net> - 3.4.4-16
+- add real fix for thread issue from
+ https://github.com/Imagick/imagick/pull/375
+
* Mon Jan 4 2021 Remi Collet <remi@remirepo.net> - 3.4.4-15
- allow to use ImageMagick7 using --with im7 build option