summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--7bed3124e797dcfcb9e2e6c2b30c3e289ac5eff4.patch41
-rw-r--r--php-pecl-igbinary.spec12
2 files changed, 51 insertions, 2 deletions
diff --git a/7bed3124e797dcfcb9e2e6c2b30c3e289ac5eff4.patch b/7bed3124e797dcfcb9e2e6c2b30c3e289ac5eff4.patch
new file mode 100644
index 0000000..7445fa5
--- /dev/null
+++ b/7bed3124e797dcfcb9e2e6c2b30c3e289ac5eff4.patch
@@ -0,0 +1,41 @@
+From 7bed3124e797dcfcb9e2e6c2b30c3e289ac5eff4 Mon Sep 17 00:00:00 2001
+From: Andy Postnikov <apostnikov@gmail.com>
+Date: Sat, 11 Jul 2020 22:51:04 +0300
+Subject: [PATCH] Replace usage call_user_function_ex() with
+ call_user_function()
+
+---
+ src/php7/igbinary.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/php7/igbinary.c b/src/php7/igbinary.c
+index c76b12a..775f585 100644
+--- a/src/php7/igbinary.c
++++ b/src/php7/igbinary.c
+@@ -542,7 +542,7 @@ static int igbinary_finish_deferred_calls(struct igbinary_unserialize_data *igsd
+ zval retval; /* return value of __wakeup */
+ zval rval;
+ ZVAL_OBJ(&rval, obj);
+- if (UNEXPECTED(call_user_function_ex(CG(function_table), &rval, &wakeup_name, &retval, 0, 0, 1, NULL) == FAILURE || Z_ISUNDEF(retval))) {
++ if (UNEXPECTED(call_user_function(CG(function_table), &rval, &wakeup_name, &retval, 0, 0) == FAILURE || Z_ISUNDEF(retval))) {
+ delayed_call_failed = 1;
+ GC_ADD_FLAGS(obj, IS_OBJ_DESTRUCTOR_CALLED);
+ }
+@@ -1727,7 +1727,7 @@ inline static int igbinary_serialize_object(struct igbinary_serialize_data *igsd
+
+ ZVAL_UNDEF(&h);
+ /* calling z->__sleep */
+- r = call_user_function_ex(CG(function_table), z, &f, &h, 0, 0, 1, NULL);
++ r = call_user_function(CG(function_table), z, &f, &h, 0, 0);
+
+ zval_dtor(&f);
+
+@@ -2693,7 +2693,7 @@ inline static int igbinary_unserialize_object(struct igbinary_unserialize_data *
+ /* FIXME: Release arg[0] */
+ /* FIXME: Release class_name */
+ ZVAL_STR_COPY(&args[0], class_name);
+- if (call_user_function_ex(CG(function_table), NULL, &user_func, &retval, 1, args, 0, NULL) != SUCCESS) {
++ if (call_user_function(CG(function_table), NULL, &user_func, &retval, 1, args) != SUCCESS) {
+ php_error_docref(NULL, E_WARNING, "defined (%s) but not found", ZSTR_VAL(class_name));
+ incomplete_class = 1;
+ ce = PHP_IC_ENTRY;
diff --git a/php-pecl-igbinary.spec b/php-pecl-igbinary.spec
index 3242af7..c2deaf5 100644
--- a/php-pecl-igbinary.spec
+++ b/php-pecl-igbinary.spec
@@ -35,7 +35,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.12.%{gh_date}.%{gh_short}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
License: BSD
@@ -43,6 +43,7 @@ URL: https://pecl.php.net/package/igbinary
Patch0: https://github.com/igbinary/igbinary/commit/e24aca97b8925ac9d21f718c0e38274bde949866.patch
Patch1: https://github.com/igbinary/igbinary/commit/07625b9a51a96d8402fd01b373edd58befa4e3fb.patch
+Patch2: https://github.com/igbinary/igbinary/commit/7bed3124e797dcfcb9e2e6c2b30c3e289ac5eff4.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-pear
@@ -64,7 +65,7 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{rel
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
@@ -88,6 +89,9 @@ Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -146,6 +150,7 @@ mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
cd NTS
%patch0 -p1
%patch1 -p1
+%patch2 -p1
# Check version
subdir="php$(%{__php} -r 'echo (PHP_MAJOR_VERSION < 7 ? 5 : 7);')"
@@ -311,6 +316,9 @@ fi
%changelog
+* Wed Jul 22 2020 Remi Collet <remi@remirepo.net> - 3.1.2-4
+- rebuild for PHP 8.0.0alpha3
+
* Thu May 7 2020 Remi Collet <remi@remirepo.net> - 3.1.2-3
- add upstream patch for test suite with PHP 7.4.6