summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION58
-rw-r--r--php-pecl-ice.spec13
3 files changed, 60 insertions, 15 deletions
diff --git a/PHPINFO b/PHPINFO
index 46aa3df..d27c78a 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,8 +5,8 @@ ice
Simple and fast PHP framework delivered as C-extension.<br>Copyright (c) 2014-2020 Ice Team.
ice => enabled
Author => Ice Team
-Version => 1.6.1
-Build Date => May 11 2020 00:00:00
+Version => 1.6.2
+Build Date => Sep 12 2020 00:00:00
Powered by Zephir => Version 0.12.18-$Id$
Website => http://www.iceframework.org
diff --git a/REFLECTION b/REFLECTION
index 18158fa..0e05be5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #76 ice version 1.6.1 ] {
+Extension [ <persistent> extension #76 ice version 1.6.2 ] {
- Dependencies {
}
@@ -986,7 +986,7 @@ Extension [ <persistent> extension #76 ice version 1.6.1 ] {
Property [ <default> protected $isLoaded ]
}
- - Methods [62] {
+ - Methods [63] {
Method [ <internal:ice> public method getDi ] {
}
@@ -1156,6 +1156,13 @@ Extension [ <persistent> extension #76 ice version 1.6.1 ] {
}
}
+ Method [ <internal:ice> public method loaded ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:ice> public method getError ] {
}
@@ -3423,7 +3430,7 @@ Extension [ <persistent> extension #76 ice version 1.6.1 ] {
Property [ <default> protected $userClass ]
}
- - Methods [63] {
+ - Methods [64] {
Method [ <internal:ice> public method initialize ] {
}
@@ -3596,6 +3603,13 @@ Extension [ <persistent> extension #76 ice version 1.6.1 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method loaded ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:ice, inherits Ice\Mvc\Model> public method getError ] {
}
@@ -3905,7 +3919,7 @@ Extension [ <persistent> extension #76 ice version 1.6.1 ] {
Property [ <default> protected $roleClass ]
}
- - Methods [63] {
+ - Methods [64] {
Method [ <internal:ice> public method initialize ] {
}
@@ -4078,6 +4092,13 @@ Extension [ <persistent> extension #76 ice version 1.6.1 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method loaded ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:ice, inherits Ice\Mvc\Model> public method getError ] {
}
@@ -4389,7 +4410,7 @@ Extension [ <persistent> extension #76 ice version 1.6.1 ] {
Property [ <default> protected $socialClass ]
}
- - Methods [65] {
+ - Methods [66] {
Method [ <internal:ice> public method initialize ] {
}
@@ -4572,6 +4593,13 @@ Extension [ <persistent> extension #76 ice version 1.6.1 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method loaded ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:ice, inherits Ice\Mvc\Model> public method getError ] {
}
@@ -4880,7 +4908,7 @@ Extension [ <persistent> extension #76 ice version 1.6.1 ] {
Property [ <default> protected $userClass ]
}
- - Methods [64] {
+ - Methods [65] {
Method [ <internal:ice> public method initialize ] {
}
@@ -5056,6 +5084,13 @@ Extension [ <persistent> extension #76 ice version 1.6.1 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method loaded ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:ice, inherits Ice\Mvc\Model> public method getError ] {
}
@@ -5364,7 +5399,7 @@ Extension [ <persistent> extension #76 ice version 1.6.1 ] {
Property [ <default> protected $userClass ]
}
- - Methods [65] {
+ - Methods [66] {
Method [ <internal:ice> public method initialize ] {
}
@@ -5547,6 +5582,13 @@ Extension [ <persistent> extension #76 ice version 1.6.1 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method loaded ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:ice, inherits Ice\Mvc\Model> public method getError ] {
}
@@ -14649,7 +14691,7 @@ Extension [ <persistent> extension #76 ice version 1.6.1 ] {
Constant [ public int STABLE ] { 4 }
Constant [ public int MAJOR ] { 1 }
Constant [ public int MINOR ] { 6 }
- Constant [ public int PATCH ] { 1 }
+ Constant [ public int PATCH ] { 2 }
Constant [ public int STAGE ] { 4 }
Constant [ public int BUILD ] { 0 }
}
diff --git a/php-pecl-ice.spec b/php-pecl-ice.spec
index 7aab123..79b7322 100644
--- a/php-pecl-ice.spec
+++ b/php-pecl-ice.spec
@@ -18,7 +18,7 @@
Summary: Simple and fast PHP framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.6.1
+Version: 1.6.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
@@ -43,19 +43,16 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -116,6 +113,7 @@ cd NTS
--with-libdir=%{_lib} \
--with-php-config=%{_bindir}/php-config
+make clean
make %{?_smp_mflags}
%if %{with_zts}
@@ -126,6 +124,7 @@ cd ../ZTS
--with-libdir=%{_lib} \
--with-php-config=%{_bindir}/zts-php-config
+make clean
make %{?_smp_mflags}
%endif
@@ -208,6 +207,10 @@ cd ../ZTS
%changelog
+* Sat Sep 12 2020 Remi Collet <remi@remirepo.net> - 1.6.2-1
+- update to 1.6.2
+- open https://github.com/ice/framework/issues/280 broken archive
+
* Mon May 11 2020 Remi Collet <remi@remirepo.net> - 1.6.1-1
- update to 1.6.1
- drop patch merged upstream in zephir