summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-http1.spec2
1 files changed, 2 insertions, 0 deletions
diff --git a/php-pecl-http1.spec b/php-pecl-http1.spec
index 81ea717..8385be4 100644
--- a/php-pecl-http1.spec
+++ b/php-pecl-http1.spec
@@ -99,7 +99,9 @@ These are the files needed to compile programs using HTTP extension.
cd %{proj_name}-%{version}
%patch0 -p1 -b .rpmconf
+%if "%{php_version}" > "5.5"
%patch1 -p3 -b .php55
+%endif
extver=$(sed -n '/#define PHP_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{version}"; then