summaryrefslogtreecommitdiffstats
path: root/php-pecl-http.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-http.spec')
-rw-r--r--php-pecl-http.spec33
1 files changed, 10 insertions, 23 deletions
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 7535e60..5030a27 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -41,7 +41,7 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-%global upstream_version 3.2.0
+%global upstream_version 3.2.1
#global upstream_prever RC1
Name: %{?sub_prefix}php-pecl-http
@@ -50,7 +50,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.5.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
Summary: Extended HTTP support
@@ -61,9 +61,6 @@ URL: http://pecl.php.net/package/pecl_http
# From http://www.php.net/manual/en/http.configuration.php
Source1: %{proj_name}.ini
-Patch0: https://patch-diff.githubusercontent.com/raw/m6w6/ext-http/pull/85.patch
-Patch1: %{proj_name}-upstream.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-hash
@@ -173,14 +170,6 @@ mv %{proj_name}-%{upstream_version}%{?upstream_prever} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%if "%{php_version}" > "7.4"
-%patch1 -p1 -b .up
-rm tests/etag001.phpt
-rm tests/message015.phpt
-%else
-%patch0 -p1 -b .pr85
-%endif
-
extver=$(sed -n '/#define PHP_PECL_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:dev}"; then
: Error: Upstream HTTP version is now ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?gh_date:dev}.
@@ -268,7 +257,8 @@ export REPORT_EXIT_STATUS=1
user=$(id -un)
: all tests when rpmbuild is used
if [ "$user" = "remi" ]; then
-export SKIP_ONLINE_TESTS=1
+rm ?TS/tests/gh-issue50.phpt
+export SKIP_ONLINE_TESTS=0
else
: only local tests when mock is used
export SKIP_ONLINE_TESTS=1
@@ -290,15 +280,8 @@ done
%if %{with_tests}
: ignore tests with erratic results
-rm ?TS/tests/client022.phpt
-rm ?TS/tests/client027.phpt
-%if 0%{?fedora} >= 30
-: https://github.com/m6w6/ext-http/issues/84
-rm ?TS/tests/client002.phpt
-rm ?TS/tests/client008.phpt
-rm ?TS/tests/client018.phpt
-rm ?TS/tests/client021.phpt
-%endif
+#rm ?TS/tests/client022.phpt
+#rm ?TS/tests/client027.phpt
: Upstream test suite NTS extension
cd NTS
@@ -369,6 +352,10 @@ fi
%changelog
+* Fri Jun 7 2019 Remi Collet <remi@remirepo.net> - 3.2.1-1
+- update to 3.2.1
+- drop patch merged upstream
+
* Thu Jun 6 2019 Remi Collet <remi@remirepo.net> - 3.2.0-5
- add upstream patch for 7.4