summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-08-04 14:11:23 +0200
committerRemi Collet <fedora@famillecollet.com>2014-08-04 14:11:23 +0200
commitb4223292032e5c77930d8c565f0b42492508be67 (patch)
tree442e2dd27dac5b2d6c45126a23de0c4869bccc92
parenta0220e8b353fada21ac44fbcc9270c8e8419b4d8 (diff)
php-pecl-http: wip
-rw-r--r--pecl_http-git.patch43
-rw-r--r--php-pecl-http.spec2
2 files changed, 44 insertions, 1 deletions
diff --git a/pecl_http-git.patch b/pecl_http-git.patch
index 9decea5..0674e01 100644
--- a/pecl_http-git.patch
+++ b/pecl_http-git.patch
@@ -48,3 +48,46 @@ index 803403f..055d585 100644
--
1.9.2
+From b0d5cbf0fc0e1c9ac8868dab045d17648cc084d9 Mon Sep 17 00:00:00 2001
+From: Michael Wallner <mike@php.net>
+Date: Mon, 4 Aug 2014 10:45:19 +0200
+Subject: [PATCH] =?utf8?q?fix=20PHP-5.4=20compatibility=C2=A7?=
+MIME-Version: 1.0
+Content-Type: text/plain; charset=utf8
+Content-Transfer-Encoding: 8bit
+
+---
+ php_http.h | 2 +-
+ php_http_header_parser.c | 2 +-
+ php_http_message_parser.c | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/php_http_header_parser.c b/php_http_header_parser.c
+index f560a85..ec41a24 100644
+--- a/php_http_header_parser.c
++++ b/php_http_header_parser.c
+@@ -62,7 +62,7 @@ php_http_header_parser_state_t php_http_header_parser_state_is(php_http_header_p
+ php_http_header_parser_state_t state;
+
+ if (parser->stack.top) {
+- return (php_http_header_parser_state_t) zend_ptr_stack_top(&parser->stack);
++ return (php_http_header_parser_state_t) parser->stack.elements[parser->stack.top - 1];
+ }
+
+ return PHP_HTTP_HEADER_PARSER_STATE_START;
+diff --git a/php_http_message_parser.c b/php_http_message_parser.c
+index 6328fa4..20ef3ac 100644
+--- a/php_http_message_parser.c
++++ b/php_http_message_parser.c
+@@ -80,7 +80,7 @@ php_http_message_parser_state_t php_http_message_parser_state_push(php_http_mess
+ php_http_message_parser_state_t php_http_message_parser_state_is(php_http_message_parser_t *parser)
+ {
+ if (parser->stack.top) {
+- return (php_http_message_parser_state_t) zend_ptr_stack_top(&parser->stack);
++ return (php_http_message_parser_state_t) parser->stack.elements[parser->stack.top - 1];
+ }
+ return PHP_HTTP_MESSAGE_PARSER_STATE_START;
+ }
+--
+1.9.2
+
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index cd84540..33db5ef 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -277,7 +277,7 @@ SKIP_ONLINE_TESTS=1 \
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n $modules -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=0 \
+REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php --show-diff
%endif
%endif