summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-28 07:31:55 +0200
committerRemi Collet <remi@remirepo.net>2017-04-28 07:31:55 +0200
commit7049ed0f797004513eb682ed5c652e727c0b532e (patch)
tree2f036162e7dc3c2ec2330ffa00d8f3b8c066e80b
parent5c694367489a5e5d3d1fb35adb9b5a1720a9c816 (diff)
cleanup BR
-rw-r--r--php-pecl-http-php7.spec31
-rw-r--r--php-pecl-http.spec31
2 files changed, 18 insertions, 44 deletions
diff --git a/php-pecl-http-php7.spec b/php-pecl-http-php7.spec
index 2274be2..23f1aa6 100644
--- a/php-pecl-http-php7.spec
+++ b/php-pecl-http-php7.spec
@@ -43,7 +43,7 @@ Version: 3.1.0
Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{proj_name}-%{version}%{?prever}.tgz
%endif
Summary: Extended HTTP support
@@ -67,26 +67,9 @@ BuildRequires: libidn-devel
BuildRequires: libicu-devel >= 50
BuildRequires: %{?scl_prefix}php-pecl-propro-devel >= 2
BuildRequires: %{?scl_prefix}php-pecl-raphf-devel >= 2
-
-%if 0%{?scl:1} && 0%{?fedora} < 15 && 0%{?rhel} < 7 && "%{?scl_vendor}" != "remi"
-# Filter in the SCL collection
-%{?filter_requires_in: %filter_requires_in %{_libdir}/.*\.so}
-# libvent from SCL as not available in system
-BuildRequires: %{sub_prefix}libevent-devel > 2
-Requires: %{sub_prefix}libevent%{_isa} > 2
-Requires: libcurl%{_isa}
-Requires: zlib%{_isa}
-%global _event_prefix %{_prefix}
-
-%else
-%global _event_prefix %{_root_prefix}
-%if "%{?vendor}" == "Remi Collet"
-BuildRequires: libevent-devel > 2
-%else
-# Copr build
-BuildRequires: libevent-devel > 1.4
-%endif
-%endif
+BuildRequires: pkgconfig(libevent) >= 2
+# only needed in F27+
+BuildRequires: openssl-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -214,7 +197,7 @@ peclconf() {
--with-http-libcurl-dir=%{_root_prefix} \
--with-http-libidn-dir=%{_root_prefix} \
--with-http-libicu-dir=%{_root_prefix} \
- --with-http-libevent-dir=%{_event_prefix} \
+ --with-http-libevent-dir=%{_root_prefix} \
--with-libdir=%{_lib} \
--with-php-config=$1
}
@@ -358,6 +341,10 @@ fi
%changelog
+* Fri Apr 28 2017 Remi Collet <remi@fedoraproject.org> - 3.1.0-2
+- add missing BR on openssl-devel for new libcurl (FTBFS from Koschei)
+- ensure we use libevent2 on EL-6
+
* Mon Dec 12 2016 Remi Collet <remi@fedoraproject.org> - 3.1.0-1
- update to 3.1.0 (php 7, stable)
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 3bfafa8..927a40a 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -38,7 +38,7 @@
#global prever RC1
Name: %{?sub_prefix}php-pecl-http
Version: 2.6.0
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Extended HTTP support
License: BSD
@@ -61,26 +61,9 @@ BuildRequires: curl-devel >= 7.18.2
BuildRequires: libidn-devel
BuildRequires: %{?sub_prefix}php-pecl-propro-devel >= 1.0.0
BuildRequires: %{?sub_prefix}php-pecl-raphf-devel >= 1.1.0
-
-%if 0%{?scl:1} && 0%{?fedora} < 15 && 0%{?rhel} < 7 && "%{?scl_vendor}" != "remi"
-# Filter in the SCL collection
-%{?filter_requires_in: %filter_requires_in %{_libdir}/.*\.so}
-# libvent from SCL as not available in system
-BuildRequires: %{sub_prefix}libevent-devel > 2
-Requires: %{sub_prefix}libevent%{_isa} > 2
-Requires: libcurl%{_isa}
-Requires: zlib%{_isa}
-%global _event_prefix %{_prefix}
-
-%else
-%global _event_prefix %{_root_prefix}
-%if "%{?vendor}" == "Remi Collet"
-BuildRequires: libevent-devel > 2
-%else
-# Copr build
-BuildRequires: libevent-devel > 1.4
-%endif
-%endif
+BuildRequires: pkgconfig(libevent) >= 2
+# only needed in F27+
+BuildRequires: openssl-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -211,7 +194,7 @@ peclconf() {
--with-http-zlib-dir=%{_root_prefix} \
--with-http-libcurl-dir=%{_root_prefix} \
--with-http-libidn-dir=%{_root_prefix} \
- --with-http-libevent-dir=%{_event_prefix} \
+ --with-http-libevent-dir=%{_root_prefix} \
--with-libdir=%{_lib} \
--with-php-config=$1
}
@@ -358,6 +341,10 @@ rm -rf %{buildroot}
%changelog
+* Fri Apr 28 2017 Remi Collet <remi@fedoraproject.org> - 2.6.0-2
+- add missing BR on openssl-devel for new libcurl (FTBFS from Koschei)
+- ensure we use libevent2 on EL-6
+
* Mon Dec 12 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
- update to 2.6.0 (php 5, stable)