summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-10 10:02:05 +0200
committerRemi Collet <remi@php.net>2022-06-10 10:02:05 +0200
commit598b8e435c91dd6343362877ca81c8186d8fa713 (patch)
treef86548497036e60b812da344da1068fdecf82a61
parent0e161b9b0597cc7283f7ab605f35f46095cae8a0 (diff)
update to 3.3.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION59
-rw-r--r--php-pecl-http.spec7
3 files changed, 56 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
index bb614ed..848af79 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
http
HTTP Support => enabled
-Extension Version => 3.2.5
+Extension Version => 3.3.0
Used Library => Compiled => Linked
libz => 1.2.11 => 1.2.11
diff --git a/REFLECTION b/REFLECTION
index c231624..7db98d5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #153 http version 3.2.5 ] {
+Extension [ <persistent> extension #154 http version 3.3.0 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -13,11 +13,10 @@ Extension [ <persistent> extension #153 http version 3.2.5 ] {
}
}
- - Constants [56] {
+ - Constants [91] {
Constant [ int http\Client\Curl\FEATURES ] { 297781149 }
Constant [ int http\Client\Curl\Features\IPV6 ] { 1 }
Constant [ int http\Client\Curl\Features\KERBEROS4 ] { 2 }
- Constant [ int http\Client\Curl\Features\KERBEROS5 ] { 262144 }
Constant [ int http\Client\Curl\Features\SSL ] { 4 }
Constant [ int http\Client\Curl\Features\LIBZ ] { 8 }
Constant [ int http\Client\Curl\Features\NTLM ] { 16 }
@@ -27,42 +26,72 @@ Extension [ <persistent> extension #153 http version 3.2.5 ] {
Constant [ int http\Client\Curl\Features\LARGEFILE ] { 512 }
Constant [ int http\Client\Curl\Features\IDN ] { 1024 }
Constant [ int http\Client\Curl\Features\SSPI ] { 2048 }
- Constant [ int http\Client\Curl\Features\GSSAPI ] { 131072 }
Constant [ int http\Client\Curl\Features\TLSAUTH_SRP ] { 16384 }
Constant [ int http\Client\Curl\Features\NTLM_WB ] { 32768 }
Constant [ int http\Client\Curl\Features\HTTP2 ] { 65536 }
+ Constant [ int http\Client\Curl\Features\GSSAPI ] { 131072 }
+ Constant [ int http\Client\Curl\Features\KERBEROS5 ] { 262144 }
Constant [ int http\Client\Curl\Features\UNIX_SOCKETS ] { 524288 }
Constant [ int http\Client\Curl\Features\PSL ] { 1048576 }
- Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.79.1 OpenSSL/1.1.1l-fips zlib/1.2.11 brotli/1.0.9 libidn2/2.3.2 libpsl/0.21.1 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.45.1 OpenLDAP/2.4.59 }
+ Constant [ int http\Client\Curl\Features\HTTPS_PROXY ] { 2097152 }
+ Constant [ int http\Client\Curl\Features\MULTI_SSL ] { 4194304 }
+ Constant [ int http\Client\Curl\Features\BROTLI ] { 8388608 }
+ Constant [ int http\Client\Curl\Features\ALTSVC ] { 16777216 }
+ Constant [ int http\Client\Curl\Features\HTTP3 ] { 33554432 }
+ Constant [ int http\Client\Curl\Features\ZSTD ] { 67108864 }
+ Constant [ int http\Client\Curl\Features\UNICODE ] { 134217728 }
+ Constant [ int http\Client\Curl\Features\HSTS ] { 268435456 }
+ Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.79.1 OpenSSL/1.1.1n-fips zlib/1.2.11 brotli/1.0.9 libidn2/2.3.2 libpsl/0.21.1 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.45.1 OpenLDAP/2.4.59 }
Constant [ string http\Client\Curl\Versions\CURL ] { 7.79.1 }
- Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/1.1.1l-fips }
+ Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/1.1.1n-fips }
Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.11 }
+ Constant [ null http\Client\Curl\Versions\ARES ] { }
+ Constant [ string http\Client\Curl\Versions\IDN ] { 2.3.2 }
+ Constant [ null http\Client\Curl\Versions\ICONV ] { }
+ Constant [ string http\Client\Curl\Versions\BROTLI ] { 1.0.9 }
+ Constant [ string http\Client\Curl\Versions\NGHTTP2 ] { 1.45.1 }
+ Constant [ null http\Client\Curl\Versions\QUIC ] { }
+ Constant [ string http\Client\Curl\Versions\CAINFO ] { /etc/pki/tls/certs/ca-bundle.crt }
+ Constant [ null http\Client\Curl\Versions\CAPATH ] { }
+ Constant [ null http\Client\Curl\Versions\ZSTD ] { }
+ Constant [ null http\Client\Curl\Versions\HYPER ] { }
Constant [ int http\Client\Curl\HTTP_VERSION_1_0 ] { 1 }
Constant [ int http\Client\Curl\HTTP_VERSION_1_1 ] { 2 }
Constant [ int http\Client\Curl\HTTP_VERSION_2_0 ] { 3 }
Constant [ int http\Client\Curl\HTTP_VERSION_2TLS ] { 4 }
+ Constant [ int http\Client\Curl\HTTP_VERSION_2_PRIOR_KNOWLEDGE ] { 5 }
+ Constant [ int http\Client\Curl\HTTP_VERSION_3 ] { 30 }
Constant [ int http\Client\Curl\HTTP_VERSION_ANY ] { 0 }
Constant [ int http\Client\Curl\SSL_VERSION_TLSv1 ] { 1 }
Constant [ int http\Client\Curl\SSL_VERSION_TLSv1_0 ] { 4 }
Constant [ int http\Client\Curl\SSL_VERSION_TLSv1_1 ] { 5 }
Constant [ int http\Client\Curl\SSL_VERSION_TLSv1_2 ] { 6 }
+ Constant [ int http\Client\Curl\SSL_VERSION_TLSv1_3 ] { 7 }
Constant [ int http\Client\Curl\SSL_VERSION_SSLv2 ] { 2 }
Constant [ int http\Client\Curl\SSL_VERSION_SSLv3 ] { 3 }
Constant [ int http\Client\Curl\SSL_VERSION_ANY ] { 0 }
Constant [ int http\Client\Curl\TLSAUTH_SRP ] { 1 }
+ Constant [ int http\Client\Curl\SSL_VERSION_MAX_DEFAULT ] { 65536 }
+ Constant [ int http\Client\Curl\SSL_VERSION_MAX_TLSv1_0 ] { 262144 }
+ Constant [ int http\Client\Curl\SSL_VERSION_MAX_TLSv1_1 ] { 327680 }
+ Constant [ int http\Client\Curl\SSL_VERSION_MAX_TLSv1_2 ] { 393216 }
+ Constant [ int http\Client\Curl\SSL_VERSION_MAX_TLSv1_3 ] { 458752 }
Constant [ int http\Client\Curl\IPRESOLVE_V4 ] { 1 }
Constant [ int http\Client\Curl\IPRESOLVE_V6 ] { 2 }
Constant [ int http\Client\Curl\IPRESOLVE_ANY ] { 0 }
+ Constant [ int http\Client\Curl\AUTH_NONE ] { 0 }
Constant [ int http\Client\Curl\AUTH_BASIC ] { 1 }
Constant [ int http\Client\Curl\AUTH_DIGEST ] { 2 }
Constant [ int http\Client\Curl\AUTH_DIGEST_IE ] { 16 }
Constant [ int http\Client\Curl\AUTH_NTLM ] { 8 }
Constant [ int http\Client\Curl\AUTH_GSSNEG ] { 4 }
Constant [ int http\Client\Curl\AUTH_SPNEGO ] { 4 }
+ Constant [ int http\Client\Curl\AUTH_BEARER ] { 64 }
+ Constant [ int http\Client\Curl\AWS_SIGV4 ] { 128 }
Constant [ int http\Client\Curl\AUTH_ANY ] { -17 }
Constant [ int http\Client\Curl\PROXY_SOCKS4 ] { 4 }
- Constant [ int http\Client\Curl\PROXY_SOCKS4A ] { 5 }
- Constant [ int http\Client\Curl\PROXY_SOCKS5_HOSTNAME ] { 5 }
+ Constant [ int http\Client\Curl\PROXY_SOCKS4A ] { 6 }
+ Constant [ int http\Client\Curl\PROXY_SOCKS5_HOSTNAME ] { 7 }
Constant [ int http\Client\Curl\PROXY_SOCKS5 ] { 5 }
Constant [ int http\Client\Curl\PROXY_HTTP ] { 0 }
Constant [ int http\Client\Curl\PROXY_HTTP_1_0 ] { 1 }
@@ -70,6 +99,12 @@ Extension [ <persistent> extension #153 http version 3.2.5 ] {
Constant [ int http\Client\Curl\POSTREDIR_302 ] { 2 }
Constant [ int http\Client\Curl\POSTREDIR_303 ] { 4 }
Constant [ int http\Client\Curl\POSTREDIR_ALL ] { 7 }
+ Constant [ int http\Client\Curl\ALTSVC_READONLYFILE ] { 4 }
+ Constant [ int http\Client\Curl\ALTSVC_H1 ] { 8 }
+ Constant [ int http\Client\Curl\ALTSVC_H2 ] { 16 }
+ Constant [ int http\Client\Curl\ALTSVC_H3 ] { 32 }
+ Constant [ int http\Client\Curl\HSTS_ENABLE ] { 1 }
+ Constant [ int http\Client\Curl\HSTS_READONLYFILE ] { 2 }
}
- Classes [33] {
@@ -3146,7 +3181,7 @@ Extension [ <persistent> extension #153 http version 3.2.5 ] {
- Static properties [0] {
}
- - Static methods [13] {
+ - Static methods [14] {
Method [ <internal:http> static public method getRequestHeader ] {
- Parameters [1] {
@@ -3245,6 +3280,12 @@ Extension [ <persistent> extension #153 http version 3.2.5 ] {
Parameter #3 [ <optional> &$result_array ]
}
}
+
+ Method [ <internal:http> static public method reset ] {
+
+ - Parameters [0] {
+ }
+ }
}
- Properties [0] {
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 99a55af..e0a31e5 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -37,7 +37,7 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-%global upstream_version 3.2.5
+%global upstream_version 3.3.0
#global upstream_prever RC1
Name: %{?sub_prefix}php-pecl-http
@@ -46,7 +46,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.7.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
Summary: Extended HTTP support
@@ -345,6 +345,9 @@ fi
%changelog
+* Fri Jun 10 2022 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0
+
* Fri Feb 25 2022 Remi Collet <remi@remirepo.net> - 3.2.5-1
- update to 3.2.5