summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-10 10:22:41 +0200
committerRemi Collet <remi@remirepo.net>2018-04-10 10:22:41 +0200
commit3a580096baeb46c5bd3bf3369c41fac92c2973b8 (patch)
tree67952cae5089e89cf6cf3603d8f830bc63c68386
parent9179bf995a1cd295387893d49194572f18ef517e (diff)
update to 3.2.0RC1
enable brotli compression support on F28+
-rw-r--r--REFLECTION325
-rw-r--r--php-pecl-http.spec29
2 files changed, 187 insertions, 167 deletions
diff --git a/REFLECTION b/REFLECTION
index 1dd40e3..d27614a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
+Extension [ <persistent> extension #185 http version 3.2.0RC1 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -13,8 +13,8 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
}
}
- - Constants [55] {
- Constant [ integer http\Client\Curl\FEATURES ] { 2066333 }
+ - Constants [56] {
+ Constant [ integer http\Client\Curl\FEATURES ] { 4179869 }
Constant [ integer http\Client\Curl\Features\IPV6 ] { 1 }
Constant [ integer http\Client\Curl\Features\KERBEROS4 ] { 2 }
Constant [ integer http\Client\Curl\Features\KERBEROS5 ] { 262144 }
@@ -33,10 +33,10 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Constant [ integer http\Client\Curl\Features\HTTP2 ] { 65536 }
Constant [ integer http\Client\Curl\Features\UNIX_SOCKETS ] { 524288 }
Constant [ integer http\Client\Curl\Features\PSL ] { 1048576 }
- Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.51.0 NSS/3.30.2 zlib/1.2.8 libidn2/2.0.2 libpsl/0.17.0 (+libidn2/0.11) libssh2/1.8.0 nghttp2/1.13.0 }
- Constant [ string http\Client\Curl\Versions\CURL ] { 7.51.0 }
- Constant [ string http\Client\Curl\Versions\SSL ] { NSS/3.30.2 }
- Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.8 }
+ Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.55.1 OpenSSL/1.1.0h zlib/1.2.11 libidn2/2.0.4 libpsl/0.18.0 (+libidn2/2.0.3) libssh2/1.8.0 nghttp2/1.25.0 }
+ Constant [ string http\Client\Curl\Versions\CURL ] { 7.55.1 }
+ Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/1.1.0h }
+ Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.11 }
Constant [ integer http\Client\Curl\HTTP_VERSION_1_0 ] { 1 }
Constant [ integer http\Client\Curl\HTTP_VERSION_1_1 ] { 2 }
Constant [ integer http\Client\Curl\HTTP_VERSION_2_0 ] { 3 }
@@ -49,6 +49,7 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Constant [ integer http\Client\Curl\SSL_VERSION_SSLv2 ] { 2 }
Constant [ integer http\Client\Curl\SSL_VERSION_SSLv3 ] { 3 }
Constant [ integer http\Client\Curl\SSL_VERSION_ANY ] { 0 }
+ Constant [ integer http\Client\Curl\TLSAUTH_SRP ] { 1 }
Constant [ integer http\Client\Curl\IPRESOLVE_V4 ] { 1 }
Constant [ integer http\Client\Curl\IPRESOLVE_V6 ] { 2 }
Constant [ integer http\Client\Curl\IPRESOLVE_ANY ] { 0 }
@@ -606,9 +607,9 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> class http\Cookie ] {
- Constants [3] {
- Constant [ integer PARSE_RAW ] { 1 }
- Constant [ integer SECURE ] { 16 }
- Constant [ integer HTTPONLY ] { 32 }
+ Constant [ public integer PARSE_RAW ] { 1 }
+ Constant [ public integer SECURE ] { 16 }
+ Constant [ public integer HTTPONLY ] { 32 }
}
- Static properties [0] {
@@ -804,9 +805,9 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> abstract class http\Encoding\Stream ] {
- Constants [3] {
- Constant [ integer FLUSH_NONE ] { 0 }
- Constant [ integer FLUSH_SYNC ] { 1048576 }
- Constant [ integer FLUSH_FULL ] { 2097152 }
+ Constant [ public integer FLUSH_NONE ] { 0 }
+ Constant [ public integer FLUSH_SYNC ] { 1048576 }
+ Constant [ public integer FLUSH_FULL ] { 2097152 }
}
- Static properties [0] {
@@ -853,34 +854,23 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
}
}
- Class [ <internal:http> class http\Encoding\Stream\Deflate extends http\Encoding\Stream ] {
+ Class [ <internal:http> class http\Encoding\Stream\Dechunk extends http\Encoding\Stream ] {
- - Constants [14] {
- Constant [ integer FLUSH_NONE ] { 0 }
- Constant [ integer FLUSH_SYNC ] { 1048576 }
- Constant [ integer FLUSH_FULL ] { 2097152 }
- Constant [ integer TYPE_GZIP ] { 16 }
- Constant [ integer TYPE_ZLIB ] { 0 }
- Constant [ integer TYPE_RAW ] { 32 }
- Constant [ integer LEVEL_DEF ] { 0 }
- Constant [ integer LEVEL_MIN ] { 1 }
- Constant [ integer LEVEL_MAX ] { 9 }
- Constant [ integer STRATEGY_DEF ] { 0 }
- Constant [ integer STRATEGY_FILT ] { 256 }
- Constant [ integer STRATEGY_HUFF ] { 512 }
- Constant [ integer STRATEGY_RLE ] { 768 }
- Constant [ integer STRATEGY_FIXED ] { 1024 }
+ - Constants [3] {
+ Constant [ public integer FLUSH_NONE ] { 0 }
+ Constant [ public integer FLUSH_SYNC ] { 1048576 }
+ Constant [ public integer FLUSH_FULL ] { 2097152 }
}
- Static properties [0] {
}
- Static methods [1] {
- Method [ <internal:http> static public method encode ] {
+ Method [ <internal:http> static public method decode ] {
- Parameters [2] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $flags ]
+ Parameter #1 [ <optional> &$decoded_len ]
}
}
}
@@ -923,22 +913,34 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
}
}
- Class [ <internal:http> class http\Encoding\Stream\Inflate extends http\Encoding\Stream ] {
+ Class [ <internal:http> class http\Encoding\Stream\Deflate extends http\Encoding\Stream ] {
- - Constants [3] {
- Constant [ integer FLUSH_NONE ] { 0 }
- Constant [ integer FLUSH_SYNC ] { 1048576 }
- Constant [ integer FLUSH_FULL ] { 2097152 }
+ - Constants [14] {
+ Constant [ public integer FLUSH_NONE ] { 0 }
+ Constant [ public integer FLUSH_SYNC ] { 1048576 }
+ Constant [ public integer FLUSH_FULL ] { 2097152 }
+ Constant [ public integer TYPE_GZIP ] { 16 }
+ Constant [ public integer TYPE_ZLIB ] { 0 }
+ Constant [ public integer TYPE_RAW ] { 32 }
+ Constant [ public integer LEVEL_DEF ] { 0 }
+ Constant [ public integer LEVEL_MIN ] { 1 }
+ Constant [ public integer LEVEL_MAX ] { 9 }
+ Constant [ public integer STRATEGY_DEF ] { 0 }
+ Constant [ public integer STRATEGY_FILT ] { 256 }
+ Constant [ public integer STRATEGY_HUFF ] { 512 }
+ Constant [ public integer STRATEGY_RLE ] { 768 }
+ Constant [ public integer STRATEGY_FIXED ] { 1024 }
}
- Static properties [0] {
}
- Static methods [1] {
- Method [ <internal:http> static public method decode ] {
+ Method [ <internal:http> static public method encode ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $flags ]
}
}
}
@@ -981,12 +983,12 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
}
}
- Class [ <internal:http> class http\Encoding\Stream\Dechunk extends http\Encoding\Stream ] {
+ Class [ <internal:http> class http\Encoding\Stream\Inflate extends http\Encoding\Stream ] {
- Constants [3] {
- Constant [ integer FLUSH_NONE ] { 0 }
- Constant [ integer FLUSH_SYNC ] { 1048576 }
- Constant [ integer FLUSH_FULL ] { 2097152 }
+ Constant [ public integer FLUSH_NONE ] { 0 }
+ Constant [ public integer FLUSH_SYNC ] { 1048576 }
+ Constant [ public integer FLUSH_FULL ] { 2097152 }
}
- Static properties [0] {
@@ -995,9 +997,8 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
- Static methods [1] {
Method [ <internal:http> static public method decode ] {
- - Parameters [2] {
+ - Parameters [1] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> &$decoded_len ]
}
}
}
@@ -1043,11 +1044,11 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> class http\Header implements Serializable ] {
- Constants [5] {
- Constant [ integer MATCH_LOOSE ] { 0 }
- Constant [ integer MATCH_CASE ] { 1 }
- Constant [ integer MATCH_WORD ] { 16 }
- Constant [ integer MATCH_FULL ] { 32 }
- Constant [ integer MATCH_STRICT ] { 33 }
+ Constant [ public integer MATCH_LOOSE ] { 0 }
+ Constant [ public integer MATCH_CASE ] { 1 }
+ Constant [ public integer MATCH_WORD ] { 16 }
+ Constant [ public integer MATCH_FULL ] { 32 }
+ Constant [ public integer MATCH_STRICT ] { 33 }
}
- Static properties [0] {
@@ -1133,14 +1134,14 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> class http\Header\Parser ] {
- Constants [8] {
- Constant [ integer CLEANUP ] { 1 }
- Constant [ integer STATE_FAILURE ] { -1 }
- Constant [ integer STATE_START ] { 0 }
- Constant [ integer STATE_KEY ] { 1 }
- Constant [ integer STATE_VALUE ] { 2 }
- Constant [ integer STATE_VALUE_EX ] { 3 }
- Constant [ integer STATE_HEADER_DONE ] { 4 }
- Constant [ integer STATE_DONE ] { 5 }
+ Constant [ public integer CLEANUP ] { 1 }
+ Constant [ public integer STATE_FAILURE ] { -1 }
+ Constant [ public integer STATE_START ] { 0 }
+ Constant [ public integer STATE_KEY ] { 1 }
+ Constant [ public integer STATE_VALUE ] { 2 }
+ Constant [ public integer STATE_VALUE_EX ] { 3 }
+ Constant [ public integer STATE_HEADER_DONE ] { 4 }
+ Constant [ public integer STATE_DONE ] { 5 }
}
- Static properties [0] {
@@ -1182,9 +1183,9 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> <iterateable> class http\Message implements Countable, Serializable, Iterator, Traversable ] {
- Constants [3] {
- Constant [ integer TYPE_NONE ] { 0 }
- Constant [ integer TYPE_REQUEST ] { 1 }
- Constant [ integer TYPE_RESPONSE ] { 2 }
+ Constant [ public integer TYPE_NONE ] { 0 }
+ Constant [ public integer TYPE_REQUEST ] { 1 }
+ Constant [ public integer TYPE_RESPONSE ] { 2 }
}
- Static properties [0] {
@@ -1491,21 +1492,21 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> class http\Message\Parser ] {
- Constants [15] {
- Constant [ integer CLEANUP ] { 1 }
- Constant [ integer DUMB_BODIES ] { 2 }
- Constant [ integer EMPTY_REDIRECTS ] { 4 }
- Constant [ integer GREEDY ] { 8 }
- Constant [ integer STATE_FAILURE ] { -1 }
- Constant [ integer STATE_START ] { 0 }
- Constant [ integer STATE_HEADER ] { 1 }
- Constant [ integer STATE_HEADER_DONE ] { 2 }
- Constant [ integer STATE_BODY ] { 3 }
- Constant [ integer STATE_BODY_DUMB ] { 4 }
- Constant [ integer STATE_BODY_LENGTH ] { 5 }
- Constant [ integer STATE_BODY_CHUNKED ] { 6 }
- Constant [ integer STATE_BODY_DONE ] { 7 }
- Constant [ integer STATE_UPDATE_CL ] { 8 }
- Constant [ integer STATE_DONE ] { 9 }
+ Constant [ public integer CLEANUP ] { 1 }
+ Constant [ public integer DUMB_BODIES ] { 2 }
+ Constant [ public integer EMPTY_REDIRECTS ] { 4 }
+ Constant [ public integer GREEDY ] { 8 }
+ Constant [ public integer STATE_FAILURE ] { -1 }
+ Constant [ public integer STATE_START ] { 0 }
+ Constant [ public integer STATE_HEADER ] { 1 }
+ Constant [ public integer STATE_HEADER_DONE ] { 2 }
+ Constant [ public integer STATE_BODY ] { 3 }
+ Constant [ public integer STATE_BODY_DUMB ] { 4 }
+ Constant [ public integer STATE_BODY_LENGTH ] { 5 }
+ Constant [ public integer STATE_BODY_CHUNKED ] { 6 }
+ Constant [ public integer STATE_BODY_DONE ] { 7 }
+ Constant [ public integer STATE_UPDATE_CL ] { 8 }
+ Constant [ public integer STATE_DONE ] { 9 }
}
- Static properties [0] {
@@ -1661,12 +1662,12 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> <iterateable> class http\QueryString implements Serializable, ArrayAccess, IteratorAggregate, Traversable ] {
- Constants [6] {
- Constant [ integer TYPE_BOOL ] { 13 }
- Constant [ integer TYPE_INT ] { 4 }
- Constant [ integer TYPE_FLOAT ] { 5 }
- Constant [ integer TYPE_STRING ] { 6 }
- Constant [ integer TYPE_ARRAY ] { 7 }
- Constant [ integer TYPE_OBJECT ] { 8 }
+ Constant [ public integer TYPE_BOOL ] { 13 }
+ Constant [ public integer TYPE_INT ] { 4 }
+ Constant [ public integer TYPE_FLOAT ] { 5 }
+ Constant [ public integer TYPE_STRING ] { 6 }
+ Constant [ public integer TYPE_ARRAY ] { 7 }
+ Constant [ public integer TYPE_OBJECT ] { 8 }
}
- Static properties [1] {
@@ -1842,12 +1843,12 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> class http\Client implements SplSubject, Countable ] {
- Constants [6] {
- Constant [ integer DEBUG_INFO ] { 0 }
- Constant [ integer DEBUG_IN ] { 1 }
- Constant [ integer DEBUG_OUT ] { 2 }
- Constant [ integer DEBUG_HEADER ] { 16 }
- Constant [ integer DEBUG_BODY ] { 32 }
- Constant [ integer DEBUG_SSL ] { 64 }
+ Constant [ public integer DEBUG_INFO ] { 0 }
+ Constant [ public integer DEBUG_IN ] { 1 }
+ Constant [ public integer DEBUG_OUT ] { 2 }
+ Constant [ public integer DEBUG_HEADER ] { 16 }
+ Constant [ public integer DEBUG_BODY ] { 32 }
+ Constant [ public integer DEBUG_SSL ] { 64 }
}
- Static properties [0] {
@@ -2083,9 +2084,9 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> <iterateable> class http\Client\Request extends http\Message implements Traversable, Iterator, Serializable, Countable ] {
- Constants [3] {
- Constant [ integer TYPE_NONE ] { 0 }
- Constant [ integer TYPE_REQUEST ] { 1 }
- Constant [ integer TYPE_RESPONSE ] { 2 }
+ Constant [ public integer TYPE_NONE ] { 0 }
+ Constant [ public integer TYPE_REQUEST ] { 1 }
+ Constant [ public integer TYPE_RESPONSE ] { 2 }
}
- Static properties [0] {
@@ -2461,9 +2462,9 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> <iterateable> class http\Client\Response extends http\Message implements Traversable, Iterator, Serializable, Countable ] {
- Constants [3] {
- Constant [ integer TYPE_NONE ] { 0 }
- Constant [ integer TYPE_REQUEST ] { 1 }
- Constant [ integer TYPE_RESPONSE ] { 2 }
+ Constant [ public integer TYPE_NONE ] { 0 }
+ Constant [ public integer TYPE_REQUEST ] { 1 }
+ Constant [ public integer TYPE_RESPONSE ] { 2 }
}
- Static properties [0] {
@@ -2786,11 +2787,11 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Interface [ <internal:http> interface http\Client\Curl\User ] {
- Constants [5] {
- Constant [ integer POLL_NONE ] { 0 }
- Constant [ integer POLL_IN ] { 1 }
- Constant [ integer POLL_OUT ] { 2 }
- Constant [ integer POLL_INOUT ] { 3 }
- Constant [ integer POLL_REMOVE ] { 4 }
+ Constant [ public integer POLL_NONE ] { 0 }
+ Constant [ public integer POLL_IN ] { 1 }
+ Constant [ public integer POLL_OUT ] { 2 }
+ Constant [ public integer POLL_INOUT ] { 3 }
+ Constant [ public integer POLL_REMOVE ] { 4 }
}
- Static properties [0] {
@@ -2849,28 +2850,28 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> class http\Url ] {
- Constants [22] {
- Constant [ integer REPLACE ] { 0 }
- Constant [ integer JOIN_PATH ] { 1 }
- Constant [ integer JOIN_QUERY ] { 2 }
- Constant [ integer STRIP_USER ] { 4 }
- Constant [ integer STRIP_PASS ] { 8 }
- Constant [ integer STRIP_AUTH ] { 12 }
- Constant [ integer STRIP_PORT ] { 32 }
- Constant [ integer STRIP_PATH ] { 64 }
- Constant [ integer STRIP_QUERY ] { 128 }
- Constant [ integer STRIP_FRAGMENT ] { 256 }
- Constant [ integer STRIP_ALL ] { 492 }
- Constant [ integer FROM_ENV ] { 4096 }
- Constant [ integer SANITIZE_PATH ] { 8192 }
- Constant [ integer PARSE_MBLOC ] { 65536 }
- Constant [ integer PARSE_MBUTF8 ] { 131072 }
- Constant [ integer PARSE_TOIDN ] { 1048576 }
- Constant [ integer PARSE_TOIDN_2003 ] { 9437184 }
- Constant [ integer PARSE_TOIDN_2008 ] { 5242880 }
- Constant [ integer PARSE_TOPCT ] { 2097152 }
- Constant [ integer IGNORE_ERRORS ] { 268435456 }
- Constant [ integer SILENT_ERRORS ] { 536870912 }
- Constant [ integer STDFLAGS ] { 3350531 }
+ Constant [ public integer REPLACE ] { 0 }
+ Constant [ public integer JOIN_PATH ] { 1 }
+ Constant [ public integer JOIN_QUERY ] { 2 }
+ Constant [ public integer STRIP_USER ] { 4 }
+ Constant [ public integer STRIP_PASS ] { 8 }
+ Constant [ public integer STRIP_AUTH ] { 12 }
+ Constant [ public integer STRIP_PORT ] { 32 }
+ Constant [ public integer STRIP_PATH ] { 64 }
+ Constant [ public integer STRIP_QUERY ] { 128 }
+ Constant [ public integer STRIP_FRAGMENT ] { 256 }
+ Constant [ public integer STRIP_ALL ] { 492 }
+ Constant [ public integer FROM_ENV ] { 4096 }
+ Constant [ public integer SANITIZE_PATH ] { 8192 }
+ Constant [ public integer PARSE_MBLOC ] { 65536 }
+ Constant [ public integer PARSE_MBUTF8 ] { 131072 }
+ Constant [ public integer PARSE_TOIDN ] { 1048576 }
+ Constant [ public integer PARSE_TOIDN_2003 ] { 9437184 }
+ Constant [ public integer PARSE_TOIDN_2008 ] { 5242880 }
+ Constant [ public integer PARSE_TOPCT ] { 2097152 }
+ Constant [ public integer IGNORE_ERRORS ] { 268435456 }
+ Constant [ public integer SILENT_ERRORS ] { 536870912 }
+ Constant [ public integer STDFLAGS ] { 3350531 }
}
- Static properties [0] {
@@ -2931,25 +2932,25 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> class http\Env\Url extends http\Url ] {
- Constants [19] {
- Constant [ integer REPLACE ] { 0 }
- Constant [ integer JOIN_PATH ] { 1 }
- Constant [ integer JOIN_QUERY ] { 2 }
- Constant [ integer STRIP_USER ] { 4 }
- Constant [ integer STRIP_PASS ] { 8 }
- Constant [ integer STRIP_AUTH ] { 12 }
- Constant [ integer STRIP_PORT ] { 32 }
- Constant [ integer STRIP_PATH ] { 64 }
- Constant [ integer STRIP_QUERY ] { 128 }
- Constant [ integer STRIP_FRAGMENT ] { 256 }
- Constant [ integer STRIP_ALL ] { 492 }
- Constant [ integer FROM_ENV ] { 4096 }
- Constant [ integer SANITIZE_PATH ] { 8192 }
- Constant [ integer PARSE_MBLOC ] { 65536 }
- Constant [ integer PARSE_MBUTF8 ] { 131072 }
- Constant [ integer PARSE_TOIDN ] { 1048576 }
- Constant [ integer PARSE_TOIDN_2003 ] { 9437184 }
- Constant [ integer PARSE_TOIDN_2008 ] { 5242880 }
- Constant [ integer PARSE_TOPCT ] { 2097152 }
+ Constant [ public integer REPLACE ] { 0 }
+ Constant [ public integer JOIN_PATH ] { 1 }
+ Constant [ public integer JOIN_QUERY ] { 2 }
+ Constant [ public integer STRIP_USER ] { 4 }
+ Constant [ public integer STRIP_PASS ] { 8 }
+ Constant [ public integer STRIP_AUTH ] { 12 }
+ Constant [ public integer STRIP_PORT ] { 32 }
+ Constant [ public integer STRIP_PATH ] { 64 }
+ Constant [ public integer STRIP_QUERY ] { 128 }
+ Constant [ public integer STRIP_FRAGMENT ] { 256 }
+ Constant [ public integer STRIP_ALL ] { 492 }
+ Constant [ public integer FROM_ENV ] { 4096 }
+ Constant [ public integer SANITIZE_PATH ] { 8192 }
+ Constant [ public integer PARSE_MBLOC ] { 65536 }
+ Constant [ public integer PARSE_MBUTF8 ] { 131072 }
+ Constant [ public integer PARSE_TOIDN ] { 1048576 }
+ Constant [ public integer PARSE_TOIDN_2003 ] { 9437184 }
+ Constant [ public integer PARSE_TOIDN_2008 ] { 5242880 }
+ Constant [ public integer PARSE_TOPCT ] { 2097152 }
}
- Static properties [0] {
@@ -3126,9 +3127,9 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> <iterateable> class http\Env\Request extends http\Message implements Traversable, Iterator, Serializable, Countable ] {
- Constants [3] {
- Constant [ integer TYPE_NONE ] { 0 }
- Constant [ integer TYPE_REQUEST ] { 1 }
- Constant [ integer TYPE_RESPONSE ] { 2 }
+ Constant [ public integer TYPE_NONE ] { 0 }
+ Constant [ public integer TYPE_REQUEST ] { 1 }
+ Constant [ public integer TYPE_RESPONSE ] { 2 }
}
- Static properties [0] {
@@ -3473,14 +3474,14 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> <iterateable> class http\Env\Response extends http\Message implements Traversable, Iterator, Serializable, Countable ] {
- Constants [8] {
- Constant [ integer TYPE_NONE ] { 0 }
- Constant [ integer TYPE_REQUEST ] { 1 }
- Constant [ integer TYPE_RESPONSE ] { 2 }
- Constant [ integer CONTENT_ENCODING_NONE ] { 0 }
- Constant [ integer CONTENT_ENCODING_GZIP ] { 1 }
- Constant [ integer CACHE_NO ] { 0 }
- Constant [ integer CACHE_HIT ] { 1 }
- Constant [ integer CACHE_MISS ] { 2 }
+ Constant [ public integer TYPE_NONE ] { 0 }
+ Constant [ public integer TYPE_REQUEST ] { 1 }
+ Constant [ public integer TYPE_RESPONSE ] { 2 }
+ Constant [ public integer CONTENT_ENCODING_NONE ] { 0 }
+ Constant [ public integer CONTENT_ENCODING_GZIP ] { 1 }
+ Constant [ public integer CACHE_NO ] { 0 }
+ Constant [ public integer CACHE_HIT ] { 1 }
+ Constant [ public integer CACHE_MISS ] { 2 }
}
- Static properties [0] {
@@ -3888,18 +3889,18 @@ Extension [ <persistent> extension #169 http version 3.1.1RC1 ] {
Class [ <internal:http> class http\Params implements ArrayAccess ] {
- Constants [12] {
- Constant [ string DEF_PARAM_SEP ] { , }
- Constant [ string DEF_ARG_SEP ] { ; }
- Constant [ string DEF_VAL_SEP ] { = }
- Constant [ string COOKIE_PARAM_SEP ] { }
- Constant [ integer PARSE_RAW ] { 0 }
- Constant [ integer PARSE_ESCAPED ] { 1 }
- Constant [ integer PARSE_URLENCODED ] { 4 }
- Constant [ integer PARSE_DIMENSION ] { 8 }
- Constant [ integer PARSE_RFC5987 ] { 16 }
- Constant [ integer PARSE_RFC5988 ] { 32 }
- Constant [ integer PARSE_DEFAULT ] { 17 }
- Constant [ integer PARSE_QUERY ] { 12 }
+ Constant [ public string DEF_PARAM_SEP ] { , }
+ Constant [ public string DEF_ARG_SEP ] { ; }
+ Constant [ public string DEF_VAL_SEP ] { = }
+ Constant [ public string COOKIE_PARAM_SEP ] { }
+ Constant [ public integer PARSE_RAW ] { 0 }
+ Constant [ public integer PARSE_ESCAPED ] { 1 }
+ Constant [ public integer PARSE_URLENCODED ] { 4 }
+ Constant [ public integer PARSE_DIMENSION ] { 8 }
+ Constant [ public integer PARSE_RFC5987 ] { 16 }
+ Constant [ public integer PARSE_RFC5988 ] { 32 }
+ Constant [ public integer PARSE_DEFAULT ] { 17 }
+ Constant [ public integer PARSE_QUERY ] { 12 }
}
- Static properties [0] {
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 12a7cca..6142e67 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -16,6 +16,12 @@
%global _root_prefix %{_prefix}
%endif
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+%global with_libbrotli 1
+%else
+%global with_libbrotli 0
+%endif
+
%global gh_commit a84b499418ee7b8992fd9e7e2abc661735a869bd
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
@@ -35,7 +41,7 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-%global upstream_version 3.1.1
+%global upstream_version 3.2.0
%global upstream_prever RC1
Name: %{?sub_prefix}php-pecl-http
@@ -44,18 +50,18 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.3.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
Summary: Extended HTTP support
License: BSD
-Group: Development/Languages
URL: http://pecl.php.net/package/pecl_http
# From http://www.php.net/manual/en/http.configuration.php
Source1: %{proj_name}.ini
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-hash
BuildRequires: %{?scl_prefix}php-spl
@@ -70,6 +76,9 @@ BuildRequires: %{?scl_prefix}php-pecl-raphf-devel >= 2
BuildRequires: pkgconfig(libevent) >= 2
# only needed in F27+
BuildRequires: openssl-devel
+%if %{?with_libbrotli}
+BuildRequires: brotli-devel >= 1.0
+%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -139,7 +148,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%package devel
Summary: Extended HTTP support developer files (header)
-Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{?scl_prefix}php-devel%{?_isa} >= 5.3.0
Obsoletes: %{?scl_prefix}php-pecl-http1-devel < 2
@@ -182,6 +190,8 @@ cp -pr NTS ZTS
%build
+%{?dtsenable}
+
peclconf() {
%configure \
--with-http \
@@ -195,6 +205,9 @@ peclconf() {
--without-http-libidnkit2-dir \
--with-http-libicu-dir=%{_root_prefix} \
--with-http-libevent-dir=%{_root_prefix} \
+%if %{?with_libbrotli}
+ --with-http-libbrotli-dir=%{_root_prefix} \
+%endif
--with-libdir=%{_lib} \
--with-php-config=$1
grep IDNA config.h
@@ -213,6 +226,8 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
+
make -C NTS install INSTALL_ROOT=%{buildroot}
# Install XML package description
@@ -301,7 +316,7 @@ NO_INTERACTION=1 \
%endif
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -344,6 +359,10 @@ fi
%changelog
+* Tue Apr 10 2018 Remi Collet <remi@remirepo.net> - 3.2.0~RC1-1
+- update to 3.2.0RC1
+- enable brotli compression support on F28+
+
* Wed Aug 23 2017 Remi Collet <remi@remirepo.net> - 3.1.1~RC1-3
- ignore 1 failed test with libcurl 7.55
https://github.com/m6w6/ext-http/issues/72