summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-12-12 11:54:41 +0100
committerRemi Collet <fedora@famillecollet.com>2016-12-12 11:54:41 +0100
commit3a319e7e81e44c40934d6ed45a4fdd144127cb18 (patch)
tree7b1ea26cd891278322f3ea0621c9118c4cc6595a
parent18f9f7160fc95a696338f56764bced59d656a402 (diff)
php-pecl-http: 2.6.0 (php 5)
-rw-r--r--REFLECTION14
-rw-r--r--php-pecl-http-php7.spec9
-rw-r--r--php-pecl-http.spec19
3 files changed, 16 insertions, 26 deletions
diff --git a/REFLECTION b/REFLECTION
index c454209..4353ff0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #71 http version 2.6.0RC1 ] {
+Extension [ <persistent> extension #77 http version 2.6.0 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -14,8 +14,8 @@ Extension [ <persistent> extension #71 http version 2.6.0RC1 ] {
}
}
- - Constants [53] {
- Constant [ integer http\Client\Curl\FEATURES ] { 1017757 }
+ - Constants [55] {
+ Constant [ integer http\Client\Curl\FEATURES ] { 2066333 }
Constant [ integer http\Client\Curl\Features\IPV6 ] { 1 }
Constant [ integer http\Client\Curl\Features\KERBEROS4 ] { 2 }
Constant [ integer http\Client\Curl\Features\KERBEROS5 ] { 262144 }
@@ -33,13 +33,15 @@ Extension [ <persistent> extension #71 http version 2.6.0RC1 ] {
Constant [ integer http\Client\Curl\Features\NTLM_WB ] { 32768 }
Constant [ integer http\Client\Curl\Features\HTTP2 ] { 65536 }
Constant [ integer http\Client\Curl\Features\UNIX_SOCKETS ] { 524288 }
- Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.43.0 NSS/3.26 zlib/1.2.8 libidn/1.33 libssh2/1.6.0 nghttp2/1.7.1 }
- Constant [ string http\Client\Curl\Versions\CURL ] { 7.43.0 }
- Constant [ string http\Client\Curl\Versions\SSL ] { NSS/3.26 }
+ Constant [ integer http\Client\Curl\Features\PSL ] { 1048576 }
+ Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.51.0 NSS/3.27 zlib/1.2.8 libidn2/0.11 libpsl/0.14.0 (+libidn2/0.10) libssh2/1.8.0 nghttp2/1.13.0 }
+ Constant [ string http\Client\Curl\Versions\CURL ] { 7.51.0 }
+ Constant [ string http\Client\Curl\Versions\SSL ] { NSS/3.27 }
Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.8 }
Constant [ integer http\Client\Curl\HTTP_VERSION_1_0 ] { 1 }
Constant [ integer http\Client\Curl\HTTP_VERSION_1_1 ] { 2 }
Constant [ integer http\Client\Curl\HTTP_VERSION_2_0 ] { 3 }
+ Constant [ integer http\Client\Curl\HTTP_VERSION_2TLS ] { 4 }
Constant [ integer http\Client\Curl\HTTP_VERSION_ANY ] { 0 }
Constant [ integer http\Client\Curl\SSL_VERSION_TLSv1 ] { 1 }
Constant [ integer http\Client\Curl\SSL_VERSION_TLSv1_0 ] { 4 }
diff --git a/php-pecl-http-php7.spec b/php-pecl-http-php7.spec
index cd2bd2e..7cdb1ef 100644
--- a/php-pecl-http-php7.spec
+++ b/php-pecl-http-php7.spec
@@ -232,8 +232,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
-
make -C NTS install INSTALL_ROOT=%{buildroot}
# Install XML package description
@@ -337,12 +335,7 @@ fi
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{proj_name}
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -366,7 +359,7 @@ rm -rf %{buildroot}
%changelog
* Mon Dec 12 2016 Remi Collet <remi@fedoraproject.org> - 3.1.0-1
-- update to 3.1.0
+- update to 3.1.0 (php 7, stable)
* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 3.1.0-0.5.RC1
- rebuild with PHP 7.1.0 GA
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 051589a..9f11014 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -10,17 +10,13 @@
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
%global sub_prefix %{scl_prefix}
-%endif
%scl_package php-pecl-http
%else
%global _root_prefix %{_prefix}
%endif
-%global prever RC1
+#global prever RC1
# The project is pecl_http but the extension is only http
%global proj_name pecl_http
%global pecl_name http
@@ -42,7 +38,7 @@
#global prever RC1
Name: %{?sub_prefix}php-pecl-http
Version: 2.6.0
-Release: 0.3.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Extended HTTP support
License: BSD
@@ -54,7 +50,7 @@ Source0: http://pecl.php.net/get/%{proj_name}-%{version}%{?prever}.tgz
Source1: %{proj_name}.ini
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel >= 5.3.0
+BuildRequires: %{?scl_prefix}php-devel < 7
BuildRequires: %{?scl_prefix}php-hash
BuildRequires: %{?scl_prefix}php-iconv
BuildRequires: %{?scl_prefix}php-spl
@@ -259,12 +255,8 @@ done
%check
-%if "%{php_version}" < "5.4"
-# Known failed test with 5.3.3 (need investigations)
-export REPORT_EXIT_STATUS=0
-%else
export REPORT_EXIT_STATUS=1
-%endif
+
user=$(id -un)
: all tests when rpmbuild is used
if [ "$user" = "remi" ]; then
@@ -366,6 +358,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Dec 12 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0 (php 5, stable)
+
* Wed Oct 5 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-0.3.RC1
- Update to 2.6.0RC1 (php 5, beta)