summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-07 13:02:03 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-07 13:02:03 +0200
commit21e05a9629628470f3438797cdca38e147dbbbae (patch)
tree054b5b20aa5bb369de6e65f6301f49cb97fff95e
parent9bc455eee19df0cc4027d9e08d23b28dd11c864d (diff)
php-pecl-http: 3.1.0beta2
-rw-r--r--REFLECTION-PHP7113
-rw-r--r--php-pecl-http-php7.spec12
2 files changed, 113 insertions, 12 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
index 910269a..88f7adb 100644
--- a/REFLECTION-PHP7
+++ b/REFLECTION-PHP7
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #84 http version 3.0.1 ] {
+Extension [ <persistent> extension #138 http version 3.1.0beta2 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -14,7 +14,29 @@ Extension [ <persistent> extension #84 http version 3.0.1 ] {
}
}
- - Constants [31] {
+ - Constants [53] {
+ Constant [ integer http\Client\Curl\FEATURES ] { 1017757 }
+ Constant [ integer http\Client\Curl\Features\IPV6 ] { 1 }
+ Constant [ integer http\Client\Curl\Features\KERBEROS4 ] { 2 }
+ Constant [ integer http\Client\Curl\Features\KERBEROS5 ] { 262144 }
+ Constant [ integer http\Client\Curl\Features\SSL ] { 4 }
+ Constant [ integer http\Client\Curl\Features\LIBZ ] { 8 }
+ Constant [ integer http\Client\Curl\Features\NTLM ] { 16 }
+ Constant [ integer http\Client\Curl\Features\GSSNEGOTIATE ] { 32 }
+ Constant [ integer http\Client\Curl\Features\ASYNCHDNS ] { 128 }
+ Constant [ integer http\Client\Curl\Features\SPNEGO ] { 256 }
+ Constant [ integer http\Client\Curl\Features\LARGEFILE ] { 512 }
+ Constant [ integer http\Client\Curl\Features\IDN ] { 1024 }
+ Constant [ integer http\Client\Curl\Features\SSPI ] { 2048 }
+ Constant [ integer http\Client\Curl\Features\GSSAPI ] { 131072 }
+ Constant [ integer http\Client\Curl\Features\TLSAUTH_SRP ] { 16384 }
+ Constant [ integer http\Client\Curl\Features\NTLM_WB ] { 32768 }
+ Constant [ integer http\Client\Curl\Features\HTTP2 ] { 65536 }
+ Constant [ integer http\Client\Curl\Features\UNIX_SOCKETS ] { 524288 }
+ Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.43.0 NSS/3.25 zlib/1.2.8 libidn/1.33 libssh2/1.6.0 nghttp2/1.7.1 }
+ Constant [ string http\Client\Curl\Versions\CURL ] { 7.43.0 }
+ Constant [ string http\Client\Curl\Versions\SSL ] { NSS/3.25 }
+ Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.8 }
Constant [ integer http\Client\Curl\HTTP_VERSION_1_0 ] { 1 }
Constant [ integer http\Client\Curl\HTTP_VERSION_1_1 ] { 2 }
Constant [ integer http\Client\Curl\HTTP_VERSION_2_0 ] { 3 }
@@ -48,7 +70,7 @@ Extension [ <persistent> extension #84 http version 3.0.1 ] {
Constant [ integer http\Client\Curl\POSTREDIR_ALL ] { 7 }
}
- - Classes [30] {
+ - Classes [31] {
Interface [ <internal:http> interface http\Exception ] {
- Constants [0] {
@@ -1826,7 +1848,13 @@ Extension [ <persistent> extension #84 http version 3.0.1 ] {
Class [ <internal:http> class http\Client implements SplSubject, Countable ] {
- - Constants [0] {
+ - Constants [6] {
+ Constant [ integer DEBUG_INFO ] { 0 }
+ Constant [ integer DEBUG_IN ] { 1 }
+ Constant [ integer DEBUG_OUT ] { 2 }
+ Constant [ integer DEBUG_HEADER ] { 16 }
+ Constant [ integer DEBUG_BODY ] { 32 }
+ Constant [ integer DEBUG_SSL ] { 64 }
}
- Static properties [0] {
@@ -1847,7 +1875,7 @@ Extension [ <persistent> extension #84 http version 3.0.1 ] {
Property [ <default> public $recordHistory ]
}
- - Methods [30] {
+ - Methods [31] {
Method [ <internal:http, ctor> public method __construct ] {
- Parameters [2] {
@@ -2049,6 +2077,13 @@ Extension [ <persistent> extension #84 http version 3.0.1 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:http> public method setDebug ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
+ }
}
}
@@ -2755,9 +2790,72 @@ Extension [ <persistent> extension #84 http version 3.0.1 ] {
}
}
+ Interface [ <internal:http> interface http\Client\Curl\User ] {
+
+ - Constants [5] {
+ Constant [ integer POLL_NONE ] { 0 }
+ Constant [ integer POLL_IN ] { 1 }
+ Constant [ integer POLL_OUT ] { 2 }
+ Constant [ integer POLL_INOUT ] { 3 }
+ Constant [ integer POLL_REMOVE ] { 4 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [6] {
+ Method [ <internal:http> abstract public method init ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $run ]
+ }
+ }
+
+ Method [ <internal:http> abstract public method timer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> integer $timeout_ms ]
+ }
+ }
+
+ Method [ <internal:http> abstract public method socket ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $socket ]
+ Parameter #1 [ <required> integer $action ]
+ }
+ }
+
+ Method [ <internal:http> abstract public method once ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http> abstract public method wait ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> integer $timeout_ms ]
+ }
+ }
+
+ Method [ <internal:http> abstract public method send ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
Class [ <internal:http> class http\Url ] {
- - Constants [17] {
+ - Constants [20] {
Constant [ integer REPLACE ] { 0 }
Constant [ integer JOIN_PATH ] { 1 }
Constant [ integer JOIN_QUERY ] { 2 }
@@ -2775,6 +2873,9 @@ Extension [ <persistent> extension #84 http version 3.0.1 ] {
Constant [ integer PARSE_MBUTF8 ] { 131072 }
Constant [ integer PARSE_TOIDN ] { 1048576 }
Constant [ integer PARSE_TOPCT ] { 2097152 }
+ Constant [ integer IGNORE_ERRORS ] { 268435456 }
+ Constant [ integer SILENT_ERRORS ] { 536870912 }
+ Constant [ integer STDFLAGS ] { 3350531 }
}
- Static properties [0] {
diff --git a/php-pecl-http-php7.spec b/php-pecl-http-php7.spec
index 8e5ecd7..6d2f671 100644
--- a/php-pecl-http-php7.spec
+++ b/php-pecl-http-php7.spec
@@ -22,7 +22,7 @@
%global gh_owner m6w6
%global gh_project ext-http
#global gh_date 20150928
-#global prever RC1
+%global prever beta2
# The project is pecl_http but the extension is only http
%global proj_name pecl_http
%global pecl_name http
@@ -38,12 +38,12 @@
#global prever RC1
Name: %{?sub_prefix}php-pecl-http
-Version: 3.0.1
+Version: 3.1.0
%if 0%{?gh_date:1}
Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.1.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{proj_name}-%{version}%{?prever}.tgz
%endif
Summary: Extended HTTP support
@@ -55,8 +55,6 @@ URL: http://pecl.php.net/package/pecl_http
# From http://www.php.net/manual/en/http.configuration.php
Source1: %{proj_name}.ini
-Patch0: %{proj_name}-upstream.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-hash
@@ -191,7 +189,6 @@ mv %{proj_name}-%{version}%{?prever} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p1 -b .upstream
extver=$(sed -n '/#define PHP_PECL_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:dev}"; then
@@ -366,6 +363,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Sep 7 2016 Remi Collet <remi@fedoraproject.org> - 3.1.0-0.1.beta2
+- Update to 3.1.0beta2 (php 7, beta)
+
* Wed Jun 8 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-2
- add upstream patch, fix test suite with PHP 7.1