summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-12-12 11:26:53 +0100
committerRemi Collet <fedora@famillecollet.com>2016-12-12 11:26:53 +0100
commit18f9f7160fc95a696338f56764bced59d656a402 (patch)
tree81f2b2a28622556f653f5a797767d41776806f07
parenta9a02ca93b42aa0f42243928ae7ea7b179069490 (diff)
php-pecl-http: 3.1.0 (php 7)
-rw-r--r--REFLECTION-PHP714
-rw-r--r--php-pecl-http-php7.spec19
2 files changed, 14 insertions, 19 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
index ec49d87..96fec44 100644
--- a/REFLECTION-PHP7
+++ b/REFLECTION-PHP7
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #145 http version 3.1.0RC1 ] {
+Extension [ <persistent> extension #153 http version 3.1.0 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -13,8 +13,8 @@ Extension [ <persistent> extension #145 http version 3.1.0RC1 ] {
}
}
- - Constants [53] {
- Constant [ integer http\Client\Curl\FEATURES ] { 1017757 }
+ - Constants [55] {
+ Constant [ integer http\Client\Curl\FEATURES ] { 2066333 }
Constant [ integer http\Client\Curl\Features\IPV6 ] { 1 }
Constant [ integer http\Client\Curl\Features\KERBEROS4 ] { 2 }
Constant [ integer http\Client\Curl\Features\KERBEROS5 ] { 262144 }
@@ -32,13 +32,15 @@ Extension [ <persistent> extension #145 http version 3.1.0RC1 ] {
Constant [ integer http\Client\Curl\Features\NTLM_WB ] { 32768 }
Constant [ integer http\Client\Curl\Features\HTTP2 ] { 65536 }
Constant [ integer http\Client\Curl\Features\UNIX_SOCKETS ] { 524288 }
- Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.43.0 NSS/3.26 zlib/1.2.8 libidn/1.33 libssh2/1.6.0 nghttp2/1.7.1 }
- Constant [ string http\Client\Curl\Versions\CURL ] { 7.43.0 }
- Constant [ string http\Client\Curl\Versions\SSL ] { NSS/3.26 }
+ Constant [ integer http\Client\Curl\Features\PSL ] { 1048576 }
+ Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.51.0 NSS/3.27 zlib/1.2.8 libidn2/0.11 libpsl/0.14.0 (+libidn2/0.10) libssh2/1.8.0 nghttp2/1.13.0 }
+ Constant [ string http\Client\Curl\Versions\CURL ] { 7.51.0 }
+ Constant [ string http\Client\Curl\Versions\SSL ] { NSS/3.27 }
Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.8 }
Constant [ integer http\Client\Curl\HTTP_VERSION_1_0 ] { 1 }
Constant [ integer http\Client\Curl\HTTP_VERSION_1_1 ] { 2 }
Constant [ integer http\Client\Curl\HTTP_VERSION_2_0 ] { 3 }
+ Constant [ integer http\Client\Curl\HTTP_VERSION_2TLS ] { 4 }
Constant [ integer http\Client\Curl\HTTP_VERSION_ANY ] { 0 }
Constant [ integer http\Client\Curl\SSL_VERSION_TLSv1 ] { 1 }
Constant [ integer http\Client\Curl\SSL_VERSION_TLSv1_0 ] { 4 }
diff --git a/php-pecl-http-php7.spec b/php-pecl-http-php7.spec
index b51cfd2..cd2bd2e 100644
--- a/php-pecl-http-php7.spec
+++ b/php-pecl-http-php7.spec
@@ -22,7 +22,7 @@
%global gh_owner m6w6
%global gh_project ext-http
#global gh_date 20150928
-%global prever RC1
+#global prever RC1
# The project is pecl_http but the extension is only http
%global proj_name pecl_http
%global pecl_name http
@@ -43,7 +43,7 @@ Version: 3.1.0
Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 0.5.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{proj_name}-%{version}%{?prever}.tgz
%endif
Summary: Extended HTTP support
@@ -55,7 +55,6 @@ URL: http://pecl.php.net/package/pecl_http
# From http://www.php.net/manual/en/http.configuration.php
Source1: %{proj_name}.ini
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-hash
BuildRequires: %{?scl_prefix}php-spl
@@ -191,15 +190,6 @@ mv %{proj_name}-%{version}%{?prever} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-# https://github.com/m6w6/ext-http/issues/53
-sed -e '/PHP_HTTP_CURL_VERSION/s/PHP_HTTP_HAVE_LIBCURL_TLSAUTH_TYPE/defined(PHP_HTTP_CURL_TLSAUTH_SRP)/' \
- -i src/php_http_client_curl.c
-
-%if 0%{?rhel} == 6
-# https://github.com/m6w6/ext-http/issues/54
-sed -e '/pragma/d' -i src/php_http_url.c
-%endif
-
extver=$(sed -n '/#define PHP_PECL_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:dev}"; then
: Error: Upstream HTTP version is now ${extver}, expecting %{version}%{?prever}%{?gh_date:dev}.
@@ -327,13 +317,13 @@ NO_INTERACTION=1 \
%endif
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
fi
-%if 0%{?fedora} < 24
# posttrans as pear can be installed after us
%posttrans
if [ -x %{__pecl} ] ; then
@@ -375,6 +365,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Dec 12 2016 Remi Collet <remi@fedoraproject.org> - 3.1.0-1
+- update to 3.1.0
+
* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 3.1.0-0.5.RC1
- rebuild with PHP 7.1.0 GA