summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-09 13:39:28 +0200
committerRemi Collet <remi@remirepo.net>2017-05-09 13:39:28 +0200
commit12c22845b5e6b2043af788a3839295e2686bcba0 (patch)
tree779b2794b5858c7f588aa5d5eeda7bacd3ed2a4a
parent19336b09dd7b483d9bb1086b4cc4ca33462dbb08 (diff)
switch away from libidn (only use libicu)
-rw-r--r--REFLECTION6
-rw-r--r--php-pecl-http.spec14
2 files changed, 14 insertions, 6 deletions
diff --git a/REFLECTION b/REFLECTION
index 96fec44..d9333f2 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #153 http version 3.1.0 ] {
+Extension [ <persistent> extension #168 http version 3.1.0 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -33,9 +33,9 @@ Extension [ <persistent> extension #153 http version 3.1.0 ] {
Constant [ integer http\Client\Curl\Features\HTTP2 ] { 65536 }
Constant [ integer http\Client\Curl\Features\UNIX_SOCKETS ] { 524288 }
Constant [ integer http\Client\Curl\Features\PSL ] { 1048576 }
- Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.51.0 NSS/3.27 zlib/1.2.8 libidn2/0.11 libpsl/0.14.0 (+libidn2/0.10) libssh2/1.8.0 nghttp2/1.13.0 }
+ Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.51.0 NSS/3.29.3 zlib/1.2.8 libidn2/2.0.2 libpsl/0.17.0 (+libidn2/0.11) libssh2/1.8.0 nghttp2/1.13.0 }
Constant [ string http\Client\Curl\Versions\CURL ] { 7.51.0 }
- Constant [ string http\Client\Curl\Versions\SSL ] { NSS/3.27 }
+ Constant [ string http\Client\Curl\Versions\SSL ] { NSS/3.29.3 }
Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.8 }
Constant [ integer http\Client\Curl\HTTP_VERSION_1_0 ] { 1 }
Constant [ integer http\Client\Curl\HTTP_VERSION_1_1 ] { 2 }
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 940a145..bf9ceb8 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -43,7 +43,7 @@ Version: 3.1.0
Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{proj_name}-%{version}%{?prever}.tgz
%endif
Summary: Extended HTTP support
@@ -62,7 +62,6 @@ BuildRequires: %{?scl_prefix}php-pear
BuildRequires: pcre-devel
BuildRequires: zlib-devel >= 1.2.0.4
BuildRequires: curl-devel >= 7.18.2
-BuildRequires: libidn-devel
# Use same version than PHP to ensure we use libicu-last (EL 6)
BuildRequires: libicu-devel >= 50
BuildRequires: %{?scl_prefix}php-pecl-propro-devel >= 2
@@ -186,11 +185,17 @@ peclconf() {
--with-http \
--with-http-zlib-dir=%{_root_prefix} \
--with-http-libcurl-dir=%{_root_prefix} \
- --with-http-libidn-dir=%{_root_prefix} \
+ --without-http-libidn-dir \
+ --without-http-libidn2-dir \
+ --without-http-libidnkit-dir \
+ --without-http-libidnkit2-dir \
+ --without-http-libidnkit-dir \
+ --without-http-libidnkit2-dir \
--with-http-libicu-dir=%{_root_prefix} \
--with-http-libevent-dir=%{_root_prefix} \
--with-libdir=%{_lib} \
--with-php-config=$1
+grep IDNA config.h
}
cd NTS
%{_bindir}/phpize
@@ -332,6 +337,9 @@ fi
%changelog
+* Tue May 9 2017 Remi Collet <remi@remirepo.net> - 3.1.0-4
+- drop dependency on libidn, only use libicu, #1449142
+
* Fri Apr 28 2017 Remi Collet <remi@fedoraproject.org> - 3.1.0-2
- add missing BR on openssl-devel for new libcurl (FTBFS from Koschei)
- ensure we use libevent2 on EL-6