summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-25 14:03:03 +0100
committerRemi Collet <remi@php.net>2022-02-25 14:03:03 +0100
commit0e161b9b0597cc7283f7ab605f35f46095cae8a0 (patch)
tree6da57228571119b44d7319c75276b29f2b7cb1f8
parentbba5177c29682881960c13bb8b9b6d984c7aafb9 (diff)
update to 3.2.5
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION10
-rw-r--r--pecl_http-upstream.patch46
-rw-r--r--php-pecl-http.spec12
4 files changed, 14 insertions, 62 deletions
diff --git a/PHPINFO b/PHPINFO
index 6b1fa79..bb614ed 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,13 +2,13 @@
http
HTTP Support => enabled
-Extension Version => 3.2.4
+Extension Version => 3.2.5
Used Library => Compiled => Linked
libz => 1.2.11 => 1.2.11
-libcurl => 7.71.1 => 7.71.1
-libevent => 2.1.8-stable => 2.1.8-stable
-libicu (IDNA2008/IDNA2003) => 67.1 => 67.1
+libcurl => 7.79.1 => 7.79.1
+libevent => 2.1.12-stable => 2.1.12-stable
+libicu (IDNA2008/IDNA2003) => 69.1 => 69.1
libidn2 (IDNA2008) => disabled => disabled
libidn (IDNA2003) => disabled => disabled
libidnkit2 (IDNA2008) => disabled => disabled
diff --git a/REFLECTION b/REFLECTION
index 60c7564..c231624 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #111 http version 3.2.4 ] {
+Extension [ <persistent> extension #153 http version 3.2.5 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #111 http version 3.2.4 ] {
}
- Constants [56] {
- Constant [ int http\Client\Curl\FEATURES ] { 12568477 }
+ Constant [ int http\Client\Curl\FEATURES ] { 297781149 }
Constant [ int http\Client\Curl\Features\IPV6 ] { 1 }
Constant [ int http\Client\Curl\Features\KERBEROS4 ] { 2 }
Constant [ int http\Client\Curl\Features\KERBEROS5 ] { 262144 }
@@ -33,9 +33,9 @@ Extension [ <persistent> extension #111 http version 3.2.4 ] {
Constant [ int http\Client\Curl\Features\HTTP2 ] { 65536 }
Constant [ int http\Client\Curl\Features\UNIX_SOCKETS ] { 524288 }
Constant [ int http\Client\Curl\Features\PSL ] { 1048576 }
- Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.71.1 OpenSSL/1.1.1i-fips zlib/1.2.11 brotli/1.0.9 libidn2/2.3.0 libpsl/0.21.1 (+libidn2/2.3.0) libssh/0.9.5/openssl/zlib nghttp2/1.41.0 }
- Constant [ string http\Client\Curl\Versions\CURL ] { 7.71.1 }
- Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/1.1.1i-fips }
+ Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.79.1 OpenSSL/1.1.1l-fips zlib/1.2.11 brotli/1.0.9 libidn2/2.3.2 libpsl/0.21.1 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.45.1 OpenLDAP/2.4.59 }
+ Constant [ string http\Client\Curl\Versions\CURL ] { 7.79.1 }
+ Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/1.1.1l-fips }
Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.11 }
Constant [ int http\Client\Curl\HTTP_VERSION_1_0 ] { 1 }
Constant [ int http\Client\Curl\HTTP_VERSION_1_1 ] { 2 }
diff --git a/pecl_http-upstream.patch b/pecl_http-upstream.patch
deleted file mode 100644
index ce8fbe0..0000000
--- a/pecl_http-upstream.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 798a561a0763cc92473e25238935242c2289fb98 Mon Sep 17 00:00:00 2001
-From: Michael Wallner <mike@php.net>
-Date: Mon, 21 Feb 2022 11:04:09 +0100
-Subject: [PATCH] fix recursive calls to curl_multi API from the user handler
-
----
- src/php_http_client_curl_user.c | 4 +---
- 1 file changed, 1 insertion(+), 3 deletions(-)
-
-diff --git a/src/php_http_client_curl_user.c b/src/php_http_client_curl_user.c
-index 1f69a51..95ea6f5 100644
---- a/src/php_http_client_curl_user.c
-+++ b/src/php_http_client_curl_user.c
-@@ -57,9 +57,7 @@ static void php_http_client_curl_user_timer(CURLM *multi, long timeout_ms, void
- fprintf(stderr, "\ntimer <- timeout_ms: %ld\n", timeout_ms);
- #endif
-
-- if (timeout_ms <= 0) {
-- php_http_client_curl_loop(context->client, CURL_SOCKET_TIMEOUT, 0);
-- } else {
-+ if (timeout_ms >= 0) {
- zval args[1], *ztimeout = &args[0];
-
- ZVAL_LONG(ztimeout, timeout_ms);
-From 2653f8b3a2bf9a6d9cded6ef46236de18a02ff77 Mon Sep 17 00:00:00 2001
-From: Michael Wallner <mike@php.net>
-Date: Mon, 21 Feb 2022 11:06:19 +0100
-Subject: [PATCH] fix recursive calls to curl_multi API from the event handler
-
----
- src/php_http_client_curl_event.c | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/src/php_http_client_curl_event.c b/src/php_http_client_curl_event.c
-index b8db1b2..2e663ed 100644
---- a/src/php_http_client_curl_event.c
-+++ b/src/php_http_client_curl_event.c
-@@ -97,8 +97,6 @@ static void php_http_client_curl_event_timer(CURLM *multi, long timeout_ms, void
- }
- break;
- case 0:
-- php_http_client_curl_event_handler(context, CURL_SOCKET_TIMEOUT, 0);
-- break;
- default:
- if (!event_initialized(context->timeout)) {
- event_assign(context->timeout, context->evbase, CURL_SOCKET_TIMEOUT, 0, php_http_client_curl_event_timeout_callback, context);
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index cbeae5d..99a55af 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -37,7 +37,7 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-%global upstream_version 3.2.4
+%global upstream_version 3.2.5
#global upstream_prever RC1
Name: %{?sub_prefix}php-pecl-http
@@ -57,11 +57,8 @@ URL: https://pecl.php.net/package/pecl_http
# From http://www.php.net/manual/en/http.configuration.php
Source1: %{proj_name}.ini
-# Upstream patches for recent libcurl
-Patch0: %{proj_name}-upstream.patch
-
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-hash
BuildRequires: %{?scl_prefix}php-spl
BuildRequires: %{?scl_prefix}php-pear
@@ -163,8 +160,6 @@ mv %{proj_name}-%{upstream_version}%{?upstream_prever} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p1 -b .up
-
extver=$(sed -n '/#define PHP_PECL_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:dev}"; then
: Error: Upstream HTTP version is now ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?gh_date:dev}.
@@ -350,6 +345,9 @@ fi
%changelog
+* Fri Feb 25 2022 Remi Collet <remi@remirepo.net> - 3.2.5-1
+- update to 3.2.5
+
* Fri Feb 25 2022 Remi Collet <remi@remirepo.net> - 3.2.4-3
- add upstream patch for recent libcurl