summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-08-03 09:19:30 +0200
committerRemi Collet <fedora@famillecollet.com>2014-08-03 09:19:30 +0200
commita0220e8b353fada21ac44fbcc9270c8e8419b4d8 (patch)
treeb6fc96a975b31ed392c69adb81564b5bdedcefac
parent7473ac2acfc0b30980506b869c86bb298edca982 (diff)
php-pecl-http: 2.1.0RC1 for remi-test
-rw-r--r--REFLECTION8
-rw-r--r--pecl_http-git.patch50
-rw-r--r--php-pecl-http.spec43
3 files changed, 93 insertions, 8 deletions
diff --git a/REFLECTION b/REFLECTION
index 1b9ff70..dccb741 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #164 http version 2.0.7 ] {
+Extension [ <persistent> extension #165 http version 2.1.0RC1 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -3533,15 +3533,17 @@ Extension [ <persistent> extension #164 http version 2.0.7 ] {
Class [ <internal:http> class http\Params implements ArrayAccess ] {
- - Constants [9] {
+ - Constants [11] {
Constant [ string DEF_PARAM_SEP ] { , }
Constant [ string DEF_ARG_SEP ] { ; }
Constant [ string DEF_VAL_SEP ] { = }
Constant [ string COOKIE_PARAM_SEP ] { }
Constant [ integer PARSE_RAW ] { 0 }
- Constant [ integer PARSE_DEFAULT ] { 1 }
+ Constant [ integer PARSE_ESCAPED ] { 1 }
Constant [ integer PARSE_URLENCODED ] { 4 }
Constant [ integer PARSE_DIMENSION ] { 8 }
+ Constant [ integer PARSE_RFC5987 ] { 16 }
+ Constant [ integer PARSE_DEFAULT ] { 17 }
Constant [ integer PARSE_QUERY ] { 12 }
}
diff --git a/pecl_http-git.patch b/pecl_http-git.patch
new file mode 100644
index 0000000..9decea5
--- /dev/null
+++ b/pecl_http-git.patch
@@ -0,0 +1,50 @@
+From b08a238775e998bb07b530c3cd80219e100c95cf Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Sat, 2 Aug 2014 17:50:00 +0200
+Subject: [PATCH] set always_populate_raw_post_data=-1 to avoid failed test
+ (because of warning)
+
+---
+ tests/message002.phpt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tests/message002.phpt b/tests/message002.phpt
+index f782f8f..403fb26 100644
+--- a/tests/message002.phpt
++++ b/tests/message002.phpt
+@@ -9,6 +9,8 @@ b=c
+ HTTP_X_TEST=test
+ --COOKIE--
+ foo=bar
++--INI--
++always_populate_raw_post_data=-1
+ --FILE--
+ <?php
+ echo "Test\n";
+--
+1.9.2
+
+From 400771d35709df29e48f4ca43551d40beac108e9 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Sat, 2 Aug 2014 17:50:41 +0200
+Subject: [PATCH] slip online test
+
+---
+ tests/client010.phpt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tests/client010.phpt b/tests/client010.phpt
+index 803403f..055d585 100644
+--- a/tests/client010.phpt
++++ b/tests/client010.phpt
+@@ -3,6 +3,7 @@ client upload
+ --SKIPIF--
+ <?php
+ include "skipif.inc";
++skip_online_test();
+ ?>
+ --FILE--
+ <?php
+--
+1.9.2
+
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 3bba98a..cd84540 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -24,10 +24,12 @@
# after 40-json 20-iconv 40-propro 40-raphf
%global ini_name 50-%{pecl_name}.ini
%endif
+%global prever RC1
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: %{?scl_prefix}php-pecl-http
-Version: 2.0.7
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 2.1.0
+Release: 0.1.RC1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Summary: Extended HTTP support
License: BSD
@@ -38,6 +40,9 @@ Source0: http://pecl.php.net/get/%{proj_name}-%{version}%{?prever}.tgz
# From http://www.php.net/manual/en/http.configuration.php
Source1: %{proj_name}.ini
+# Upstream patches
+Patch0: %{proj_name}-git.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel >= 5.3.0
BuildRequires: %{?scl_prefix}php-hash
@@ -165,6 +170,8 @@ These are the files needed to compile programs using HTTP extension.
mv %{proj_name}-%{version}%{?prever} NTS
cd NTS
+%patch0 -p1 -b .git
+
extver=$(sed -n '/#define PHP_PECL_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
: Error: Upstream HTTP version is now ${extver}, expecting %{version}%{?prever}.
@@ -235,22 +242,44 @@ done
modules=""
for mod in json hash iconv propro raphf; do
if [ -f %{php_extdir}/${mod}.so ]; then
- modules="$modules --define extension=${mod}.so"
+ modules="$modules -d extension=${mod}.so"
fi
done
: Minimal load test for NTS extension
%{__php} --no-php-ini \
$modules \
- --define extension=$PWD/NTS/modules/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
+%if %{with_tests}
+: Upstream test suite NTS extension
+cd NTS
+SKIP_ONLINE_TESTS=1 \
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n $modules -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff
+%endif
+
%if %{with_zts}
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
$modules \
- --define extension=$PWD/ZTS/modules/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite ZTS extension
+cd ../ZTS
+SKIP_ONLINE_TESTS=1 \
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n $modules -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=0 \
+%{__ztsphp} -n run-tests.php --show-diff
+%endif
%endif
@@ -291,6 +320,10 @@ rm -rf %{buildroot}
%changelog
+* Sat Aug 02 2014 Remi Collet <remi@fedoraproject.org> - 2.1.0-0.1.RC1
+- Update to 2.1.0RC1
+- run test suite during build
+
* Fri Jul 11 2014 Remi Collet <remi@fedoraproject.org> - 2.0.7-1
- Update to 2.0.7