summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-14 16:06:44 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-14 16:06:44 +0100
commit5a7cc06adf88d2caafe1a16a685e2ed8eb30d9a4 (patch)
treefad94d47a184661b686a0e70c7133e6710ab06f3
parent43904cb3031ba46c8e7847e53e4efd321d3bf10f (diff)
php-pecl-http: add patch + cleanups
-rw-r--r--http-curl.patch18
-rw-r--r--php-pecl-http.spec4
2 files changed, 21 insertions, 1 deletions
diff --git a/http-curl.patch b/http-curl.patch
new file mode 100644
index 0000000..b98b612
--- /dev/null
+++ b/http-curl.patch
@@ -0,0 +1,18 @@
+--- pecl_http-2.0.0beta3/php_http_curl_client.c.old 2012-12-13 18:57:02.000000000 +0100
++++ pecl_http-2.0.0beta3/php_http_curl_client.c 2012-12-13 18:57:05.000000000 +0100
+@@ -642,6 +642,7 @@
+ return SUCCESS;
+ }
+
++#if PHP_HTTP_CURL_VERSION(7,21,3)
+ static STATUS php_http_curl_client_option_set_resolve(php_http_option_t *opt, zval *val, void *userdata)
+ {
+ php_http_client_t *h = userdata;
+@@ -670,6 +671,7 @@
+ }
+ return SUCCESS;
+ }
++#endif
+
+ static void php_http_curl_client_options_init(php_http_options_t *registry TSRMLS_DC)
+ {
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 634caa7..0d60423 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -143,7 +143,7 @@ install -Dpm644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/z-%{pecl_name}.ini
%check
-# Minimal load test for NTS extension
+# Install needed extensions
modules=""
for mod in json hash iconv; do
if [ -f %{php_extdir}/${mod}.so ]; then
@@ -152,6 +152,8 @@ for mod in json hash iconv; do
modules="$modules --define extension=${mod}.so"
fi
done
+
+# Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension_dir=%{proj_name}-%{version}%{?prever}/modules \
$modules \