summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-21 13:34:18 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-21 13:34:18 +0100
commit2c97fd7b481e0d2b93b575cfc8dd9ce98eab2c54 (patch)
treeb3c08d49abb5c8010382ea3bca5d98e02596d41a
parentea1f86e8ad88fff3f913b1ff6b6d33ca2263e3bc (diff)
php-pecl-http: fix build with php 5.5.0beta1
-rw-r--r--php-pecl-http-php55.patch43
-rw-r--r--php-pecl-http.spec7
2 files changed, 49 insertions, 1 deletions
diff --git a/php-pecl-http-php55.patch b/php-pecl-http-php55.patch
new file mode 100644
index 0000000..8f5c3a6
--- /dev/null
+++ b/php-pecl-http-php55.patch
@@ -0,0 +1,43 @@
+diff -ru pecl_http-zts/php_http_client_datashare.c pecl_http-2.0.0beta4/php_http_client_datashare.c
+--- pecl_http-zts/php_http_client_datashare.c 2013-03-21 12:54:46.601262693 +0100
++++ pecl_http-2.0.0beta4/php_http_client_datashare.c 2013-03-21 13:17:05.103056205 +0100
+@@ -261,7 +261,7 @@
+ return &php_http_property_proxy_init(NULL, object, member, NULL TSRMLS_CC)->myself;
+ }
+
+- return zend_get_std_object_handlers()->get_property_ptr_ptr(object, member PHP_HTTP_ZEND_LITERAL_CC TSRMLS_CC);
++ return zend_get_std_object_handlers()->get_property_ptr_ptr(object, member PHP_HTTP_ZEND_LITERAL_TCC TSRMLS_CC);
+ }
+
+
+diff -ru pecl_http-zts/php_http_message.c pecl_http-2.0.0beta4/php_http_message.c
+--- pecl_http-zts/php_http_message.c 2012-12-31 12:54:50.000000000 +0100
++++ pecl_http-2.0.0beta4/php_http_message.c 2013-03-21 13:16:47.435992961 +0100
+@@ -1097,7 +1097,7 @@
+ }
+ zval_ptr_dtor(&copy);
+
+- return zend_get_std_object_handlers()->get_property_ptr_ptr(object, member PHP_HTTP_ZEND_LITERAL_CC TSRMLS_CC);
++ return zend_get_std_object_handlers()->get_property_ptr_ptr(object, member PHP_HTTP_ZEND_LITERAL_TCC TSRMLS_CC);
+ }
+
+ static zval *php_http_message_object_read_prop(zval *object, zval *member, int type PHP_HTTP_ZEND_LITERAL_DC TSRMLS_DC)
+diff -ru pecl_http-zts/php_http_misc.h pecl_http-2.0.0beta4/php_http_misc.h
+--- pecl_http-zts/php_http_misc.h 2012-12-31 12:54:50.000000000 +0100
++++ pecl_http-2.0.0beta4/php_http_misc.h 2013-03-21 13:16:07.416849571 +0100
+@@ -128,6 +128,7 @@
+ # define PHP_HTTP_ZEND_LITERAL_DC
+ # define PHP_HTTP_ZEND_LITERAL_CC
+ # define PHP_HTTP_ZEND_LITERAL_CCN
++# define PHP_HTTP_ZEND_LITERAL_TCC
+ # define ZVAL_COPY_VALUE(zv, arr) do { \
+ (zv)->value = (arr)->value; \
+ Z_TYPE_P(zv) = Z_TYPE_P(arr); \
+@@ -136,6 +137,7 @@
+ # define PHP_HTTP_ZEND_LITERAL_DC , const zend_literal *literal_key
+ # define PHP_HTTP_ZEND_LITERAL_CC , (literal_key)
+ # define PHP_HTTP_ZEND_LITERAL_CCN , NULL
++# define PHP_HTTP_ZEND_LITERAL_TCC , BP_VAR_RW , (literal_key)
+ #endif
+
+ #define INIT_PZVAL_ARRAY(zv, ht) \
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 14b6ddb..acb59e8 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -7,7 +7,7 @@
Name: php-pecl-http
Version: 2.0.0
-Release: 0.14.%{prever}%{?dist}.2
+Release: 0.15.%{prever}%{?dist}
Summary: Extended HTTP support
License: BSD
@@ -20,6 +20,7 @@ Source1: %{proj_name}.ini
# fix memset arg order
Patch1: %{name}-build.patch
+Patch2: %{name}-php55.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: php-devel >= 5.3.0
@@ -98,6 +99,7 @@ These are the files needed to compile programs using HTTP extension.
cd %{proj_name}-%{version}%{?prever}
%patch1 -p0 -b .build
+%patch2 -p1 -b .php55
extver=$(sed -n '/#define PHP_HTTP_EXT_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -197,6 +199,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Mar 21 2013 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.15.beta4
+- fix build with php 5.5.0beta1
+
* Sun Dec 31 2012 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.14.beta4
- update to 2.0.0beta4