summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-31 15:12:21 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-31 15:12:21 +0100
commit24ade3b04d8ed7c282518ae319b998d9223b84dc (patch)
tree88623e47555ba01a7117e5b963e2b65f071c9ce5
parent0a2635a817797099ca5d7ab204b0b2dffb92b6f0 (diff)
php-pecl-http 2.0.0beta4
-rw-r--r--http-curl.patch18
-rw-r--r--php-pecl-http-build.patch13
-rw-r--r--php-pecl-http.spec14
3 files changed, 21 insertions, 24 deletions
diff --git a/http-curl.patch b/http-curl.patch
deleted file mode 100644
index b98b612..0000000
--- a/http-curl.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- pecl_http-2.0.0beta3/php_http_curl_client.c.old 2012-12-13 18:57:02.000000000 +0100
-+++ pecl_http-2.0.0beta3/php_http_curl_client.c 2012-12-13 18:57:05.000000000 +0100
-@@ -642,6 +642,7 @@
- return SUCCESS;
- }
-
-+#if PHP_HTTP_CURL_VERSION(7,21,3)
- static STATUS php_http_curl_client_option_set_resolve(php_http_option_t *opt, zval *val, void *userdata)
- {
- php_http_client_t *h = userdata;
-@@ -670,6 +671,7 @@
- }
- return SUCCESS;
- }
-+#endif
-
- static void php_http_curl_client_options_init(php_http_options_t *registry TSRMLS_DC)
- {
diff --git a/php-pecl-http-build.patch b/php-pecl-http-build.patch
new file mode 100644
index 0000000..f6b30bf
--- /dev/null
+++ b/php-pecl-http-build.patch
@@ -0,0 +1,13 @@
+Index: php_http_client_datashare.c
+===================================================================
+--- php_http_client_datashare.c (révision 328937)
++++ php_http_client_datashare.c (copie de travail)
+@@ -22,7 +22,7 @@
+ if (!h) {
+ free_h = h = emalloc(sizeof(*h));
+ }
+- memset(h, sizeof(*h), 0);
++ memset(h, 0, sizeof(*h));
+
+ zend_llist_init(&h->clients, sizeof(zval *), ZVAL_PTR_DTOR, 0);
+ h->ops = ops;
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 67e2d5a..6b1e0c0 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -3,11 +3,11 @@
# The project is pecl_http but the extension is only http
%global proj_name pecl_http
%global pecl_name http
-%global prever beta3
+%global prever beta4
Name: php-pecl-http
Version: 2.0.0
-Release: 0.13.%{prever}%{?dist}.2
+Release: 0.14.%{prever}%{?dist}.1
Summary: Extended HTTP support
License: BSD
@@ -18,9 +18,8 @@ Source0: http://pecl.php.net/get/%{proj_name}-%{version}%{?prever}.tgz
# From http://www.php.net/manual/en/http.configuration.php
Source1: %{proj_name}.ini
-# Fix for curl version older than 7.21.3
-# http://svn.php.net/viewvc?view=revision&revision=328773
-Patch0: %{pecl_name}-curl.patch
+# fix memset arg order
+Patch1: %{name}-build.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: php-devel >= 5.3.0
@@ -98,7 +97,7 @@ These are the files needed to compile programs using HTTP extension.
%setup -c -q
cd %{proj_name}-%{version}%{?prever}
-%patch0 -p1 -b .oldcurl
+%patch1 -p0 -b .build
extver=$(sed -n '/#define PHP_HTTP_EXT_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -198,6 +197,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Dec 31 2012 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.14.beta4
+- update to 2.0.0beta4
+
* Thu Dec 13 2012 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.13.beta3
- update to 2.0.0beta3