summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION28
-rw-r--r--php-pecl-http-message.spec8
3 files changed, 34 insertions, 4 deletions
diff --git a/PHPINFO b/PHPINFO
index 451cdcc..6ad83ca 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,4 +1,4 @@
http_message
-Version => 0.2.0
+Version => 0.2.1
diff --git a/REFLECTION b/REFLECTION
index a8b5afb..3513d9c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,10 +1,10 @@
-Extension [ <persistent> extension #191 http_message version 0.2.0 ] {
+Extension [ <persistent> extension #192 http_message version 0.2.1 ] {
- Dependencies {
Dependency [ psr (Required) ]
}
- - Classes [8] {
+ - Classes [9] {
Class [ <internal:http_message> abstract class HttpMessage\Message implements Psr\Http\Message\MessageInterface ] {
- Constants [0] {
@@ -1025,6 +1025,30 @@ Extension [ <persistent> extension #191 http_message version 0.2.0 ] {
}
}
}
+
+ Class [ <internal:http_message> class HttpMessage\Emitter ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:http_message> public method emit ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> Psr\Http\Message\ResponseInterface $serverParams ]
+ }
+ }
+ }
+ }
}
}
diff --git a/php-pecl-http-message.spec b/php-pecl-http-message.spec
index 519e555..fbcd0d7 100644
--- a/php-pecl-http-message.spec
+++ b/php-pecl-http-message.spec
@@ -20,7 +20,7 @@
Summary: PSR-7 HTTP Message implementation
Name: %{?sub_prefix}php-pecl-http-message
-Version: 0.2.0
+Version: 0.2.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
@@ -202,6 +202,9 @@ cd ../ZTS
--modules | grep %{pecl_name}
%if %{with_tests}
+: Ignore tests using CGI
+rm -r tests/Emitter
+
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
@@ -235,6 +238,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Nov 7 2019 Remi Collet <remi@remirepo.net> - 0.2.1-1
+- update to 0.2.1
+
* Thu Sep 5 2019 Remi Collet <remi@remirepo.net> - 0.2.0-1
- update to 0.2.0