summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-22 14:43:42 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-22 14:43:42 +0200
commitfbc6f0e5edc09af9ae0226f77b59d7ffc3a76858 (patch)
treeb1ee728ab8bf266040f64c3448e153704b34bef5
php-pecl-hrtime: 0.4.3 - New package
-rw-r--r--Makefile4
-rw-r--r--hrtime-svn.patch61
-rw-r--r--php-pecl-hrtime.spec212
3 files changed, 277 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/hrtime-svn.patch b/hrtime-svn.patch
new file mode 100644
index 0000000..5efc701
--- /dev/null
+++ b/hrtime-svn.patch
@@ -0,0 +1,61 @@
+--- pecl/hrtime/trunk/tests/001.phpt 2014/04/22 09:35:46 333402
++++ pecl/hrtime/trunk/tests/001.phpt 2014/04/22 11:33:51 333403
+@@ -11,13 +11,11 @@
+ $c = new HRTime\StopWatch;
+
+ $t0 = microtime(true);
+- for ($i = 0; $i < 1024; $i++);
+- $t1 = microtime(true);
+- $elapsed0 = $t1 - $t0;
+-
+ $c->start();
+- for ($i = 0; $i < 1024; $i++);
++ for ($i = 0; $i < (1024*1024); $i++);
++ $t1 = microtime(true);
+ $c->stop();
++ $elapsed0 = $t1 - $t0;
+
+ $e0 = $elapsed0;
+ $e1 = $c->getLastElapsedTime(HRTime\Unit::SECOND);
+--- pecl/hrtime/trunk/tests/004.phpt 2014/04/22 09:35:46 333402
++++ pecl/hrtime/trunk/tests/004.phpt 2014/04/22 11:33:51 333403
+@@ -11,13 +11,11 @@
+ $c = new HRTime\StopWatch;
+
+ $t0 = microtime(true);
+- usleep(1);
+- $t1 = microtime(true);
+- $elapsed0 = $t1 - $t0;
+-
+ $c->start();
+ usleep(1);
++ $t1 = microtime(true);
+ $c->stop();
++ $elapsed0 = $t1 - $t0;
+
+ $e0 = $elapsed0;
+ $e1 = $c->getLastElapsedTime(HRTime\Unit::SECOND);
+===================================================================
+--- pecl/hrtime/trunk/config.m4 (révision 333402)
++++ pecl/hrtime/trunk/config.m4 (copie de travail)
+@@ -7,6 +7,7 @@
+ [ --enable-hrtime Enable hrtime support])
+
+ if test "$PHP_HRTIME" != "no"; then
+- PHP_ADD_LIBRARY(rt)
++ PHP_ADD_LIBRARY(rt,,HRTIME_SHARED_LIBADD)
++ PHP_SUBST(HRTIME_SHARED_LIBADD)
+ PHP_NEW_EXTENSION(hrtime, hrtime.c timer.c, $ext_shared)
+ fi
+===================================================================
+--- pecl/hrtime/trunk/timer.h (révision 333402)
++++ pecl/hrtime/trunk/timer.h (copie de travail)
+@@ -75,3 +75,8 @@
+ \return Current timestamp, in milliseconds */
+ TIMER_API tick_t timer_system( void );
+
++/* Compatibility stuff for php < 5.3.7*/
++#ifndef PHP_FE_END
++#define PHP_FE_END {NULL, NULL, NULL}
++#endif
++
diff --git a/php-pecl-hrtime.spec b/php-pecl-hrtime.spec
new file mode 100644
index 0000000..cedfe11
--- /dev/null
+++ b/php-pecl-hrtime.spec
@@ -0,0 +1,212 @@
+# spec file for php-pecl-hrtime
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-pecl-hrtime}
+%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
+%{!?__pecl: %global __pecl %{_bindir}/pecl}
+%{!?__php: %global __php %{_bindir}/php}
+
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name hrtime
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+
+Summary: High resolution timing
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 0.4.3
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: BSD
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+# http://svn.php.net/viewvc?view=revision&revision=333403
+# http://svn.php.net/viewvc?view=revision&revision=333405
+Patch0: %{pecl_name}-svn.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: %{?scl_prefix}php-devel > 5.2
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?vendor}" == "Remi Collet"
+# Other third party repo stuff
+%if "%{php_version}" > "5.4"
+Obsoletes: php53-pecl-%{pecl_name}
+Obsoletes: php53u-pecl-%{pecl_name}
+Obsoletes: php54-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+The extension implements a high resolution StopWatch class.
+It uses the the best possible APIs on different platforms.
+It also makes possible to implement a custom stopwatch using
+low level ticks delivered by the underlaying APIs.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+cd NTS
+%patch0 -p3 -b .svn
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_HRTIME_VERSION/{s/.* "//;s/".*$//;p}' php_hrtime.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable '%{summary}' extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS \
+ install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS \
+ install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Test & Documentation
+for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
+done
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%check
+# Too fast, not reliable
+rm ?TS/tests/004.phpt
+
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/zts-php -n run-tests.php
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pecl_docdir}/%{pecl_name}
+%doc %{pecl_testdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Tue Apr 22 2014 Remi Collet <remi@fedoraproject.org> - 0.4.3-1
+- initial package, version 0.4.3 (beta) \ No newline at end of file